Permisos y Crear Carpetas con debían 9 stretch y Emby Server

2 envíos / 0 nuevos
Último envío
#1 Mar, 24/12/2019 - 13:19
ELTANO4D
Imagen de ELTANO4D
Desconectado/a
se unió: 14/12/19

Permisos y Crear Carpetas con debían 9 stretch y Emby Server

Estado: 
[ACTIVO]

Hola, buenos días.

Soy nuevo utilizando Debian 9 Stretch. ¿Porque no usas la aversión 10? pues porque para lo que lo voy a utilizar me es mas confiable el 9 ya que es mucho mas estable que el v10 por el momento.

Les comento mi idea y cuales son los problemas que estoy teniendo.

Estoy estudiando Linux Expert en CENTRALTECH. Para pasar de año tengo que armar y preparar un servidor de VOD con Linus Debían 9 Stretch.

Para tal prueba cuento con una CPU Dual Core 2.66mhz, RAM 4GB 800mhz, un HHD 120gb SATA "donde ira montado debían y otro HDD de 1TB SATA, a donde irán las Películas y Series.

1) Instalar debian en el HDD 120gb.
2) Montar el HHD 1TB.
3) Darle permisos de usuario y grupo Escritura y Lectura.
----------------------------------------------------------------

Lo que realice hasta ahora.

1) Instale debían 9 stretch en el HDD 120GB.
    /raiz = 10gb
    /sawp = 8192gb
    /home = 101gb

2) Monto el HHD 1tb.
    fdisk -l
    fdisk /deb/adb    
    fdsik -m
    n = Agregar nueva partición
    p = Elijo (1-4) 1.
    Elijo el tamaño total. Enter
    +931,5G de tamaño
    w = Guardo y salgo.

    mkdir /media/Emby_Server

3) ahora le doy permisos
    chmod ug+rw /media/Emby_Server    ej: drw-rw-r-- (root root) Así quedaría el tema de permisos)
----------------------------------------------------------------------------------------
Hasta acá debiera andar fantástico, y al instalar Emby Server, y configurarlo en la opción donde elijo las carpetas donde estarían las películas y series, debería llegar hasta la siguiente carpeta. ej:"/media/Emby_Server pero todo lo contrario, /media/diego

Cuando voy a equipos, y entro al HDD montado, para crear las carpetas, me indica que no poseo los permisos que corresponden.

¿Donde estaría el error? llevo dos semanas configurando etc, y nada.

Alguien puede ayudarme y guiarme para resolver el problema, desde ya muchas gracias a todos.

saludos, felices fiestas.

 

ELTANO

 

 

PD: No sabría donde poner mi post. mil disculpas.

Mar, 24/12/2019 - 14:19
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

¿ que te dice ?

ls -l /media/Emby_Server

¿creaste el directorio como root? 

¿Tu usuario esta en el grupo root o cual ?

Si vos queres que tu usuario tenga permisos sobre un directorio , o bien tu usuario crea el directorio , o bien lo crea root y luego le asignas ese directorio a dicho usuario ( cambias de dueño) o  creas un grupo que incluya al creador del directorio y a tu usuario , y le asignas ese directorio a dicho grupo ,.Luego claro  le pones los permisos que necesites al directorio respecto a usuario/grupo.

Por cierto para crear directorios dale también permiso de  ejecución , chmod +x 

Lectura 

Mas lectura 

Mucho mas lectura