Portatil a suspensión cada X segundos

19 envíos / 0 nuevos
Último envío
#1 Jue, 09/06/2016 - 09:42
Dynamost
Imagen de Dynamost
Desconectado/a
se unió: 09/06/16

Portatil a suspensión cada X segundos

Estado: 
[ACTIVO]

Hola a todos/ as

Os voy a exponer mi problemilla a ver si entre todos conseguimos dar con el secreto. A mi me trae ya de cabeza.

   El caso es que estoy llevo intentando instalar Debian 8.4.0 tanto XFCE como LXDE y  lo consigo instalar sin que me dé ningún problema.

   El motivo de confusión llega cuando al estar portatil (viejo, pero que cumple requisitos) encendido unos minutos y sin que me de tiempo si quiera a agregar los repos.. al "sources. list" el mismo portatil entra en modo suspensión cada X segundos en cortos intervalos de tiempo , así como así, por la cara.

   Lo curioso es que intenté también instalar el "AV Linux 2016 con kernel RT" y me ocurría lo mismo . Algo que con "LinuX Musix, basado en Wheezy, también con Kernel RT" no me sucede.

   La última vez que lo instalé desde el modo experto (ya lo había intentado de todas las demás formas) recuerdo que cambié el Kernel al mismo que trae la ISO de la instalación pero que acababa en (i586) por probar ya que me dijo alguien en un foro que probara con "backports" pero es que no me da ni tiempo a agregar los repositorios , y en el modo rescate que me da a elegir en la pantalla de carga no sé como activar la red.

 

    Así estoy pues, perdonad mi falta de tecnicismos en algunos puntos de la explicación pero es que estoy comenzando en Debian y estoy pegáo.

 Salu2, vamos hablando si os apetece.

Jue, 09/06/2016 - 11:53
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

¿que significa que no sabes activar la red ? 

Jue, 09/06/2016 - 11:57
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

Te faltaría poner las especificaciones de hardware de tu portátil como marca, modelo, etc. y completar: "Poner información del hardware aquí" con la info de lshw -short y de lsb_release -a (para usar lshw su apt-get update && apt-get install lshw)
 

Jue, 09/06/2016 - 12:19 (Responder a #3)
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

caliban wrote:

¿que significa que no sabes activar la red ? 

En modo rescate para activar el servicio de red

systemctl start NetworkManager.service

 

Jue, 09/06/2016 - 13:21
Dynamost
Imagen de Dynamost
Desconectado/a
se unió: 09/06/16

Hola y gracias por las rápidas respuestas.

El comando "lshw -short" me tiró:

H/W path             Device     Class          Description
==========================================================
                                system         Computer
/0                              bus            TravelMate 240
/0/0                            memory         117KiB BIOS
/0/4                            processor      Intel(R) Pentium(R) 4 CPU 2.50GHz
/0/4/8                          memory         8KiB L1 cache
/0/4/9                          memory         512KiB L2 cache
/0/17                           memory         1280MiB System Memory
/0/17/0                         memory         1GiB SODIMM DDR Synchronous
/0/17/1                         memory         256MiB SODIMM DDR Synchronous
/0/100                          bridge         82852/82855 GM/GME/PM/GMV Processor to I/O Controller
/0/100/0.1                      generic        82852/82855 GM/GME/PM/GMV Processor to I/O Controller
/0/100/0.3                      generic        82852/82855 GM/GME/PM/GMV Processor to I/O Controller
/0/100/2                        display        82852/855GM Integrated Graphics Device
/0/100/2.1                      display        82852/855GM Integrated Graphics Device
/0/100/1d                       bus            82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1
/0/100/1d.1                     bus            82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2
/0/100/1d.2                     bus            82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3
/0/100/1d.7                     bus            82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller
/0/100/1e                       bridge         82801 Mobile PCI Bridge
/0/100/1e/4                     bridge         PCI1520 PC card Cardbus Controller
/0/100/1e/4.1                   bridge         PCI1520 PC card Cardbus Controller
/0/100/1e/a          eth0       network        RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
/0/100/1f                       bridge         82801DBM (ICH4-M) LPC Interface Bridge
/0/100/1f.1                     storage        82801DBM (ICH4-M) IDE Controller
/0/100/1f.1/0        ide0       bus            IDE Channel 0
/0/100/1f.1/0/0      /dev/hda   disk           60GB FUJITSU MHT2060AT
/0/100/1f.1/0/0/1    /dev/hda1  volume         19GiB Windows NTFS volume
/0/100/1f.1/0/0/2    /dev/hda2  volume         14GiB Linux filesystem partition
/0/100/1f.1/0/0/3    /dev/hda3  volume         21GiB Extended partition
/0/100/1f.1/0/0/3/5  /dev/hda5  volume         20GiB Linux filesystem partition
/0/100/1f.1/0/0/3/6  /dev/hda6  volume         1349MiB Linux swap / Solaris partition
/0/100/1f.1/1        ide1       bus            IDE Channel 1
/0/100/1f.1/1/0      /dev/hdc   disk           QSI CD-RW/DVD-ROM SBW-242
/0/100/1f.1/1/0/0    /dev/hdc   disk           
/0/100/1f.3                     bus            82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller
/0/100/1f.5                     multimedia     82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
/0/100/1f.6                     communication  82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller
/1                              system         
/2                   wlan0      network        Wireless interface

¿?

El "lsb_release -a" no me lo reconoce y me escupe "bash: lsb_release: no se encontró la orden".

 

Con respecto a la activacion de la red: me refería a que no podia iniciar el wicd de ninguna de las maneras. Pero quizás o seguramente este comando que me habeis escrito arriba solucione la papeleta.

 

Ahora voy a agregar repositorios y dejarlo a punto como he visto en alguna web, si consigo conectar al Wifi. Después hare Upgrade y os comentaré como ha ido.

 

Si habeis visto algo inusual por ahí arriba, por favor comentadme

 

Gracias de nuevo, Salu2

Jue, 09/06/2016 - 13:33
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Asegurate de que solo tengas un gestor de conexiones o wicd, o networkmanager. Y si vas a usar cualquiera de los dos no tengas configuraciones agregadas (por vos ) en el archivo de interfaces para evitar conflictos .

Jue, 09/06/2016 - 13:57
Dynamost
Imagen de Dynamost
Desconectado/a
se unió: 09/06/16

El comando funcionó con Wicd era el único servicio que tenía pero no he podido hacer nada ya que sigue entrando en suspensión, se desconecta el gestor y no tengo tiempo para instalar nada.

    Alguien sabe dealgún software para poder capturar el "systemctl log" y pegarlo por aquí para que veais que me lanza ?

    Aun no sé nadie con el mismo problema que yo. Creo que tendré que darme por vencido. Debian 8 no es para mi :(

    Salu2

Jue, 09/06/2016 - 14:18
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Fijate si como root te da tiempo a anular la suspención 

systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target

No tengo una laptop no puedo probar, Otra cosa que se me ocurre, es instalar lo basico del sistema hacer los cambios que te hagan falta y luego instalar el resto incluida la parte gráfica 

Jue, 09/06/2016 - 15:58
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 Hola a todos.

 

 A lo mejor estoy "meando fuera de sitio", pero de repente me ha saltado una idea, colgada de una duda.

 

 ¿Seguro que es una suspensión?, no vaya a ser algún tipo de cierre forzado, que aprovecha la suspensión para conservar los datos.

  Me refiero por ejemplo a casos como que haya polvo y se recaliente, o haya un problema de ventilación, (¿se oyen los ventiladores?,

  ¿sale aire caliente del portátil?).

 Una prueba: ¿te funciona bien con otros sistemas operativos, u otras distribuciones de linux?, (prueba algún live cd de otra distro).

 Y ahora que hablo de ello,  esto me recuerda el caso de hace unos años, en que pillé un live cd de linux, (creo que era un live-cd de movix),

 que en uno de los portátiles, al minuto o dos de haber empezado se cortaba por las buenas, como si hubieran quitado la correinte.

 Después de haber investigado y probado un poco, me di cuenta de que arrancaba bien, pero cuando esa distro tomaba el control

 el ventilador no giraba.

 Al cabo de nada se protegia por sobrecalentamiento. (Y si lo encendias, normal, a continuación, salia un aire como para decapar pintura laugh)

 

 Comprueba los puntos mencionados, pues si me dices que se cierra a los 5 minutos, puede ser, pero a segundos del inicio, y

 por suspensión, me parece un poco raro.

 

 Ah, mira también si puedes los logs, a ver si hay alguna alarma, algún error, o si aparece quién ha mandado entrar en suspensión.

 

 Saludos a todos.

 

Jue, 09/06/2016 - 22:01
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

Habre una consola TTY {Ctrl + Alt + F1 ... o F2, o F3 etc.}, logueate con la cuenta de root {contraseña de root}, actualiza el sistema a Debian Jessie 8.5, terminada la operación, edita el {/etc/systemd/logind.conf} ... Descomenta o agrega lo siguiente:

 

[...]

HandlePowerKey=ignore
HandleSuspendKey=ignore
HandleHibernateKey=ignore
HandleLidSwitch=ignore

[...]

Reiniciar el sistema.

Saludos.

PD: Si ves algún cambio, observa la configuración de opciones de energía en XFCE.

 

Vie, 17/06/2016 - 01:50 (Responder a #10)
Dynamost
Imagen de Dynamost
Desconectado/a
se unió: 09/06/16

Percontator wrote:

 Hola a todos.

 

 A lo mejor estoy "meando fuera de sitio", pero de repente me ha saltado una idea, colgada de una duda.

 

 ¿Seguro que es una suspensión?, no vaya a ser algún tipo de cierre forzado, que aprovecha la suspensión para conservar los datos.

  Me refiero por ejemplo a casos como que haya polvo y se recaliente, o haya un problema de ventilación, (¿se oyen los ventiladores?,

  ¿sale aire caliente del portátil?).

 Una prueba: ¿te funciona bien con otros sistemas operativos, u otras distribuciones de linux?, (prueba algún live cd de otra distro).

 Y ahora que hablo de ello,  esto me recuerda el caso de hace unos años, en que pillé un live cd de linux, (creo que era un live-cd de movix),

 que en uno de los portátiles, al minuto o dos de haber empezado se cortaba por las buenas, como si hubieran quitado la correinte.

 Después de haber investigado y probado un poco, me di cuenta de que arrancaba bien, pero cuando esa distro tomaba el control

 el ventilador no giraba.

 Al cabo de nada se protegia por sobrecalentamiento. (Y si lo encendias, normal, a continuación, salia un aire como para decapar pintura laugh)

 

 Comprueba los puntos mencionados, pues si me dices que se cierra a los 5 minutos, puede ser, pero a segundos del inicio, y

 por suspensión, me parece un poco raro.

 

 Ah, mira también si puedes los logs, a ver si hay alguna alarma, algún error, o si aparece quién ha mandado entrar en suspensión.

 

 Saludos a todos.

 Hola muy buenas y perdonad por tardar tanto en contestar pero ando liadillo ultimamente.

    Los ventiladores  van bien. Quiero decir: ni ruidos extraños ni subidones de mortadela antes de que el equipo vaya a suspensión.

    Con otros sistemas operativos como "Wheezy" va bien. EL problema me da con todas las distros basadas en "Debian 8" como " I/O Linux", "AV Linux 2016" o el propio "Jessie". Casi todas basadas en distros para creación multimedia.

    También me ocurre con "Ubuntu Studio" tanto la 14.04 como la última que está dispuesta a descarga desde su web, la 16. X.

 

    Salu2

Vie, 17/06/2016 - 01:56 (Responder a #11)
Dynamost
Imagen de Dynamost
Desconectado/a
se unió: 09/06/16

Berbellon wrote:

Habre una consola TTY {Ctrl + Alt + F1 ... o F2, o F3 etc.}, logueate con la cuenta de root {contraseña de root}, actualiza el sistema a Debian Jessie 8.5, terminada la operación, edita el {/etc/systemd/logind.conf} ... Descomenta o agrega lo siguiente:

 

[...]

HandlePowerKey=ignore
HandleSuspendKey=ignore
HandleHibernateKey=ignore
HandleLidSwitch=ignore

[...]

Reiniciar el sistema.

Saludos.

PD: Si ves algún cambio, observa la configuración de opciones de energía en XFCE.

 

   Sí, también probé con esta solución pero nada, el asunto sigue igual y por lo que he podido leer en algunos foros Debian es un Bug que afecta a ordenatas antiguos con Bios antiguas también así que........

   Seguiré probando soluciones a ver si doy con ella. Mientras si algúna buena, y sabia, alma sabe, y puede aportar, algo más que no se corte.

   

Salu2 y Gracias por la atención.

 

Dom, 19/06/2016 - 13:17 (Responder a #12)
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Oye, se me ocurre:

 

 Aparte de eso de mirar los logs para ver si sale quién pide pasar a suspensión, ¿has probado a arrancar solo la cónsola de texto?,

 Sin activar el servidor X11 ni el modo gráfico.

 Si no quieres desmontar la configuración que tienes para el arranque automático del escritorio, puedes intentar arrancarlo

 en modo administrador o como rescate, usando solo los primeros runlevels. (con red o sin ella)

 

 De esta manera se podrá saber más facilmente si el problema viene del núcleo o de la implementación de la instalación,

 o si empieza al intentar pasar al runlevel 5 y arrancar los sevicios gráficos.

 

Lun, 27/06/2016 - 12:34 (Responder a #13)
Pajaro_xdd
Imagen de Pajaro_xdd
Desconectado/a
colaborador
se unió: 16/03/16

Dynamost wrote:
Sí, también probé con esta solución pero nada, el asunto sigue igual y por lo que he podido leer en algunos foros Debian es un Bug que afecta a ordenatas antiguos con Bios antiguas también así que........

   Seguiré probando soluciones a ver si doy con ella. Mientras si algúna buena, y sabia, alma sabe, y puede aportar, algo más que no se corte.

   

Salu2 y Gracias por la atención.

 

 

Si has leido que afecta a PCs con BIOS antiguas trata de actualizar tu BIOS, si hay actualización disponible, quizá eso solucione el problema.

"Mi cuerpo se cansó, mi vida bostezó, pero mi mente sigue en pie."

Lun, 27/06/2016 - 23:23 (Responder a #14)
Dynamost
Imagen de Dynamost
Desconectado/a
se unió: 09/06/16

Muy Buenas

    Ojalá pudiera pero la última actualización que existe para descargar, desde el FTP de Acer, data del 2004 y no hay, que yo sepa, y la he buscado bastante, otra más reciente.

    Tengo una curiosidad: en la Bios del portátil me tira como memoria gráfica 16MB pero cuando instalo el driver de Intel me marca 64MB. ¿puede tener algo que ver esto con estos apagones súbitos que estoy sufriendo ?.

     La verdad es que el driver más reciente de la gráfica si que es más modernillo

     No voy a ceder en el intento y dentro de un rato volveré a descargas Debian y a instalarlo de nuevo siguiendo los consejos que aquí habeis expuesto y fotografiando el Log del arranque para colgarlo y que podais echar un vistazo.

 

 

    Salu2 y gracias nuevamente.

Mar, 28/06/2016 - 11:31
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

Si vas a hacer una nueva instalación, creo que lo mejor seria que te descargues un netinstal con la última versión estable de debian y que en el proceso de instalación, donde seleccionas los de paquetes para instalación, desactivas todo para dejar prácticamente un sistema base. Este tipo de instalación es muy rápida ya que creo que no se descarga nada de internet.

https://debian-handbook.info/browse/es-ES/stable/sect.installation-steps.html

La idea seria que, si teniendo un sistema base, sin las X ni un powermanager, etc, etc y el ordenador no se reinicia, podríamos descartar el kernel, la bios, etc y enfocarnos en el controlador de video o el de energia y ver que escritorio poner.

PD: para evitar cualquier inconveniente lo mejor seria hacer la instalación via lan

saludos...

 

Mar, 28/06/2016 - 13:47
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 La propuesta de Pajaro _xdd es muy razonable tras lo expuesto, aunque personalmente soy bastante contrario a tocar mucho la bios,

 (si no es inevitable no lo hare ), pues siempre es un riesgo apreciable. Si hay un apagon o no lo has hecho como espera el fabricante,

 o te has equivocado al cojer la versión para tu computadora, o lo que sea, -y posibilidades hay muchas-, es fácil pasar de un laptop

 que no acaba de rendir bien a un hermoso y flamante ladrillo de una conocida marca.

 Mejor malo conocido, si no estás seguro.

 

 Queda además el tema de que tras descontinuar la fabricación de la familia de ese modelo no creo que actualicen mucho su bios, salvo

 casos de un gran error que dejen en mal lugar la imagen de marca.

 Seguramente prefieren que te compres una bios nueva, ... pegada a su correspondiente computadora que lo usa.

 

 Asi que aun siendo un buen consejo, quizás mejor ir haciendo pruebas y combinatorias por el lado del s.o.

Empezando por lo que apoyamos Rockyiii y yo, que tampoco no cuesta mucho, y si tienes un rincon de dsico disponible se puede

hacer incluso aparte, como instalación de prueba.

 

 

Jue, 07/07/2016 - 15:42
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

Aquí, https://lists.debian.org/debian-user/2014/10/msg02161.html, tratan un problema semejante al tuyo, "Problem with systemd-sleep in Jessie", dan algunas sugerencias, pero de antemano advierto que no se llego a una solución, posible error en el firmware o en el kernel.

Intenta con la versión testing de Debian o alguna otra distribución como Manjaro Linux.

Saludos.

Dom, 10/07/2016 - 14:14
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 ... Aunque entonces nos quedaremos con las ganas de saber si el fallo realmente está en el kernel, en alguna incompatibilidad hardware

o en el sistema gráfico.

 

 Pero si te decides por otro linux, también puedes mirar antes si con una versión anterior te va bien. Por ejemplo el 8.0.0

 A mi se me ha instalado sin ningún problema en ordenadores incluso anteriores al tuyo, (a excepción de que no vió una partición dos, aunque no está

muy claro como se llegó a eso).

 En cambio wheezy, a pesar de ser un pingüino, en cuanto me descuidaba me pegaba cada picotazo que no veas. Es por ahora

el único debian desde woody que no ha encajado con lo mio.

 

 A ver.