Prioridad de w3m como navegador

4 envíos / 0 nuevos
Último envío
#1 Sáb, 25/08/2018 - 16:43
Liberto
Imagen de Liberto
Desconectado/a
se unió: 12/03/16

Prioridad de w3m como navegador

Estado: 
[ACTIVO]

Buenas a todxs.

Soy usuario de Debian Strecht y tengo como navegador prioritario w3m:

update-alternatives --config x-www-browser
Existen 3 opciones para la alternativa x-www-browser (que provee /usr/bin/x-www-browser).

De hecho, acabo de hacer la modificación:

update-alternatives --config x-www-browser
Existen 3 opciones para la alternativa x-www-browser (que provee /usr/bin/x-www-browser).

  Selección   Ruta                  Prioridad  Estado
------------------------------------------------------------
* 0            /usr/bin/firefox-esr   70        modo automático
  1            /usr/bin/chromium      40        modo manual
  2            /usr/bin/firefox-esr   70        modo manual
  3            /usr/share/w3m         40        modo manual

Pulse <Intro> para mantener el valor por omisión [*] o pulse un número de selección: 3
update-alternatives: utilizando /usr/share/w3m para proveer /usr/bin/x-www-browser (x-www-browser) en modo manual

Hecho esto, y a la hora de ejecutar Newsbeuter, al intentar abrir tengo este mensaje de error:

/usr/bin/sensible-browser: 24: exec: /usr/bin/x-www-browser: Permission denied

Obviamente es un problema de permisos, pero no estoy consiguiendo dar con la forma de cambiarlo.

¿Sabéis cómo hacerlo?

Un saludo

Dom, 26/08/2018 - 13:15
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

Fijate si el  asunto no viene de lado de xdg-utils 

https://wiki.debian.org/HOWTO/DefaultWebBrowser

Lun, 27/08/2018 - 03:36
Liberto
Imagen de Liberto
Desconectado/a
se unió: 12/03/16

Entiendo que no. Uso XFCE.

De hecho, al comprobarlo, en principio está todo bien:

# xdg-settings get default-web-browser
w3m.desktop

 

"O inventamos o erramos" (Simón Rodríguez)

Lun, 27/08/2018 - 13:43
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

Por la información de la pagina oficial  tendrás un archivo de configuración personal para tu usuario en 

~./newsbeuter/config 

Y dentro algo similar a esto :(aca indicando lynx como navegador texto mas sofisticado )

##Add these items for a better experience, and a place to start making changes:

auto-reload yes
browser lynx
cleanup-on-quit yes
download-path “~/downloads/podcasts”
notify-screen yes
player mplayer
refresh-on-startup yes
reload-time 20
reload-threads 2

en dicho archivo se configura el navegador para uso . si es tu caso  y luego al intentar abrir una url  , te da el mensaje de 

error que mostrás ??