Problema con graficos en Debian 9 xfce

18 envíos / 0 nuevos
Último envío
#1 Mié, 20/02/2019 - 21:09
Aaron
Imagen de Aaron
Desconectado/a
se unió: 20/02/19

Problema con graficos en Debian 9 xfce

Estado: 
[SOLUCIONADO]

Hace unos días que comencé con Debian. Mi computadora es una HP pavilion g4 amd e2 1800.

Tengo problemas al instalar los graficos. Me ha costado identificar como instalarlos. Ya lo hice una vez, funcionó y cuando agregué el repositorio para mis gráficos (lo hice mal y por mi ignorancia agregué repositorio de Jessie) se desconfiguró la tarjeta de Red, lo solucione pero ahora sigo con la duda de como instalar los gráficos.
 

Mié, 20/02/2019 - 23:54
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Entiendo que como sos un usuario nuevo en Debian, y querés resolver tu problema con la tarjeta de vídeo, te apuraste en publicar este post y no te tomaras el tiempo necesario para leer las normas del foro y cumplirlas.

¿que es lfce? será xfce? ¿tenes problemas con los gráficos o queres instalar los drivers privativos de ati, nvidia, intel?
Al iniciar el post hay una parte donde se pide información genérica del hardware "Poner información del hardware aquí" la cual es muy útil a la hora de determinar que firmware o controlador requiere el ordenador en cuestión y cosas por el estilo. Por eso te recomiendo que edites este post y que instales lshw para luego agregar la informacion de lshw -short y de lsb_release -a.
Ya que has estado modificando los repositorios sería conveniente que también lo postees el contenido de tu sources.list
 

cat /etc/apt/sources.list

saludos...

Lun, 25/02/2019 - 02:31 (Responder a #2)
Aaron
Imagen de Aaron
Desconectado/a
se unió: 20/02/19

Ya, gracias por comentar. 

Estos son los repositorios que tengo. Donde esta comentado #Graficos, es donde agregué Jessie, pero luego lo corregí por Strech, lo que corrigió la desconfiguración de la red. Ahora quisiera saber como identificar la instalación de mis graficos. Gracias.

Mis repositorios:

# deb cdrom:[Official Debian GNU/Linux Live 9.7.0 xfce 2019-01-23T19:58]/ stretch main

#deb cdrom:[Official Debian GNU/Linux Live 9.7.0 xfce 2019-01-23T19:58]/ stretch main

# Line commented out by installer because it failed to verify:
#deb http://security.debian.org/debian-security stretch/updates main contrib non-free
# Line commented out by installer because it failed to verify:
#deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://deb.debian.org/debian/ stretch-updates main contrib non-free

deb http://httpredir.debian.org/ strech_updates main contrib non-free

#Graficos
deb http://httpredir.debian.org/debian/ strech main contrib non-free

debAr

Lun, 25/02/2019 - 10:39
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

en la wiki de debian hay una entrada sobre ati que puede serte de ayuda: https://wiki.debian.org/AtiHowTo
 

su
apt-get update && apt-get upgrade
apt-get install firmware-linux-nonfree libgl1-mesa-dri xserver-xorg-video-ati

 

Lun, 25/02/2019 - 21:16 (Responder a #4)
Aaron
Imagen de Aaron
Desconectado/a
se unió: 20/02/19
# sudo apt-get install firmware-linux-nonfree libgl1-mesa-dri xserver-xorg-video-ati
E: No se pudo bloquear /var/lib/dpkg/lock - open (11: Recurso no disponible temporalmente)
E: No se pudo bloquear el directorio de administración (/var/lib/dpkg/), ¿quizás haya algún otro proceso utilizándolo?

Gracias. Ya lo había utilizado. Y pues... Esto es lo que vuelve a enviarme.

¿Tienes alguna idea de qué esta sucediendo? Gracias.

debAr

Lun, 25/02/2019 - 22:23
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

no entiendo porque estas usando sudo cuando te he puesto el comando su

Por defecto sudo no viene activado en debian

Mar, 26/02/2019 - 01:01 (Responder a #6)
Aaron
Imagen de Aaron
Desconectado/a
se unió: 20/02/19

Perdon, tienes razón. Ahora te actualizare el error que me mostro.

# apt-get install firmware-linux-nonfree libgl1-mesa-dri xserver-xorg-video-ati
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
El paquete firmware-linux-nonfree no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente
Sin embargo, los siguientes paquetes lo reemplazan:
  firmware-misc-nonfree

E: El paquete «firmware-linux-nonfree» no tiene un candidato para la instalación

 

debAr

Mar, 05/03/2019 - 21:41 (Responder a #7)
almursi2
Imagen de almursi2
Desconectado/a
se unió: 26/02/19

Aaron wrote:

Perdon, tienes razón. Ahora te actualizare el error que me mostro.

# apt-get install firmware-linux-nonfree libgl1-mesa-dri xserver-xorg-video-ati
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
El paquete firmware-linux-nonfree no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente
Sin embargo, los siguientes paquetes lo reemplazan:
  firmware-misc-nonfree

E: El paquete «firmware-linux-nonfree» no tiene un candidato para la instalación

 

 

Buenas Aaron, puede que se trate de un viejo bug con sources.list, por lo que te aconsejo que pruebes a cambiar "main contrib non-free" por "contrib non-free main". Por ejemplo este es mi caso:

deb http://ftp.caliu.cat/debian/ stable non-free contrib main

deb http://ftp.caliu.cat/debian/ stretch-updates non-free contrib main

deb http://ftp.caliu.cat/debian/ stretch-backports contrib non-free main

Sea como sea, el "main" lo último.

Saludos cordiales.

Mié, 06/03/2019 - 12:15
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Estas tratando de instalar un paquete no disponible, sin embargo lee con cuidado , te estan indicando una solución para reemplazarlo .

firmware-misc-nonfree

 

Mié, 06/03/2019 - 22:09 (Responder a #9)
almursi2
Imagen de almursi2
Desconectado/a
se unió: 26/02/19

caliban wrote:

Estas tratando de instalar un paquete no disponible, sin embargo lee con cuidado , te estan indicando una solución para reemplazarlo .

firmware-misc-nonfree

 

 

Disculpa caliban, pero insisto: es un viejo bug, Me suena que lo comenté hace un par de años por aquí(como almursi a secas). Puede que esté relacionado con la edición manual de sources.list. Este es el paquete "desaparecido":

https://packages.debian.org/search?keywords=firmware-linux-nonfree&searchon=names&suite=stable&section=all

En el caso de que no aparezcan los paquetes contrib y non-free, en cuanto cambias el orden de las secciones con main al final los índices son descargados correctamente. Saludos cordiales.

 

p.d.: De hecho acabo de notificar el bug, por si acaso siguiera sin tener parche.

p.d.2: Sin embargo ahora no conseguimos reproducirlo, debe de haber por ahí algo que provoque el problema en equis circunstancias. Y por lo visto lo debí de comentar en el antiguo foro de esdebian...

Jue, 07/03/2019 - 12:58 (Responder a #10)
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

almursi2 wrote:

 

Disculpa caliban, pero insisto: es un viejo bug, Me suena que lo comenté hace un par de años por aquí(como almursi a secas). Puede que esté relacionado con la edición manual de sources.list. Este es el paquete "desaparecido":

https://packages.debian.org/search?keywords=firmware-linux-nonfree&searchon=names&suite=stable&section=all

En el caso de que no aparezcan los paquetes contrib y non-free, en cuanto cambias el orden de las secciones con main al final los índices son descargados correctamente. Saludos cordiales.

 

 

No me estoy metiendo con el problema,solo le indico que significa el mensaje de error , y la posible solución que le indica apt.

En cuanto al paquete , simplemente con buscarlo a ver si existe en 

https://packages.debian.org/stretch/firmware-linux-nonfree

En cuanto el bug,no tengo idea,  siempre edito mi sources.list  , siempre pongo main al inicio,  y si busco:

aptitude search firmware-linux-nonfree
p   firmware-linux-nonfree                   - Binary firmware for various drivers in the Linux k

Figura dicho paquete .(al menos en Sid )

Jue, 07/03/2019 - 15:23
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

El paquete firmware-linux-nonfree esta para debian 9 en los repos  https://packages.debian.org/stretch/firmware-linux-nonfree
proba lo siguiente:

wget ftp.de.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-linux-nonfree_20161130-4_all.deb
su
dpkg -i firmware-linux-nonfree_20161130-4_all.deb
apt-get -f install

igualmente el paquete que tenes que instalar es firmware-amd-graphics ya que firmware-linux-nonfree es lo que llaman metapaquete

saludos...

Vie, 08/03/2019 - 09:07
almursi2
Imagen de almursi2
Desconectado/a
se unió: 26/02/19

Buenas, el comentario de rockyiii es el buenosmiley, probablemente le faltó el update. En mi caso era una errata y tenía puesto nonfree sin el guión, en cuanto lo corregí quedó resuelto. En cuanto al bug, si lo comenté en esdebian tuvo que ser con la distribución estable anterior como mínimo, pero por precaución siempre iba poniendo el main al final, así que no tuve ocasión de ver que estaba resuelto. En cuanto saque un rato lo probare, que tengo por ahí la colección de instaladores. Saludos cordiales.

Vie, 08/03/2019 - 21:46 (Responder a #13)
Aaron
Imagen de Aaron
Desconectado/a
se unió: 20/02/19

Justamente eso hice. Cuando creí haber instalado los gráficos. La tarjeta de red se desconfiguro y ya no pude conectarme inalambricamente. Gracias, ya lo había probado. Pero si puedes explicarme porqué sucedió eso, te lo agradecería. Así puedo volver a intentar instalar

firmware-misc-nonfree

 

debAr

Vie, 08/03/2019 - 21:55 (Responder a #14)
Aaron
Imagen de Aaron
Desconectado/a
se unió: 20/02/19

Gracias rockyii. Lo voy a intentar después. Hay un error que me muestra al ingresar:

wget ftp.de.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-linux-nonfree_20161130-4_all.deb

Este es el error:

--2019-03-08 18:42:01--  http://ftp.de.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-linux-nonfree_20161130-4_all.deb
Resolviendo ftp.de.debian.org (ftp.de.debian.org)... 141.76.2.4
Conectando con ftp.de.debian.org (ftp.de.debian.org)[141.76.2.4]:80... conectado.
Petición HTTP enviada, esperando respuesta... 301 Moved Permanently
Localización: https://172.XX.0.1/sgerror.php?url=403%20&a=172.XX.XXX.XXX&n=172.XX.XXX.XXX&i=&s=SitiosBloqueados&t=blk_BL_downloads&u=http://ftp.de.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-linux-nonfree_20161130-4_all.deb [siguiendo]
--2019-03-08 18:42:06--  https://172.XX.X.X/sgerror.php?url=403%20&a=172.XX.XXX.XXX&n=172.XX.XXX.XXX&i=&s=SitiosBloqueados&t=blk_BL_downloads&u=http://ftp.de.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-linux-nonfree_20161130-4_all.deb
Conectando con 172.XX.X.X:443... conectado.
ERROR: El certificado de “172.XX.X.X” no es confiable.
ERROR: El certificado de “172.XX.X.X” no tiene un emisor conocido.
El propietario del certificado no se ajusta al nombre de equipo “172.XX.X.X”

Entenderas que tache cierta parte de la dirección IP por seguridad.

Imagino que es porque estoy en una red protegida que no me deja ingresar. Lo voy a intentar más tarde y te escribo para comentarte si arreglé o no el error. 

Gracias por responder.

debAr

Vie, 08/03/2019 - 23:33
Aaron
Imagen de Aaron
Desconectado/a
se unió: 20/02/19

GRACIAS A TODOS  LOS QUE COMENTARON.

Resulta que para instalar 

firmware-linux-nonfree

Necesitaba instalar 

firmware-amd-graphics

Junto a 

firmware-misc-nonfree

Que era el que ya tenía instalado pero me desconfiguraba la tarjeta de red por no tener complementos.

 

Ahora ya entiendo lo que ignoraba. Ya se corrigió el error y se instaló correctamente. 

Ahora ya puedo jugar CS 1.6 tranquilo jajajaja

debAr

Vie, 08/03/2019 - 23:37
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

No se que podra ser ese mensaje. En mi caso no hay problema para descargarlo

wget ftp.de.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-linux-nonfree_20161130-4_all.deb
--2019-03-08 23:26:00--  http://ftp.de.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-linux-nonfree_20161130-4_all.deb
Resolviendo ftp.de.debian.org (ftp.de.debian.org)... 141.76.2.4
Conectando con ftp.de.debian.org (ftp.de.debian.org)[141.76.2.4]:80... conectado.
Petición HTTP enviada, esperando respuesta... 200 OK
Longitud: 14078 (14K) [application/x-debian-package]
Grabando a: “firmware-linux-nonfree_20161130-4_all.deb”

firmware-linux-nonfree_201611 100%[=================================================>]  13,75K  52,4KB/s    en 0,3s    

2019-03-08 23:26:02 (52,4 KB/s) - “firmware-linux-nonfree_20161130-4_all.deb” guardado [14078/14078]

Yo te puse el enlace de alemania pero a lo mejor te convenga el de brasil o el de eeuu en esta url hay estan los enlaces de los distintos repositorios  https://packages.debian.org/stretch/all/firmware-linux-nonfree/download de ultima descárgalo desde un navegador web

para dpkg acordate que primero te tenes que loguear con su

Vie, 08/03/2019 - 23:39 (Responder a #17)
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Aaron wrote:

GRACIAS A TODOS  LOS QUE COMENTARON.

Resulta que para instalar 

firmware-linux-nonfree

Necesitaba instalar 

firmware-amd-graphics

Junto a 

firmware-misc-nonfree

Que era el que ya tenía instalado pero me desconfiguraba la tarjeta de red por no tener complementos.

 

Ahora ya entiendo lo que ignoraba. Ya se corrigió el error y se instaló correctamente. 

Ahora ya puedo jugar CS 1.6 tranquilo jajajaja

yes

*PD si te gusta el cs te puede gustar el urban terror https://www.urbanterror.info/downloads/