Problema con Servicio de Streaming Icecast + Video

10 envíos / 0 nuevos
Último envío
#1 Mié, 04/10/2017 - 01:23
nigealix20
Imagen de nigealix20
Desconectado/a
se unió: 04/10/17

Problema con Servicio de Streaming Icecast + Video

Estado: 
[ACTIVO]

Hola estoy teniendo un problema arme un servidor de icecast en un servidor con debian 8 jessie puedo transmitir audio sin ningún inconveniente ahora lo que quiero hacer es transmitir audio y vídeo por lo que buscando vi que se podía lograr con theora + vorbis todo bien ahora puedo transmitir vídeo y audio pero por separado cuando lo quiero hacer junto me lanza este error

el servidor tiene un linux debian y necesito que se pueda transmitir desde una computadora con windows 7 +

Fallo emitiendo / transcodificando:
Su instalación Libav/FFmpeg (libavcodec) no tiene el siguiente codificador:
Vorbis Audio.
Si no conoce como solucionar esto solicite soporte para su distribución.

uso el VLC para dicho propósito

estuve investigando pero no encuentro nada para poder solucionarlo agradezco mucho la ayuda y si necesitan algún dato mas pídanme y se los pasare

no soy un experto en linux pero hago lo que puedo y voy aprendiendo poco a poco

muchas gracias

Mié, 04/10/2017 - 09:57
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Fijate si este artículo te puede ser de ayuda https://elbinario.net/2017/10/03/haciendo-streaming-con-obs-con-un-servidor-icecast2/
el programa obs es espectacular y creo que ya viene incluido en debian 8 y tengo entendido que es multiplataforma
Con ffmpg podes armar tambien un "servidor" de streaming https://trac.ffmpeg.org/wiki/StreamingGuide https://trac.ffmpeg.org/wiki/ffserver

Mié, 04/10/2017 - 13:32
nigealix20
Imagen de nigealix20
Desconectado/a
se unió: 04/10/17

hola gracias por la ayuda pero necesitaría que sea sobre icecast  o shoutcast ya que estamos usando una plataforma llamada centova para las estadisticas que funciona con icecast y shoutcast

Mié, 04/10/2017 - 14:35
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

bueno, por lo que dice el error te falta el codec de vorbis audio , fijate si tenes

con ffmpeg2theora y oggfwd http://v2v.cc/~j/ffmpeg2theora/examples.html http://lists.xiph.org/pipermail/icecast/2006-December/010796.html

 

La otra que se me ocurre es que instales ffmpeg desde el repositorio www.deb-multimedia.org 

Mié, 04/10/2017 - 15:59
nigealix20
Imagen de nigealix20
Desconectado/a
se unió: 04/10/17

root@nnvserver:/# apt-get install libvorbis0a
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
libvorbis0a ya está en su versión más reciente.
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 39 no actualizados.
root@nnvserver:/# apt-get install libvorbisenc2
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
libvorbisenc2 ya está en su versión más reciente.
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 39 no actualizados.
root@nnvserver:/# apt-get install libvorbisfile3
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
libvorbisfile3 ya está en su versión más reciente.
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 39 no actualizados.
root@nnvserver:/#

Mié, 04/10/2017 - 21:24
nigealix20
Imagen de nigealix20
Desconectado/a
se unió: 04/10/17

tengo todo instalado y sigo con el mismo problema es raro ya no se si es tema del servidor o problema de la computadora con windows

Mié, 04/10/2017 - 23:56
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

a lo mejor si mostrarias como configuraste o la url de la guia que usaste para configurar icecast y los comandos que utilizas para theora  + vorbis (sin poner ip reales ni ninguna información que pueda causarte algún tipo de vulnerabilidad) alguien pueda darte una mano  ya que cuanto más información aportes seguramente mas personas te van a poder ayudar
tampoco queda claro de donde sale el error (que comando estas ejecutando cuando sale el error)

Fallo emitiendo / transcodificando:
Su instalación Libav/FFmpeg (libavcodec) no tiene el siguiente codificador:
Vorbis Audio.

supongo que usas vlc para trasmitir el video desde win7 al servidor icecast si es asi a lo mejor el problema no esté en los programas de debian, sino en como estas trasmitiendo desde windows ese video (la configuración). 

yo te decia de instalar ffmpeg de los repos de deb-multimedia porque es recien en debian 9 que vuelve a usarse ffmpeg en lugar de su fork livcodec https://lamiradadelreplicante.com/2015/06/20/debian-prepara-su-vuelta-a-ffmpeg/ a lo mejor el fork llama a voris audio con otro nombre y eso causa el conflicto

 

Jue, 05/10/2017 - 04:33
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

que te devuelve la salida de ffmpeg en consola? Ejecutandolo sin parámetro alguno te dirá las características que tiene activadas y desactivadas. Busca entre ellas vorbis a ver si dice --enable o --disable.

Por otro lado, dices que el servidor corre Debian, pero ¿necesitas transmitir desde un windows 7? ¿que haces, transmites desde debian a un windows 7 para que éste transmita lo que le pasa el debian? no entiendo del todo esta parte...

  No hay bar que por bien no venga....
Jue, 05/10/2017 - 11:40
nigealix20
Imagen de nigealix20
Desconectado/a
se unió: 04/10/17

y como hago eso?

Jue, 05/10/2017 - 12:48 (Responder a #9)
moonwatcher
Imagen de moonwatcher
Desconectado/a
moderador
se unió: 21/01/16

nigealix20 wrote:

y como hago eso?

$ ffmpeg

 

We were but stones. Your light made us stars

https://linuxveredas.blogspot.com.es/