Problemas al instalar amd-graphics en debian 11

12 envíos / 0 nuevos
Último envío
#1 Lun, 12/09/2022 - 10:44
viriato
Imagen de viriato
Desconectado/a
se unió: 29/08/17

Problemas al instalar amd-graphics en debian 11

He hecho una instalación limpia después de observar los problemas que tengo. Durante unos segundos, la torre del PC hace más ruido de lo normal, creo que es un problema de la tarjeta gráfica.  Y de vez en cuando,  se congela la pantalla

 

Y después de instalar, a veces surge el mismo dichoso problema. Ignoro si es por culpa de la tarjeta gráfica AMD-ATI que tengo o es por culpa del sistema operativo Debian. No sé si  probar con Ubuntu. Igual abandono DebianHe leido que las tarjetas AMD-ATI causan muchos problemas y es aquí cuando clamo al cielo contra los fabricantes de hardware que solo piensan en Windows.

 

Les dejo lo que aparece en el terminal:

 

update-initramfs: Generating /boot/initrd.img-5.10.0-18-amd64
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_gpu_info.bin for modu
le amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_ta.bin for modul
e amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_sos.bin for modu
le amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_ta.bin for module amd
gpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_asd.bin for module am
dgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_sos.bin for module am
dgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_rlc.bin for module am
dgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_mec2.bin for module a
mdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_mec.bin for module am
dgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_rlc.bin for modu
le amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_mec2.bin for mod
ule amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_mec.bin for modu
le amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_me.bin for modul
e amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_pfp.bin for modu
le amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_ce.bin for modul
e amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_sdma.bin for module a
mdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_sdma.bin for mod
ule amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/sienna_cichlid_mes.bin for mod
ule amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navi10_mes.bin for module amdg
pu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_vcn.bin for modu
le amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_vcn.bin for module am
dgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_smc.bin for modu
le amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/arcturus_smc.bin for module am
dgpu
W: Possible missing firmware /lib/firmware/amdgpu/navy_flounder_dmcub.bin for mo
dule amdgpu

 

Lun, 12/09/2022 - 11:44
viriato
Imagen de viriato
Desconectado/a
se unió: 29/08/17
$ git clone git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
$ cd /home/user/firmware/amdgpu 
# cp * /lib/firmware/amdgpu

// Y este comando me falla

# update-initramfs -k all -u -v

 

Lun, 12/09/2022 - 12:32
viriato
Imagen de viriato
Desconectado/a
se unió: 29/08/17

Intento iniciar inittramfs-tolls y falla.

Lun, 12/09/2022 - 16:29
Berbellon
Imagen de Berbellon
Conectado
colaborador
se unió: 04/05/16

Puede que sea un problema de firmware o puede que no. He visto esas advertencias cuanto hay actualizaciones de kernel (en APT). Pero cuando consulto dmesg o journalctl, no veo ningún problema en específico con el hardware.

Esta es mi gráfica,


00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)

Si tuviera problemas con ella usaría el ID de la gráfica (00:02.0) para encontrar alguna solución.

Posiblemente necesites un kernel más actual?

Si fuera problema de firmware, Debian debería dar alguna solución, https://www.phoronix.com/news/Debian-Non-Free-Firmware-GR

"... No sé si probar con Ubuntu ..."

Si todo funciona como se espera con Ubuntu, adelante. Ver porque todo sale bien con Ubuntu, replicarlo en Debian y dar la solución en el foro, sería mejor.

Lun, 12/09/2022 - 17:46 (Responder a #4)
viriato
Imagen de viriato
Desconectado/a
se unió: 29/08/17

En mi caso, está es mi gráfica

user@debian:~$ lspci | grep VGA 09:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] (rev e7)

No descarto que el problema sea de hardware

https://microsofters.com/184343/amd-confirma-los-problemas-de-ryzen-y-sus-graficas-con-windows-11/

 

Este es mi equipo:
 


placa baseASUS ROG Strix X570-F Gaming, Placa Base, 1

ramCorsair Vengeance RGB - Kit de memoria Entusiasta de 16 GB (2 x 8 GB, DDR4, 3200 MHz, C16 XMP 2.0) negro

microprocesador AMD Ryzen 7 2700 - Procesador con disipador de calor Wraith Spire LED (20 MB, 8 núcleos, velocidad de 4.10 GhZ, 65 W)

tarjeta gráfica Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480] ASUS ROG-STRIX-RX580-T8G-GAMING Radeon RX 580 8GB GDDR5 - Tarjeta gráfica (AMD, Radeon RX 580, 7680 x 4320 Pixeles, 1411 MHz, 1431 MHz, 8 GB)

fuente de alimentacionCorsair RM750 - Fuente de Alimentación (ATX Totalmente Modular, 80 Plus Gold, 750 W) color negro (CP-9020195-EU)

disco duro SSD 1TBCrucial P1 CT1000P1SSD8 - Disco Duro sólido Interno SSD de 1 TB (3D NAND, NVMe, PCIe, M.2)

disco duro SSD 512 GBCrucial P1 CT500P1SSD8 - Disco Duro sólido Interno SSD de 500 GB (3D NAND, NVMe, PCIe, M.2)

He leído de todo:

Que igual es un problema de la tarjeta gráfica, que si la fuente de alimentación a lo mejor no suministra suficiente corriente eléctrica a la tarjeta gráfica, que si los procesadores ryzen y las tarjetas gráficas de AMD dan problemas en Windows 11. Que da igual el sistema operativo que elijas, que de vez en cuando, se congela o se bloquea, que se incrementa mucho la temperatura y los recursos que consume la computadora, que las tarjetas gráficas AMD (ATI) son un peligro para los laptops por esa razón...

 

Este artículo es bastante esclarecedor al respecto:

AMD (ATI) y sus eternos problemas https://blog.desdelinux.net/amdati-y-sus-eternos-problemas/

De momento, he hecho una instalación de Debian 11,5 bulleye y noto cierta estabilidad, espero que dure... porque sino, me pego un tiro. Hace unas semanas, hice una actualización de Debian 10 a Debian 11 y si antes, tenía algún problema de vez en cuando, en los últímos días, los bloqueos o congelamientos de pantalla, ocurrían 5 o 6 veces.

Puedes pensar que los drivers propietarios de AMD son una porquería, pero si no los hubiera instalado, tendría una resolucin de pantalla muy baja, sin contar que recibes mensajes que el ordenador consume muchos recursos por esa razón.

 

Mar, 13/09/2022 - 05:38
NerveNet
Imagen de NerveNet
Desconectado/a
colaborador
se unió: 14/03/16

Dices que se te bloquea. ¿Se te bloquea el PC al completo o sigues teniendo acceso a la consola?

 

Me explico, tengo un equipo con una Nvidia viejita, con los controladores Nouveau todo va como la seda. Pero si instalo el firmware de la tarjeta tan pronto arranco VLC para ver un vídeo se congela el sistema aparentemente, VLC tira de aceleración hardware con esta tarjeta gráfica pero sólo si el firmware está presente.

El caso es que sigo pudiendo acceder al equipo por SSH, así que entro por SSH al equipo reinicio el entorno gráfico y listo, a seguir trabajando.

Comentar que basta con no instalar el firmware para evitar ese problema en mi caso.

 

En cambio, si se bloquease al completo el equipo, sin posibilidad de acceder por SSH quiere decir que este se ha colgado por completo y pudiera haber un problema Hardware.

A un clic de distancia de ti...

Mar, 13/09/2022 - 13:17
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Eso que ves al actualizarse la imagen del kernel no es ningún error y no es relevante mientras tu gráfica no necesite uno de esos firmwares.

Esos errores son "normales" y aparecen cuando se actualiza un kernel en el cual se ha introducido soporte para nuevas gráficas o hardware nuevos. Usualmente, ocurre que al introducir dicho soporte nuevo o inicial, el sistema "sabe" que para que ese soporte funcione correctamente necesita esos archivos de firmware, pero no quiere decir que tu sistema lo necesite, y tambien normalmente se arregla en un par de actualizaciones, ya que es cuando se introducen esos archivos de firmware en el paquete correspondiente.

Lo que puedes mirar es con dmesg | grep -i firmware o journalctl -b |grep -i firmware si se busca uno que no exista y tratar de instalarlo.

Esos problemas que comentas, tampoco son exclusivos de amd. Intel por ejemplo los ha sufrido durante mucho tiempo al introducir gráficas nuevas que provocaban cuelgues aleatorios del sistema hasta que se actualizaban los drivers.

  No hay bar que por bien no venga....
Mié, 14/09/2022 - 09:18 (Responder a #7)
viriato
Imagen de viriato
Desconectado/a
se unió: 29/08/17

Gracias por contestar

 

Puedo reiniciar el PC con la combinación de teclas ALT + IMPR PANTALLA + B y nada más.

Aparece una imagen distorsionada fija amarillenta granulada con mucho ruido. A veces, si estás viendo una película, pués escuchas la música... no es un bloqueo total. pero me obliga a reiniciar.

El problema es que a veces, recibo un mensaje que la pantalla de que debian no trabaja con la resolución óptima y eso consume muchos recursos.  y me da un error al inicio con un texto similar a éste: [drm:amdgpu_pci_probe [amdgpu]] *ERROR* amdgpu requires firmware installed"

La solución que me dieron en el foro en inglés debian forum es que instalase los drivers oficiales con el comando $ apt install amd-firmware

Con la versión anterior de de Debian 10, tambień se me congelaba la pantalla cada x días pero con la versión 11, además de congelarse la pantalla y ofrecer una imagen fija, esta aparece distorsionada.

He hecho una instalación nueva y  durante 3 días iba todo bien hasta que ocurre el problema este:

 

A mí me está quedando claro que veo numerosos problemas en linux cuando se trata de equipos nuevos o potentes, sobre todo con la tarjeta gráfica.

 

NerveNet wrote:

Dices que se te bloquea. ¿Se te bloquea el PC al completo o sigues teniendo acceso a la consola?

 

Me explico, tengo un equipo con una Nvidia viejita, con los controladores Nouveau todo va como la seda. Pero si instalo el firmware de la tarjeta tan pronto arranco VLC para ver un vídeo se congela el sistema aparentemente, VLC tira de aceleración hardware con esta tarjeta gráfica pero sólo si el firmware está presente.

El caso es que sigo pudiendo acceder al equipo por SSH, así que entro por SSH al equipo reinicio el entorno gráfico y listo, a seguir trabajando.

Comentar que basta con no instalar el firmware para evitar ese problema en mi caso.

 

En cambio, si se bloquease al completo el equipo, sin posibilidad de acceder por SSH quiere decir que este se ha colgado por completo y pudiera haber un problema Hardware.

Mié, 14/09/2022 - 09:21 (Responder a #8)
viriato
Imagen de viriato
Desconectado/a
se unió: 29/08/17

Gracias por responder:

 

root@debian:/home/User# dmesg | grep -i firmware

[    0.000443] Spectre V2 : Enabling Speculation Barrier for firmware calls
[    0.299465] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    0.309233] acpi PNP0A08:00: [Firmware Info]: MMCONFIG for domain 0000 [bus 00-3f] only partially covers this bridge
[    1.598338] amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_mc.bin
[    1.600200] amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_pfp_2.bin
[    1.600216] amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_me_2.bin
[    1.600231] amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_ce_2.bin
[    1.600248] amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_rlc.bin
[    1.600322] amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_mec_2.bin
[    1.600393] amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_mec2_2.bin
[    1.601187] amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_sdma.bin
[    1.601203] amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_sdma1.bin
[    1.601370] amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_uvd.bin
[    1.601373] [drm] Found UVD firmware Version: 1.130 Family ID: 16
[    1.602043] amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_vce.bin
[    1.602046] [drm] Found VCE firmware Version: 53.26 Binary ID: 3
[    1.602659] amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_k_smc.bin
[    6.482105] bluetooth hci0: firmware: failed to load brcm/BCM20702A1-0a5c-21e8.hcd (-2)
[    6.483084] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
[    6.484094] bluetooth hci0: firmware: failed to load brcm/BCM-0a5c-21e8.hcd (-2)
[    6.485215] Bluetooth: hci0: BCM: firmware Patch file not found, tried:

 

Mié, 14/09/2022 - 09:23 (Responder a #9)
viriato
Imagen de viriato
Desconectado/a
se unió: 29/08/17

root@debian:/home/jesus# journalctl -b |grep -i firmware


sep 14 10:46:48 debian kernel: Spectre V2 : Enabling Speculation Barrier for firmware calls
sep 14 10:46:48 debian kernel: ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
sep 14 10:46:48 debian kernel: acpi PNP0A08:00: [Firmware Info]: MMCONFIG for domain 0000 [bus 00-3f] only partially covers this bridge
sep 14 10:46:48 debian kernel: amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_mc.bin
sep 14 10:46:48 debian kernel: amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_pfp_2.bin
sep 14 10:46:48 debian kernel: amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_me_2.bin
sep 14 10:46:48 debian kernel: amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_ce_2.bin
sep 14 10:46:48 debian kernel: amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_rlc.bin
sep 14 10:46:48 debian kernel: amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_mec_2.bin
sep 14 10:46:48 debian kernel: amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_mec2_2.bin
sep 14 10:46:48 debian kernel: amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_sdma.bin
sep 14 10:46:48 debian kernel: amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_sdma1.bin
sep 14 10:46:48 debian kernel: amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_uvd.bin
sep 14 10:46:48 debian kernel: [drm] Found UVD firmware Version: 1.130 Family ID: 16
sep 14 10:46:48 debian kernel: amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_vce.bin
sep 14 10:46:48 debian kernel: [drm] Found VCE firmware Version: 53.26 Binary ID: 3
sep 14 10:46:48 debian kernel: amdgpu 0000:09:00.0: firmware: direct-loading firmware amdgpu/polaris10_k_smc.bin
sep 14 10:46:48 debian NetworkManager[640]: <info>  [1663145208.7241] manager[0x55f0a729c010]: monitoring kernel firmware directory '/lib/firmware'.
sep 14 10:46:48 debian kernel: bluetooth hci0: firmware: failed to load brcm/BCM20702A1-0a5c-21e8.hcd (-2)
sep 14 10:46:48 debian kernel: firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
sep 14 10:46:48 debian kernel: bluetooth hci0: firmware: failed to load brcm/BCM-0a5c-21e8.hcd (-2)
sep 14 10:46:48 debian kernel: Bluetooth: hci0: BCM: firmware Patch file not found, tried:
sep 14 10:48:58 debian systemd[1]: Starting Firmware update daemon...
sep 14 10:48:58 debian systemd[1]: Started Firmware update daemon.
sep 14 10:49:01 debian gnome-software[2490]: automatically prevented from changing kind on system/package/*/generic/firmware-ath9k-htc/* from generic to unknown!

 

Panko wrote:

Eso que ves al actualizarse la imagen del kernel no es ningún error y no es relevante mientras tu gráfica no necesite uno de esos firmwares.

Esos errores son "normales" y aparecen cuando se actualiza un kernel en el cual se ha introducido soporte para nuevas gráficas o hardware nuevos. Usualmente, ocurre que al introducir dicho soporte nuevo o inicial, el sistema "sabe" que para que ese soporte funcione correctamente necesita esos archivos de firmware, pero no quiere decir que tu sistema lo necesite, y tambien normalmente se arregla en un par de actualizaciones, ya que es cuando se introducen esos archivos de firmware en el paquete correspondiente.

Lo que puedes mirar es con dmesg | grep -i firmware o journalctl -b |grep -i firmware si se busca uno que no exista y tratar de instalarlo.

Esos problemas que comentas, tampoco son exclusivos de amd. Intel por ejemplo los ha sufrido durante mucho tiempo al introducir gráficas nuevas que provocaban cuelgues aleatorios del sistema hasta que se actualizaban los drivers.

Sáb, 17/09/2022 - 16:07
Berbellon
Imagen de Berbellon
Conectado
colaborador
se unió: 04/05/16

Haz considerado cambiar de enfoque y culpar al procesador, como bien dices Linux adolece con el Hardware. No hablo del mantenimiento preventivo del PC.

En bugzilla.kernel.org, la wiki de Gentoo y Arch, hablan de casos semejantes al tuyo relacionados con los procesadores AMD Ryzen.
https://bugzilla.kernel.org/show_bug.cgi?id=206487

En general debes tener lo último de linux-firmware, el microcódigo de AMD, actualizar la BIOS, degradar la BIOS a una versión anterior, parámetros del kernel para el grub, incluso modificar los voltajes para la CPU. Funciona algo de esto, NPI.

Antes revisa todo el mensaje de dmesg.

Vie, 23/09/2022 - 11:40
lalo
Imagen de lalo
Desconectado/a
colaborador
se unió: 22/02/16

tengo un processador AMD Ryzen 7 5700G
en el cual puse Debian 11 y surgio el error:
[drm:amdgpu_pci_probe [amdgpu]] *ERROR* amdgpu requires firmware installed

al instalar:
apt install isenkram && isenkram-autoinstall-firmware

se solucionó.

Saludos 
lalo