QmapShack 1.13.0 no puedo compilarlo

10 envíos / 0 nuevos
Último envío
#1 Dom, 21/04/2019 - 15:15
Antonio
Imagen de Antonio
Desconectado/a
se unió: 21/01/18

QmapShack 1.13.0 no puedo compilarlo

Estado: 
[SOLUCIONADO]

Hola,

El problema lo tengo en la primera etapa que es esta

Entiendo que se intenta descargar cosas de bitbucket. Pues no puede hacer la descarga, me lanza este error.

Estoy usando Debian Buster, con el escritorio Gnome 3.30.2

Dom, 21/04/2019 - 17:09
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

Desde ya te aclaro que Debian no es una distro ideal para compilar y por otra parte el programa qmapshack está en los repositorios de debian buster https://packages.debian.org/buster/qmapshack Así que si no existe un motivo específico para compilarlo, creo que la mejor opción seria instalar el paquete desde el repositorio y evitarte muchos dolores de cabeza.

su
apt update && apt install qmapshack

saludos...

Dom, 21/04/2019 - 20:05
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

¿Has probado lo que te indica que hagas?

  No hay bar que por bien no venga....
Lun, 22/04/2019 - 06:40
Antonio
Imagen de Antonio
Desconectado/a
se unió: 21/01/18

Lo primero gracias por vuestros posts.

Panko

¿Has probado lo que te indica que hagas?

No lo he probado porque no se como hacerlo exactamente, pero en esta pagina, si no he entendido mal no es buena recomendacion desactivarlo.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=918475

 

 

Vive y deja vivir

Lun, 22/04/2019 - 06:45 (Responder a #4)
Antonio
Imagen de Antonio
Desconectado/a
se unió: 21/01/18

rockyii ya lo tengo instalado del repositorio de buster el qmapshack, que es la version 1.12.3, y me va bien. Solo era por tener la ultima version de la aplicacion y tambien por practicar cosas en linux, ya que soy novato en esto.

¿Para ti cual es la mejor distro para crear programas y compilarlos en linux?.

Gracias por tu tiempo de antemano.

Vive y deja vivir

Lun, 22/04/2019 - 11:35
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

No tengo mucha idea en ese tema, pero seguramente con distros como gentoo, slackware, Arch Linux, centOS, entre otras

Aclaro que no quiero decir que con debian no puedas compilar.
Sobre el comando hg por lo que estuve mirando el ejecutable viene en el paquete

https://packages.debian.org/stretch/mercurial

https://packages.debian.org/search?searchon=contents&keywords=hg&mode=path&suite=stable&arch=any

Lun, 22/04/2019 - 13:11 (Responder a #6)
Antonio
Imagen de Antonio
Desconectado/a
se unió: 21/01/18

rockyiii wrote:

No tengo mucha idea en ese tema, pero seguramente con distros como gentoo, slackware, Arch Linux, centOS, entre otras

Aclaro que no quiero decir que con debian no puedas compilar.
Sobre el comando hg por lo que estuve mirando el ejecutable viene en el paquete

https://packages.debian.org/stretch/mercurial

https://packages.debian.org/search?searchon=contents&keywords=hg&mode=path&suite=stable&arch=any

 

rockyiii gracias por tu aporte, creo que me esperaré a que lancen Buster como versión estable.

Entiendo que antes de lanzar la versión como estable, lo habrán solucionado.

Vive y deja vivir

Lun, 22/04/2019 - 17:09 (Responder a #7)
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Antonio wrote:

Lo primero gracias por vuestros posts.

Panko

¿Has probado lo que te indica que hagas?

No lo he probado porque no se como hacerlo exactamente, pero en esta pagina, si no he entendido mal no es buena recomendacion desactivarlo.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=918475

 

 

 

En ningún momento indican que no sea conveniente utilizar esa opción. Tu problema está basado en el nivel de seguridad que implementa openssl en debian, y que el sitio desde donde intentas clonar las fuentes del software no cumplen el nivel de seguridad requerido por la configuarción de openssl en  debian. Es cuestión tuya deshabilitar dicha opción para "relajar" dicho nivel de seguridad, o de informar a los responsable del repositorio de mercurial que actualicen su configuración de seguridad (lo cual es justo lo que te dice el mensaje de error que recibes).

  No hay bar que por bien no venga....
Mar, 23/04/2019 - 03:43
Antonio
Imagen de Antonio
Desconectado/a
se unió: 21/01/18

Panko, gracias por aclararmelo. Ya dije que soy novato en todo esto.

Cuando pueda desabilitare esa opcion.

Gracias de nuevo.

Vive y deja vivir

Mar, 21/05/2019 - 13:49
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Y ya de paso, por cortesía, no estará de mas que les avises sobre este error que te da, para que

 espabilen y pongan al día sus certificados y sus niveles de seguridad ssl.

 (if this error persists, consider contacting the server operator  ...

     " (Si el error persiste, considere contactar con el operador del servidor  "