Sin poderes de root en sesion grafica

10 envíos / 0 nuevos
Último envío
#1 Mié, 29/08/2018 - 21:54
darkblacklife
Imagen de darkblacklife
Desconectado/a
colaborador
se unió: 23/02/16

Sin poderes de root en sesion grafica

Estado: 
[ACTIVO]

Hola, hice un update a debian sid de 64bit luego de 4 meses... Tratare de hacerme entender pero no se bien como definir mi problema

 

Me encuentro que si estando en sesión gráfica (cinnamon) como usuario normal abro una terminal (xterm por ejemplo), hago un 'su' y me logueo como root no puedo ejecutar aplicaciones como gparted, synaptic, aptitude, etc... y si quiero largar desde el menu alguna que requiera permisos de administrador (como gparted) no me acepta la contraseña de root para autenticar...

Lo raro es que si haciendo ctrl+alt+Fx me paso a una terminal de modo texto, me logueo como root y hago startx me abre un entorno gráfico donde ese problema no existe...

¿alguien sabe qué puede estar pasando?

Gracias

Mié, 29/08/2018 - 21:58
darkblacklife
Imagen de darkblacklife
Desconectado/a
colaborador
se unió: 23/02/16

Más especificamente me sale esto al querer ejecutar aplicaciones como root que requieran especialmente permisos de root

# gparted
bash: gparted: no se encontró la orden

 

con las aplicaciones que no requieren permiso de root no hay problema...

ExDebian - La mayor comunidad de Debian en español

 

Mié, 29/08/2018 - 22:10
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

con su podes hacer un :

apt update && apt upgrade

De no ser asi puede que con

su -

te funcione

Mié, 29/08/2018 - 22:25 (Responder a #3)
darkblacklife
Imagen de darkblacklife
Desconectado/a
colaborador
se unió: 23/02/16

rockyiii wrote:

con su podes hacer un :

apt update && apt upgrade

De no ser asi puede que con

su -

te funcione

Gracias por responder... Lo primero no ayudó... lo 2do sirve para loguearme como root y ejecutar aplicaciones que requieren permisos de root... PERO, las que son aplicaciones gráficas no me las corre y me tira cosas como

(synaptic:13520): Gtk-WARNING **: 22:22:19.424: cannot open display:
(gpartedbin:13578): Gtk-WARNING **: 22:22:36.110: cannot open display:

En cualquier caso antes podia correrlas logueandome como 'su' y desde el menu de la sesion gráfica...

 

ExDebian - La mayor comunidad de Debian en español

 

Mié, 29/08/2018 - 22:49
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

yo te decia de probar con su - porque hubo un cambio de política en debian sobre su.

podrias fijarte

echo "export PATH=$PATH:/usr/local/sbin:/usr/sbin:/sbin" >> /home/usuario/.bashrc

https://exdebian.org/foro/error-al-actualizar-dpkg-error-no-se-ha-encontrado-2-en-el-path-o-no-es-ejecutable-solucionado

Mié, 29/08/2018 - 23:34 (Responder a #5)
darkblacklife
Imagen de darkblacklife
Desconectado/a
colaborador
se unió: 23/02/16

rockyiii wrote:

yo te decia de probar con su - porque hubo un cambio de política en debian sobre su.

podrias fijarte

echo "export PATH=$PATH:/usr/local/sbin:/usr/sbin:/sbin" >> /home/usuario/.bashrc

https://exdebian.org/foro/error-al-actualizar-dpkg-error-no-se-ha-encontrado-2-en-el-path-o-no-es-ejecutable-solucionado

Sí señor, gracias, agregué eso en el usuario comun, abrir terminal y me logue con 'su' y no me sirvió, pero lo agregué en el .bashrc del root, me logué con 'su' y ahora andan esas aplicaciones... Lo que sigue sin andar cuando quiero largar aplicaciones como gparted con privilegios de usuario comun (desde terminal o menu del administrador gráfico), cuando em abre un cuadro de autenticación no me reconoce la contraseña de root para autenticar.... salvo que se requiera una contraseña distinta tipo contraseña de sudo o algo asi... ¿?

EDITO: Me respondo a mi mismo... resulta que en ese cuadro de autenticación uso la propia contraseña del usuario, no la de root, no se por que funciona así... en fin... ya quedo solucionado entonces

ExDebian - La mayor comunidad de Debian en español

 

Dom, 02/09/2018 - 14:13
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Antes, en las "generaciones" anteriores, en el entorno gráfico no te permitía ni logearte. Lo más que vi

 fue tener una ventana de terminal de root en el escritorio. Y eso era todo.

 Aclaraban que era por motivos de seguridad. Y me parece que en alguna tenías que editar no se que archivo

 para poder abrir una sesión gráfica como root.

 

 ¿Entonces todo esto ha cambiado ?, ¿Se puede entrar ya en el escritorio con loggin de root?

 

Sáb, 26/10/2019 - 14:56
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

He editado el comentario por incumplir las normas del foro .

....................................................................................................................................

..............................................................................................................................

Buenas tardes.

Yo tengo un problema similar. O quizá sea el mismo.........................................

................................................................................................................

21. No invadas o desvíes temas abiertos por otros usuarios
Si tienes una duda abre un nuevo tema, no hagas tu consulta en un tema abierto por otro usuario. No desvíes la conversación de la problemática inicial. 

https://exdebian.org/normas/normas-del-foro

Abrí tu propio tema con toda la información necesaria ,alguien seguramente te va a responder algo al respecto.

Sáb, 26/10/2019 - 16:46 (Responder a #8)
Fran
Imagen de Fran
Desconectado/a
se unió: 24/10/19

Ok. Moderador. Lo lamento.

Saludos!

Dom, 27/10/2019 - 10:28
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Como bien se dice arriba, las políticas de seguridad han ido cambiando, llegando estos cambios también a su y sudo. Básicamente, ahora mismo sudo se usa para dar poderes limitados a un usuario, y siempre usa su misma contraseña y además mantiene el PATH. su le da más poderes aún, usa la contraseña de root, y cambia ligeramente PATH y entorno, y su - da poderes totales y cambita completamente tanto PATH como el entorno.

Respecto al error del display que te aparecía, tienes dos soluciones, indicarselo antes con DISPLAY=:X en el mismo comando, siendo la X el display donde corre tu sesión gráfica (usualemente :0 o :1), o eliminar la restricción de acceso que viene configurda por defecto con el comando xhost (desde hace tiempo por motivos de seguridad, nada ni nadie, ni  siquiera root puede acceder a la sesión gráfica de un usuario, a excepción de aquellas apps que tengan configurados suid y gid para ello).

~$ xhost
access control enabled, only authorized clients can connect
SI:localuser:boinc
SI:localuser:panko

como se puede ver en la salida del comando, solo dos usuarios pueden acceder a mi  sesión, yo y boinc, al tener el control de acceso activado. Esto lo puedes cambiar añadiendo usuarios que tengan permisos, o usando xhost +/- para habilitar/deshabilitar el control de acceso

$ xhost -
access control enabled, only authorized clients can connect


$ xhost +
access control disabled, clients can connect from any host

Por añadir algo de info al  hilo, que siempre viene bien.

  No hay bar que por bien no venga....