VPN problemas con openvpn y version de ssl en firewall del servidor

1 envío / 0 nuevos
#1 Sáb, 02/11/2019 - 19:00
rasorm
Imagen de rasorm
Desconectado/a
se unió: 29/06/17

VPN problemas con openvpn y version de ssl en firewall del servidor

Estado: 
[SOLUCIONADO]

Buenas noches,

Recientemente tuve un problema con openvpn, debian 10 y un firewall antiguo.

Lo pongo en conocimiento por si a alguien le pasa lo mismo. No soy técnico pero a grandes rasgos puedo contarlo.

Cuando intentaba establecer la conexión VPN desde mi debian 10 (cliente) daba un error, el log me mostraba un error de versión en openssl, indicando que la del firewall (servidor) era antigua.

Tenía un problema, ya que el firewall era bastante antiguo y la versión que utilizaba de ssl no se podía actualizar. Así que no podía conectar a no ser que volviera a debian 9, que gastaba una version ssl compatible con mi firewall. Pero una vez en Debian10, me fastidiaba bastante tener que poner otra vez el 9.

Por suerte, el técnico informático decidió que era hora de cambiar el firewall para poner otro con balanceo de datos... bastante más moderno. Y para mi suerte este ya trae la versión ssl que resuelve varios problemas de seguridad y es compatible con la de ssl de Debian10.

Así que ya he podido conectar.

saludos

rasorm