Wifi no funciona en dispositivos USB en DEBIAN 9

22 envíos / 0 nuevos
Último envío
#1 Mié, 20/12/2017 - 08:24
setaseta
Imagen de setaseta
Desconectado/a
se unió: 20/12/17

Wifi no funciona en dispositivos USB en DEBIAN 9

Hola

Llevo usando Debian durante muchos años, y el otro día después de instalar Debian 9.3 no funcionaban los adaptadores externos de USB Wifi.

El caso que se podían ver todas los puntos de acceso ( las redes de alrededor) , pero cuando das para conectar e introducir la contraseña nunca llega a conectar.

Como había instalado antes las versiones 9.0  - 9.1 y 9.2 y las tenía aún en particiones, probé si se conectaba, y nada.

También por si las moscas probé en Debian 8 , y se conectaba perfectamente.

Tengo una colección de adaptadores wifi, y en todos pasa lo mismo, por lo cual es un error del propio Debian 9.

Como curiosidad, en ordenadores que tienen el adaptador wifi integrado (portátiles),  se conecta perfectamente. Pero si a ese mismo ordenador pinchas el adaptador wifi USB, para probarlo no se conecta con el adaptador pinchado.

Espero que alguien me de la solución.

 

Saludos

JUAN

Mié, 20/12/2017 - 12:43
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

¿Entorno gráfico?

¿Estas usando networkmanager?

¿Los adaptadores de red tienen distintos chipset o son todos de la misma familia?

¿Investigaste algo por tu cuenta ?¿intentaste algo ?

En fín para que alguien pueda darte alguna opinión, o consejo tenes que aportar la mayor parte de datos posibles para poder especular .

Por cierto la frase "espero que alguien me de la solución"  suena muy mal  por que nos convierte en 

un servicio de ayuda al usuario, lo cual es te foro NO es.Entiendo que ha sido un desliz involuntario de tu parte 

¿cierto?, y estas solicitando amablemente si alguien puede orientarte ¿no?.

Edito : A ver si esto te sirve de algo 

Edito(bis):Si otras opciones no funcionan ,podes intentar conectarte manualmente ,por que si no funciona te va a ser mas sencillo ver que errores indica.Una segunda ( y mas fácil ) opción para intentar descartar un problema con networmanager es  instalando wicd 

Mié, 20/12/2017 - 13:08
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Entre este enlace y este tan majete, con suerte te ahorras un hilo nuevo... y si no, con lo que hayas sacado de ahí podrás darnos la información que necesitamos y sabremos por donde empezar a echarte un cable...

un "esto no funciona" sin más, no ayuda mucho... puede ser hasta culpa de la junta de la trócola, o que se haya invertido el condensador de fluzo, quién s abe.

  No hay bar que por bien no venga....
Jue, 21/12/2017 - 09:59
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

!!!Atencion el siguiente comentario corresponde al usuario @setaseta , (lo edite para agregarle las etiquetas codigo )!!

-------------------------------------------------------------------------------------------------------------------------------------------

Hola

Entorno: Mate, Gnome, Xfce, LXLE.    Debian 9.x

Procesador : AMD  4G RAM

Adaptadores USB-Wifi:  Hago colección  (El problema aparece  en los 10 que tengo)

Programa de conexión: networkmanager

No hay mucho que probar...Si alguno dispone de USB-Wifi que pinche, pruebe y me diga si le pasa lo mismo.

Saludos

Juan

Salida de messages:
 

Dec 21 13:43:01 debian91sda4 kernel: [  363.586606] usb 1-1: new high-speed USB device number 6 using ehci-pci
Dec 21 13:43:01 debian91sda4 kernel: [  363.762581] usb 1-1: New USB device found, idVendor=148f, idProduct=3070
Dec 21 13:43:01 debian91sda4 kernel: [  363.762594] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Dec 21 13:43:01 debian91sda4 kernel: [  363.762601] usb 1-1: Product: 802.11 n WLAN
Dec 21 13:43:01 debian91sda4 kernel: [  363.762607] usb 1-1: Manufacturer: Ralink
Dec 21 13:43:01 debian91sda4 mtp-probe: checking bus 1, device 6: "/sys/devices/pci0000:00/0000:00:02.1/usb1/1-1"
Dec 21 13:43:01 debian91sda4 mtp-probe: bus: 1, device: 6 was not an MTP device
Dec 21 13:43:02 debian91sda4 kernel: [  364.302625] usb 1-1: reset high-speed USB device number 6 using ehci-pci
Dec 21 13:43:02 debian91sda4 kernel: [  364.460142] ieee80211 phy1: rt2x00_set_rt: Info - RT chipset 3070, rev 0201 detected
Dec 21 13:43:02 debian91sda4 kernel: [  364.490648] ieee80211 phy1: rt2x00_set_rf: Info - RF chipset 0005 detected
Dec 21 13:43:02 debian91sda4 NetworkManager[577]: <info>  [1513860182.5235] (wlan0): using nl80211 for WiFi device control
Dec 21 13:43:02 debian91sda4 NetworkManager[577]: <info>  [1513860182.5236] device (wlan0): driver supports Access Point (AP) mode
Dec 21 13:43:02 debian91sda4 NetworkManager[577]: <info>  [1513860182.5253] manager: (wlan0): new 802.11 WiFi device (/org/freedesktop/NetworkManager/Devices/4)
Dec 21 13:43:02 debian91sda4 kernel: [  364.507286] usbcore: registered new interface driver rt2800usb
Dec 21 13:43:02 debian91sda4 NetworkManager[577]: <info>  [1513860182.5405] rfkill1: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:02.1/usb1/1-1/1-1:1.0/ieee80211/phy1/rfkill1) (driver rt2800usb)
Dec 21 13:43:02 debian91sda4 kernel: [  364.530443] rt2800usb 1-1:1.0 wlx00a1b09042e8: renamed from wlan0
Dec 21 13:43:02 debian91sda4 NetworkManager[577]: <info>  [1513860182.5798] device (wlan0): interface index 4 renamed iface from 'wlan0' to 'wlx00a1b09042e8'
Dec 21 13:43:02 debian91sda4 NetworkManager[577]: <info>  [1513860182.5920] devices added (path: /sys/devices/pci0000:00/0000:00:02.1/usb1/1-1/1-1:1.0/net/wlx00a1b09042e8, iface: wlx00a1b09042e8)
Dec 21 13:43:02 debian91sda4 NetworkManager[577]: <info>  [1513860182.5921] device added (path: /sys/devices/pci0000:00/0000:00:02.1/usb1/1-1/1-1:1.0/net/wlx00a1b09042e8, iface: wlx00a1b09042e8): no ifupdown configuration found.
Dec 21 13:43:02 debian91sda4 NetworkManager[577]: <info>  [1513860182.5922] device (wlx00a1b09042e8): state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Dec 21 13:43:02 debian91sda4 kernel: [  364.568011] IPv6: ADDRCONF(NETDEV_UP): wlx00a1b09042e8: link is not ready
Dec 21 13:43:02 debian91sda4 kernel: [  364.568091] ieee80211 phy1: rt2x00lib_request_firmware: Info - Loading firmware file 'rt2870.bin'
Dec 21 13:43:02 debian91sda4 kernel: [  364.575461] rt2800usb 1-1:1.0: firmware: direct-loading firmware rt2870.bin
Dec 21 13:43:02 debian91sda4 kernel: [  364.575474] ieee80211 phy1: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.29
Dec 21 13:43:03 debian91sda4 kernel: [  364.993602] IPv6: ADDRCONF(NETDEV_UP): wlx00a1b09042e8: link is not ready
Dec 21 13:43:03 debian91sda4 NetworkManager[577]: <info>  [1513860183.0186] (wlx00a1b09042e8): using nl80211 for WiFi device control
Dec 21 13:43:03 debian91sda4 NetworkManager[577]: <info>  [1513860183.4423] device (wlx00a1b09042e8): set-hw-addr: set MAC address to DA:FF:F2:90:74:04 (scanning)
Dec 21 13:43:03 debian91sda4 kernel: [  365.891453] IPv6: ADDRCONF(NETDEV_UP): wlx00a1b09042e8: link is not ready
Dec 21 13:43:03 debian91sda4 NetworkManager[577]: <info>  [1513860183.9709] sup-iface[0x80c88d80,wlx00a1b09042e8]: supports 4 scan SSIDs
Dec 21 13:43:03 debian91sda4 NetworkManager[577]: <info>  [1513860183.9730] device (wlx00a1b09042e8): supplicant interface state: starting -> ready
Dec 21 13:43:03 debian91sda4 NetworkManager[577]: <info>  [1513860183.9731] device (wlx00a1b09042e8): state change: unavailable -> disconnected (reason 'supplicant-available') [20 30 42]
Dec 21 13:43:03 debian91sda4 kernel: [  365.948964] IPv6: ADDRCONF(NETDEV_UP): wlx00a1b09042e8: link is not ready
Dec 21 13:43:05 debian91sda4 NetworkManager[577]: <info>  [1513860185.3428] device (wlx00a1b09042e8): supplicant interface state: ready -> inactive
Dec 21 13:43:21 debian91sda4 NetworkManager[577]: <info>  [1513860201.0780] device (wlx00a1b09042e8): Activation: starting connection 'setamodem3' (7f36ec2e-59db-4f02-8505-c1273ce15b39)
Dec 21 13:43:21 debian91sda4 NetworkManager[577]: <info>  [1513860201.0795] audit: op="connection-activate" uuid="7f36ec2e-59db-4f02-8505-c1273ce15b39" name="setamodem3" pid=1206 uid=1000 result="success"
Dec 21 13:43:21 debian91sda4 NetworkManager[577]: <info>  [1513860201.0808] device (wlx00a1b09042e8): state change: disconnected -> prepare (reason 'none') [30 40 0]
Dec 21 13:43:21 debian91sda4 NetworkManager[577]: <info>  [1513860201.5014] device (wlx00a1b09042e8): set-hw-addr: reset MAC address to 00:A1:B0:90:42:E8 (preserve)
Dec 21 13:43:21 debian91sda4 kernel: [  383.890728] IPv6: ADDRCONF(NETDEV_UP): wlx00a1b09042e8: link is not ready
Dec 21 13:43:21 debian91sda4 NetworkManager[577]: <info>  [1513860201.9205] device (wlx00a1b09042e8): state change: prepare -> config (reason 'none') [40 50 0]
Dec 21 13:43:21 debian91sda4 NetworkManager[577]: <info>  [1513860201.9218] device (wlx00a1b09042e8): Activation: (wifi) access point 'setamodem3' has security, but secrets are required.
Dec 21 13:43:21 debian91sda4 NetworkManager[577]: <info>  [1513860201.9225] device (wlx00a1b09042e8): state change: config -> need-auth (reason 'none') [50 60 0]
Dec 21 13:43:21 debian91sda4 NetworkManager[577]: <info>  [1513860201.9311] device (wlx00a1b09042e8): state change: need-auth -> prepare (reason 'none') [60 40 0]
Dec 21 13:43:21 debian91sda4 NetworkManager[577]: <info>  [1513860201.9332] device (wlx00a1b09042e8): state change: prepare -> config (reason 'none') [40 50 0]
Dec 21 13:43:21 debian91sda4 NetworkManager[577]: <info>  [1513860201.9349] device (wlx00a1b09042e8): Activation: (wifi) connection 'setamodem3' has security, and secrets exist.  No new secrets needed.
Dec 21 13:43:21 debian91sda4 NetworkManager[577]: <info>  [1513860201.9355] Config: added 'ssid' value 'setamodem3'
Dec 21 13:43:21 debian91sda4 NetworkManager[577]: <info>  [1513860201.9365] Config: added 'scan_ssid' value '1'
Dec 21 13:43:21 debian91sda4 NetworkManager[577]: <info>  [1513860201.9372] Config: added 'key_mgmt' value 'WPA-PSK'
Dec 21 13:43:21 debian91sda4 NetworkManager[577]: <info>  [1513860201.9376] Config: added 'auth_alg' value 'OPEN'
Dec 21 13:43:21 debian91sda4 NetworkManager[577]: <info>  [1513860201.9381] Config: added 'psk' value '<hidden>'
Dec 21 13:43:21 debian91sda4 NetworkManager[577]: <info>  [1513860201.9656] device (wlx00a1b09042e8): supplicant interface state: inactive -> scanning
Dec 21 13:43:23 debian91sda4 kernel: [  385.235328] wlx00a1b09042e8: authenticate with c4:a3:66:cc:e7:7e
Dec 21 13:43:23 debian91sda4 kernel: [  385.305614] wlx00a1b09042e8: send auth to c4:a3:66:cc:e7:7e (try 1/3)
Dec 21 13:43:23 debian91sda4 kernel: [  385.308474] wlx00a1b09042e8: authenticated
Dec 21 13:43:23 debian91sda4 NetworkManager[577]: <info>  [1513860203.3414] device (wlx00a1b09042e8): supplicant interface state: scanning -> authenticating
Dec 21 13:43:28 debian91sda4 NetworkManager[577]: <info>  [1513860208.4094] device (wlx00a1b09042e8): supplicant interface state: authenticating -> disconnected
Dec 21 13:43:28 debian91sda4 NetworkManager[577]: <info>  [1513860208.5106] device (wlx00a1b09042e8): supplicant interface state: disconnected -> scanning
Dec 21 13:43:29 debian91sda4 kernel: [  391.842584] wlx00a1b09042e8: authenticate with c4:a3:66:cc:e7:7e
Dec 21 13:43:29 debian91sda4 kernel: [  391.932800] wlx00a1b09042e8: send auth to c4:a3:66:cc:e7:7e (try 1/3)
Dec 21 13:43:29 debian91sda4 NetworkManager[577]: <info>  [1513860209.9668] device (wlx00a1b09042e8): supplicant interface state: scanning -> authenticating
Dec 21 13:43:29 debian91sda4 kernel: [  391.952667] wlx00a1b09042e8: authenticated
Dec 21 13:43:34 debian91sda4 kernel: [  396.933984] wlx00a1b09042e8: aborting authentication with c4:a3:66:cc:e7:7e by local choice (Reason: 3=DEAUTH_LEAVING)
Dec 21 13:43:35 debian91sda4 NetworkManager[577]: <info>  [1513860215.0176] device (wlx00a1b09042e8): supplicant interface state: authenticating -> disconnected
Dec 21 13:43:35 debian91sda4 NetworkManager[577]: <info>  [1513860215.5182] device (wlx00a1b09042e8): supplicant interface state: disconnected -> scanning
Dec 21 13:43:36 debian91sda4 kernel: [  398.827726] wlx00a1b09042e8: authenticate with c4:a3:66:cc:e7:7e
Dec 21 13:43:36 debian91sda4 kernel: [  398.915787] wlx00a1b09042e8: send auth to c4:a3:66:cc:e7:7e (try 1/3)
Dec 21 13:43:36 debian91sda4 kernel: [  398.918486] wlx00a1b09042e8: authenticated
Dec 21 13:43:36 debian91sda4 NetworkManager[577]: <info>  [1513860216.9457] device (wlx00a1b09042e8): supplicant interface state: scanning -> authenticating
Dec 21 13:43:41 debian91sda4 kernel: [  403.918114] wlx00a1b09042e8: aborting authentication with c4:a3:66:cc:e7:7e by local choice (Reason: 3=DEAUTH_LEAVING)
Dec 21 13:43:41 debian91sda4 NetworkManager[577]: <info>  [1513860221.9971] device (wlx00a1b09042e8): supplicant interface state: authenticating -> disconnected
Dec 21 13:43:42 debian91sda4 NetworkManager[577]: <info>  [1513860222.9982] device (wlx00a1b09042e8): supplicant interface state: disconnected -> scanning
Dec 21 13:43:44 debian91sda4 kernel: [  406.320049] wlx00a1b09042e8: authenticate with c4:a3:66:cc:e7:7e
Dec 21 13:43:44 debian91sda4 NetworkManager[577]: <info>  [1513860224.4460] device (wlx00a1b09042e8): supplicant interface state: scanning -> authenticating
Dec 21 13:43:44 debian91sda4 kernel: [  406.419720] wlx00a1b09042e8: send auth to c4:a3:66:cc:e7:7e (try 1/3)
Dec 21 13:43:44 debian91sda4 kernel: [  406.442347] wlx00a1b09042e8: authenticated
Dec 21 13:43:47 debian91sda4 NetworkManager[577]: <warn>  [1513860227.1335] device (wlx00a1b09042e8): Activation: (wifi) association took too long, failing activation
Dec 21 13:43:47 debian91sda4 NetworkManager[577]: <info>  [1513860227.1336] device (wlx00a1b09042e8): state change: config -> failed (reason 'ssid-not-found') [50 120 53]
Dec 21 13:43:47 debian91sda4 NetworkManager[577]: <warn>  [1513860227.1358] device (wlx00a1b09042e8): Activation: failed for connection 'setamodem3'
Dec 21 13:43:47 debian91sda4 NetworkManager[577]: <warn>  [1513860227.1463] sup-iface[0x80c88d80,wlx00a1b09042e8]: connection disconnected (reason -3)
Dec 21 13:43:47 debian91sda4 NetworkManager[577]: <info>  [1513860227.1465] device (wlx00a1b09042e8): supplicant interface state: authenticating -> disconnected
Dec 21 13:43:47 debian91sda4 NetworkManager[577]: <info>  [1513860227.1469] device (wlx00a1b09042e8): state change: failed -> disconnected (reason 'none') [120 30 0]
Dec 21 13:43:47 debian91sda4 kernel: [  409.125535] IPv6: ADDRCONF(NETDEV_UP): wlx00a1b09042e8: link is not ready
Dec 21 13:43:47 debian91sda4 NetworkManager[577]: <info>  [1513860227.5827] device (wlx00a1b09042e8): set-hw-addr: set MAC address to 8A:F2:8F:85:4F:45 (scanning)
Dec 21 13:43:48 debian91sda4 kernel: [  409.992270] IPv6: ADDRCONF(NETDEV_UP): wlx00a1b09042e8: link is not ready

 

Jue, 21/12/2017 - 12:48
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

¿Intentaste lo del enlace que te puse ?

¿Intentaste usar wicd a ver que ocurre ? 

Por cierto, sí tenes mucho para probar dado que tenes un problema, no veo el modo que lo soluciones si no buscas alternativas para probar y lo intentas .

Jue, 21/12/2017 - 14:16
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Tengo un par, bueno, en realidad he llegado a probar con 6 diferentes, con diferentes chips (realtek, zydas, atheros) y ninguno me ha dado problemas, todos funcionan a la primera mientras tengan el firmware instalado si es que lo necesitan). No nos sirve que digas "tengo 10", esos 10, posiblemente se puedan reducir a 3 ó 4, ya que muchos usarán el mismo chip o uno similar (lo más extendido es rtl/realtek, y atheros, algun que otro broadcom/bcm y algún zydas, así que puedes tener 20 si quieres, que en realidad tienes 5 distintos como mucho).

¿Ese log es todo del mismo adaptador wifi? Si es así, veo que tiene activado "mac.randomize". Esta opción, incluída en las últimas versiones de wpasupplicant (y recientemente también añadido soporte a NetworkManager) puede hacer que algunos disopositivos wifi no funcionen correctamente (sobre todo bcm y alguno que use el drive wl, que no veo que sea tu caso). Esta opción, tiene dos modos de funcionamiento. El primero, hace que se cambie la mac del dispositivo cuando se realiza el escaneo de redes, y luego vuelva a cambiarla cuando se hace/intenta la conexión. El segundo, solo cambia la mac cuando se hace la conexión. Hay un bug reportado al respecto contra wpasupplicant por esta misma razón

Nos vendría bien saber que chip usa cada usb-wifi que tienes (ahi solo veo un rtl, que además tiene su firmware instalado). También veo un cambio entre unmanaged a unavailable (reason managed), nos vendría bien saber el contenido de tu archivo /etc/network/interfaces, así como el de /etc/NetworkManager/NetworkManager.conf, y el de /etc/NetworkManager/conf.d/20-mac-address.conf si por casualidad existiera (éste último nombre puede cambiar, o simplemente no existir el archivo).

Otra cosa que sí puedo decirte: Network-Manager tiene cierto problemilla, almenos en mi caso, y es que es incapaz de cambiar de una conexión a otra. Es decir, si está conectado y tratas de cambiar a otra red wifi, no consigue hacer la conexión, hay que desconectarlo primero y luego conectarlo a la nueva (por si diera la casualidad que es tu caso).

Utliza los botones de formato que tienes en la parte de arriba, en concreto el de "Insertar fragmento de código" (el que está a la izquierda de las comillas) para poner los datos aqui...

  No hay bar que por bien no venga....
Sáb, 23/12/2017 - 03:25
setaseta
Imagen de setaseta
Desconectado/a
se unió: 20/12/17

Hola otra vez

Los módulos cargados de los diferentes CHIP son:

usbcore               184320  16 ath9k_htc,usbhid,rt73usb,rt2800usb,usb_storage,rt2x00usb,ehci_hcd,ohci_pci,zd1211rw,r8188eu,xhci_pci,uas,ohci_hcd,rtl8187,xhci_hcd,ehci_pci

Creo que podemos descartar que usen el mismo módulo.

Tenía la foto de los 12 adaptadores Usb-Wifi pero no se insertarla.

Vuelvo a repetir:

Como curiosidad, en ordenadores que tienen el adaptador wifi integrado (portátiles),  se conecta perfectamente. Pero si a ese mismo ordenador pinchas el adaptador wifi USB, para probarlo no se conecta con el adaptador pinchado.

Saludos

JUAN

 

Sáb, 23/12/2017 - 05:01
setaseta
Imagen de setaseta
Desconectado/a
se unió: 20/12/17

Hola

Por fin he dado con la solución.

De serie Debian 9.x  tiene activado "mac.randomize"  en la configuración de NetworkManager.  lo cual impide la conexión de dispositivos USB-Wifi.

Para cambiarlo añadir en /etc/NetworkManager/NetworkManager.conf

[device]
wifi.scan-rand-mac-address=no

 

Lo que no entiendo como alguien se ha conectado con USB-Wifi  si no modifico esto. ?¿?¿?¿

 

Saludos

JUAN

Sáb, 23/12/2017 - 10:39
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Pues precisamente acerca de mac.randomize te había hablado en mi última contestación... y, además, no tengo eso puesto en dicho archivo de configuración y si se me conecta cualquier wifi usb hasta el momento, en mi caso tengo una realtek, una atheros, y otra que usa el driver zydas... Lo único, lo que te dije, que posiblemente, con esa opción, no sea capaz de cambiar de red si no se desconecta antes la otra, lo cual podría ser tu caso si tuvieras la interna conectada ya a una red.

  No hay bar que por bien no venga....
Sáb, 23/12/2017 - 12:53
setaseta
Imagen de setaseta
Desconectado/a
se unió: 20/12/17

Hola

La idea de mirar lo de mac.randomize me la diste tu, y eso es lo que hice mirar por internet.

He probado lo de tener todas las redes desconectadas e intentar conectar con el pincho de USB-Wifi y nada sigue sin conectar.

Lo que si funciona es añadir en /etc/NetworkManager/NetworkManager.conf

[device]
wifi.scan-rand-mac-address=no

 

Hago reiniciar las redes con:

/etc/init.d/network-manager restart

/etc/init.d/networking restart

 

Ahora funciona y ya puedo probar todos mis adaptadores USB-WIFI

Gracias por todo, hasta el próximo problema. Este Debian 9.x es de lo mas curioso, 4 versiones en 6 meses.

 

JUAN

 

Sáb, 23/12/2017 - 13:18
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

En mi primera contestación , te puse este enlace donde  se indica esa solución

Edit NetworkManager config file
 sudo nano /etc/NetworkManager/NetworkManager.conf
Now add below lines to the file


[device]
wifi.scan-rand-mac-address=no

, Supongo que ni vale la pena que me moleste en poner enlaces para que alguien los lea ( ¿leer ,horror!!!)

Sáb, 23/12/2017 - 16:39
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Pobre @caliban , que naide le hace caso... ya sabes como va esto, que somos veteranos ya xD

Respecto al hilo, igual que él mismo ya te había dado la pista, te aclaro algo que ya he dicho. Ahora, la MAC de los dispositivos se cambia "automágicamente" si quieres a cada conexión, con lo que adquieres algo más de privacidad, sobre todo si te conectas a redes que no son la tuya, como puede ser la de un amigo, la del trabajo, la de la biblioteca donde vayas a estudiar... Este asunto tiene dos modos de funcionar, cambiar la mac cuando hace el escaneo de redes, y cambiar la mac cuando se va a conectar a una. En tu caso, ha sido el primer modo de funcionar el que ha impedido que se realizara la conexión. Es decir, escanear las redes existentes con una mac randomizada, y conectarte a ellas con otra mac (randomizada o real). Hay incluso un bug reportado contra  wpasupplicant si mal no recuerdo, que creo ya he comentado, con algunos dispositivos en la blacklist para que no se use éste método con ellos. Creo que, si no está reportado, podrías hacerlo tu mismo usando la herramienta reportbug-ng (que, además, te permitirá buscar si está reportado el bug contra wpasupplicant o NetworkManager y añadir información al mismo, o simplemente crear un reporte nuevo si no está reportado ya).

 

  No hay bar que por bien no venga....
Sáb, 23/12/2017 - 17:29
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Snif, snif,  eso nadie me hace caso , ahora me ofendo y presento mi renuncia indeclinable!!! :þ

(La culpa de todo la tiene rockyIII )

Mis disculpas por invadir el hilo con idioteces ,pero tenía que hacer catársis 

Sáb, 23/12/2017 - 19:19
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

Saludos Panko,

Esa funcionalidad (direcciones MAC aleatorias) de NetworkManager, depende de la versión 2.6 de wpa_supplicant ... Versión que no existe en Stretch o Buster ... Posiblemente no se trate de un fallo/issue.

Para mas detalles lean el blog de Thomas Haller's y Lubomir Rintels.

PD: Investiguen si su hardware es capaz de soportar " MAC Address randomization".

Dom, 24/12/2017 - 11:35 (Responder a #14)
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Berbellon wrote:
Saludos Panko, Esa funcionalidad (direcciones MAC aleatorias) de NetworkManager, depende de la versión 2.6 de wpa_supplicant ... Versión que no existe en Stretch o Buster ... Posiblemente no se trate de un fallo/issue. Para mas detalles lean el blog de Thomas Haller's y Lubomir Rintels. PD: Investiguen si su hardware es capaz de soportar " MAC Address randomization".

Opción que si soporta network-manager, aún no estando activada en otras versiones de wpasupplicant, por eso insistí en el asunto. No es el primer caso, ni será el último, seguro :p

  No hay bar que por bien no venga....
Dom, 24/12/2017 - 17:22
setaseta
Imagen de setaseta
Desconectado/a
se unió: 20/12/17

Hola

Perdona no haber visto el enlace de esto .

Pero te pareces a mi mujer, ;) después de 1000 palabras que te dice, entre medias te dice algo importante, y pretende que te enteres de lo importante. Pero yo me desconecto a las 700 palabras, soy demasiado simple.

Siempre le digo, Dime lo importante al principio, y luego cuéntame la paja.

A mi mujer la quiero mucho.

Saludos

JUAN

Dom, 24/12/2017 - 17:37
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

No fueron mil palabras ,si no mas bien algunos comentarios respecto a tu modo de preguntar y a la falta de ciertos datos .

Si por sintético y concreto se trata  hubieras comenzado vos siéndolo con los datos necesarios , y por ejemplo ,limpiar de polvo y paja el log y pegando aca solo la parte necesaria y los errores.

Como ves , todos necesitamos un contexto para explicar algo ,y te incluye

Creo que estas confundido y crees que esto es un foro de ayuda al usuario O sea  presto una solución concreta a un problema planteado  y no es el caso .

Por cierto me tomo cinco minutos encontrar el enlace que te puse ¿cuanto te tomo a vos buscar ?

 

Lun, 25/12/2017 - 19:52 (Responder a #17)
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

Panko wrote:

Berbellon wrote:
Saludos Panko, Esa funcionalidad (direcciones MAC aleatorias) de NetworkManager, depende de la versión 2.6 de wpa_supplicant ... Versión que no existe en Stretch o Buster ... Posiblemente no se trate de un fallo/issue. Para mas detalles lean el blog de Thomas Haller's y Lubomir Rintels. PD: Investiguen si su hardware es capaz de soportar " MAC Address randomization".

Opción que si soporta network-manager, aún no estando activada en otras versiones de wpasupplicant, por eso insistí en el asunto. No es el primer caso, ni será el último, seguro :p

Más temas con el título "No tengo WIFI", jejejeje.

Mar, 26/12/2017 - 09:07
setaseta
Imagen de setaseta
Desconectado/a
se unió: 20/12/17

Hola

Remitir un problema que le va ocurrir al  100% de personas que tenga un PC fijo (o portatil) , y que intente conectar mediante un adaptador USB-WIFI , creo que es importante.

Mi error fue quizás hacer la búsqueda solo en español y no en ingles. Ahora si aparece en español referenciando a este foro.

Dejemos estas discusiones que no conducen a nada, y solo sirven para no avanzar.

Saludos

JUAN

Mié, 27/12/2017 - 10:43
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Hombre, al 100%.... ¿no crees que tendríamos varias preguntas en el foro sobre el tema y no solo la tuya? Por las mismas versiones de paquetes que tiene debian 9 he pasado yo (uso la rama unstable, así que ahora ya voy mas adelantado), y nunca me ha pasado eso que dices...

  No hay bar que por bien no venga....
Sáb, 17/08/2019 - 19:15
Victor man
Imagen de Victor man
Desconectado/a
se unió: 17/08/19