Sin aplicaciones que clickar. [Solucionado]

12 envíos / 0 nuevos
Último envío
#1 Dom, 07/05/2017 - 14:26
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

Sin aplicaciones que clickar. [Solucionado]

Estado: 
[SOLUCIONADO]

 Hoy soy yo el que pregunta sobre instalaciones.

 Tengo un portátil (compaq evo n600c), que aunque antiguo, con sus 1'2 Ghz y su Gb ram,
 es capaz de correr un jessie normal con el escritorio mate. No será rápido, pero funciona.
 Es por cierto ese que tiene una partición msdos y que anteriormente al instalar jessie
 me lo lió todo y tuve que reparticionar y reinstalar el dos, por lo que desde entonces
 ha tenido que conformarse con usar el linux de forma indirecta, sin tocar los arranques
 ni el setup del disco.

 Ahora, tras una pequeña reestructuración, he decidido probar de nuevo, montando un debian 8.x
 en 2 particiones ( / y /home).
 Lo estoy haciendo desde dvd .iso en dos particiones lógicas ext4, pero por alguna razón este ordenador

 parece estar disfrutando en romperme todas las instalaciones.

 Con el 8.7 me empezaba a dar extraños errores de disco (dvd), a pesar de ser correcto y de
 haber ejecutado "comprobar integridad del disco" hasta 4 ó 5 veces seguidas diciendome siempre
 que todo estaba perfecto. ( ?? !).
 Con el 8.0 al menos me he librado de eso, y es el que tuvo antes. (y funcionaba).
 Aún asi, al instalar, una vez me pierde algún paquete que había cargado bien y se rompe la instalación.
 Otras me configura mal algún paquete, empieza a arrastrar defectos de configuración de otros
 paquetes dependientes, y se va haciendo la bola hasta que rompe la instalación por exceso de
 dependencias incumplidas.
 Una vez hasta se me quedó clavado el instalador, - cuando estaba ya al 95% de la instalación total -.
 Podías acceder a las dos cónsolas de comandos, ejecutar cosas, el log seguía registrando,
 todo normal, pero el instalador (alt+f1) se quedó congelado sin responder a nada.
 !!

 Por tanto decidí, otro intento instalando el sistema base, configurar el apt, y como
 los probemas siempre surjen al "instalar y configurar los paquetes seleccionados",
 desde "configurar el apt" saltar a la instalación del grub y "finalizar"
 Una vez arrancada la nueva instalación, mandé tasksel, que es en esencia lo que hace el cd/dvd.
 
 Aunque tuvo un final un poco raro, la barra marcaba el 100% y me devolvió el prompt sin ningún
 error ni comentario.
 Efectivamente, al reiniciar, mando startx, arranca el servidor x, me lleva al login gráfico,
 y al escritorio.
 Todo esta perfecto, su fondo, sus iconos, sus barras, sus carpetas, sus menús.
 Sin embargo ...  Cuando paso al menu de "aplicaciones", ... no hay nada que desplegar, está vacio!!.
 Con una mirada más atenta al menu de la derecha veo que tampoco está la linea que me daria acceso
 a cosas como el synaptic, todo está en marcha, pero no hay ni una maldita linea para acceso
 a ninguna aplicación, ni una en absoluto!!.

 ¿A alguien le ha pasado alguna vez, como lo arregló?. ¿Por donde tendría que empezar?.
 ¿Algún dpkg -i,  liarme con algún registro,  o reinstalar algo desde la cónsola?.
 ¿Pero que y como?, no tengo ni idea de por donde empezar en un caso como este, y antes de
 echarlo todo abajo y empezar de nuevo desde cero, a ver si puedo enterarme de algo nuevo.

 Porque además es curioso que en el mismo disco y ordenador le he hecho la misma instalación
 pero en una sola partición, (pequeña, solo prueba), y me la ha hecho bien a la primera.
 (!! ??)

 

Dom, 07/05/2017 - 15:28
Devoto
Imagen de Devoto
Desconectado/a
colaborador
se unió: 17/04/16

¿Y ya has mirado tu sources.list?, a mi me paso algo similar a ti pero con Lenny. No podía hacer casi nada por los errores y al final use apt para instalar manualmente todo lo que me hacia falta. Y después de eso funcionaba bien el sistema...

 

Pero, ¿y que errores te da cuando intentas abrir algo desde la terminal?, tal vez una captura de pantalla nos muestre que puede haber salido mal.

devoto - El amor ocupa devoción.

Dom, 07/05/2017 - 18:22
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

Advertencia: Mate 1.16.1 en Slackware 14.2.

Uso un portátil del 2004, aunque tengo acceso a la unidad óptica, en ocasiones hay errores de lectura (no puedo confiar en una instalación desde este medio). El HDD pasa una revisión "smart", pero ya contiene 12 sectores defectuosos, no ha aumentado hasta la fecha actual.

Si un IDE soporta hasta 4 particiones primarias, porque instalas en particiones logicas. Debian ya soporta este tipo de particiones para su instalación.

Pasando al asunto, verifica (1) /usr/share/applications/ , (2) ~/.local/share/applications/ . Puedes lanzar aplicaciones desde Alt + F2, las típicas del escritorio mate, pluma, etc. (otras, firefox).

Respalda los archivos de ~/.config/menus/ (En Slack, mate-applications.menu,  mate-settings.menu), rm -r ~/.config/menus, reinicia mate.

Esto es lo que contiene mate-applications.menu

<?xml version="1.0" ?>
<!DOCTYPE Menu
  PUBLIC '-//freedesktop//DTD Menu 1.0//EN'
  'http://standards.freedesktop.org/menu-spec/menu-1.0.dtd'>
<Menu>
	<Name>Applications</Name>
	<MergeFile type="parent">/etc/xdg/menus/mate-applications.menu</MergeFile>
</Menu>

Esto es lo que observo en

[15:20 nikita@berbellon ~] > ls /etc/xdg/menus/
lxde-applications.menu            mate-settings.menu
mate-applications.menu            matecc.menu
mate-preferences-categories.menu  xfce-applications.menu

Si no observas nada, reinstala el paquete, mate-menus-1.16.0-i586-1gv [inst=sí]: mate-menus (MATE Menu Layout)

PD 1: Puedes sustituir "marco window manager", por, "openbox" u  otros.

PD 2: Si usas un sistema MS-DOS, porque no instalas desde ahí. ¿?

Mar, 09/05/2017 - 14:14
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 @ Devoto: Es que instalo desde dvd porque este es un sistema offline, por lo tanto suelo dejar los

 sources tal como vengan.

 

 @ Berbellon:  Gracias, ire mirando todo eso, y a ver si pillo lo que es.

    Si un IDE soporta hasta 4 particiones primarias, porque instalas en particiones logicas. Debian ya soporta este tipo de particiones para su instalación.

  Si, la verdad es que si. Quizás sea por la costumbre, desde el principio siempre las he visto en particiones

  extendidas. Tal vez se me haría raro ver un linux por debajo del 5.

  Del otro lado, si no ocupo las 4 tengo mas espacio para otras cosas que se me ocurra poner aparte. wink

 

  PD 2: Si usas un sistema MS-DOS, porque no instalas desde ahí. ¿?

  Pues ya que lo dices, nunca me lo he planteado hasta ahora. indecision

  Claro que dado el tamaño que suelen tener, ¿quieres decir que cabría todo un instalador y lo que lleva con el?.

  Esta partición, tiene 512 Mb, pero para ms-dos, como max 2 Gb.  -Si es "a la última y sin barreras de disco"-.

 

  Advertencia: Mate 1.16.1 en Slackware 14.2.

  Ah, gracias. Aunque por ahora como "segundo de a bordo", slackware sería la solución solo en caso

  de emergencia.   (Aunque en alguna prueba que hice parecia no dar problemas).

  Actualmente estoy con debian. smiley

 

   

Dom, 14/05/2017 - 14:03
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 Hola.

 Ya va saliendo que es lo que falta.  /usr/share/aplications/  esta efectivamente lleno de ficheros *.desktop,  imagino que es correcto.
 En cambio, el directorio  -/.local/share/applications  parece no haberse presentado.

En  .local/share/  solo veo  gvfs-metadata y keyrings, y dos ficheros,  recently-used.xbel y .converted launchers, que por cierto está vacío, (0 bytes).

 En cuanto a  -/.config/menus/  tampoco está, solo veo  user-dirs.dirs (638 bytes)  y user-dirs.locale (10 bytes),
 asi como los subdirectorios  dconf, caja, pluma, y pulse .  No parece haber nada mas.
 ¿He de crear el subdirectorio, dejarlo vacío, y reiniciar el servidor gráfico y entrada al escritorio, o mejor que lance otras cosas antes?
 
 Y en  /etc/xdg/menus/  tengo:  mate-applications.menu.dpkg-new,  mate-settings.menu.dpkg-new,  matecc.menu.dpkg-new,

 mate-screensavers.menu,  mate-screensavers.menu.dpkg-new,   pero no el  mate-perferences-categories.menu,

(no he podido aún elegir preferences), ni los escritorios lxde ni xfce, que no fueron seleccionados, solo mate.
 También hay el softlink  debian-menu.menu  que según pone apunta a  /var/lib/menu-xdg/menus/debian-menu.menu
 
 ¿Servirá de algo ordenar el   dpkg-i mate-menus-1.16.0-586-1gv [inst=si]: mate-menus (Mate Menu Layout)   que dices,

 o si están los archivos descritos no añadirán nada nuevo que solucione el problema?.
 
 

Dom, 14/05/2017 - 16:54 (Responder a #5)
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

Percontator wrote:
Y en  /etc/xdg/menus/  tengo:  mate-applications.menu.dpkg-new,  mate-settings.menu.dpkg-new,  matecc.menu.dpkg-new, mate-screensavers.menu.dpkg-new
 

Una falla de dpkg.

"The first hint comes from the file extension “.dpkg-new”. This extension is used by dpkg to unpack the updated files near the old files. When everything has been unpacked, they are renamed over the old files.

The failure happens precisely when dpkg tries to rename the file (in fact when it tries to fsync() it before the rename)"

En el directorio /etc/, observas archivos con extensión *.dpkg-new.

Porque no remueve y purgas mate, e instalas según su wiki:

MATE 1.8.1 is currently packaged for Debian 8 (jessie). MATE 1.12 is also available on Debian testing (“Stretch”) and unstable (“Sid”).

(If sudo is unavailable on your system, simply omit it and use a root shell) 
First make sure your package list is up-to-date by running:

sudo apt-get update
To install MATE, choose one of the apt-get options below.

This will install the base packages required for a minimal MATE desktop
sudo apt-get install mate-desktop-environment-core
This will install the complete MATE desktop
sudo apt-get install mate-desktop-environment
This will install the complete MATE desktop including a few extras
sudo apt-get install mate-desktop-environment-extras

Suerte.

Dom, 14/05/2017 - 16:58
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

PD: No se olvide de limpiar la cache antes de realizar alguna instalación .....

PD2: Prestar atención a la terminal cuando se utilice .....

Lun, 15/05/2017 - 12:12
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Voy a reiterar lo dicho varias veces en el foro, LEERSE LAS NORMAS 

5. Escribe con propiedad
El cuerpo del mensaje debe estar bien redactado: Escribe con propiedad, usando signos de puntuación y evitando en la medida de lo posible faltas de ortografía y gramática, no abuses del resaltado (negrita y/o colores), esto indica que estás metiendo prisa, así como escribir en mayúsculas, ya que indica que estás gritando. No uses abreviaturas típicas de los SMS. Usa párrafos e intenta ser extremadamente claro con el problema, añadiendo toda la información que pueda ser oportuna. Los usuarios de este foro son hispanohablantes, por lo tanto usa el español.

Sí van a poner un texto en otro idioma,corresponde que se ponga una traducción del mismo.

Voy a comenzar a borrar los textos en otro idioma que no se acompañen con su traducción .

Mar, 16/05/2017 - 14:13
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Una falla de dpkg.  Pues vaya, que suerte que tengo!, nunca me ha fallado y ahora lo hace a lo grande.

 

 Intentaré lo que dices. A ver si me aclaro, ... o lo lio más.

 

 Gracias.

 

  ( Aunque el apt-get no se si me lo aceptará fuera de línea.  (offline). )

 

 

Dom, 21/05/2017 - 14:08
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 
 Pues si. Esta vez apt-get me sirvió correctamente. :)
 Primero ordene apt-get autoclean, seguido de apt-get clean ...por si acaso.
 Luego inserté el disco de instalación y me fui al subdirectorio del mate,  (pool/main/m).
 Desde alli ordené el apt-get install mate-desktop-environment.
 Y a partir de aquí, un buen rato de contemplar los "configurando xxxxxxx", y si
 me pregunta "conservar script o instalar nuevo?", elegir la opción por defecto.

 Y ya está, ya tengo rellenados los menús de aplicaciones.
 Hubo un pequeño problemilla con un par de ficheros del python 3, que implicaron a orca,
 pero teniendo lo otro no creo que sea nada del otro mundo, cuestión de satisfacer
 la dependencia, synaptic o dpkg y ya estará,  aunque no suelo usar orca.

 Gracias por la guia.

 

 Una pregunta adicional: Todos esos mensajes que van apareciendo, con sus "configurando",
 sus explicaciones, sus preguntas, sus warning, etc, ¿en que log de que subdirectorio se guardan?.

 

Mié, 31/05/2017 - 19:46
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

/var/log/dpkg (sería el más completo), /var/log/apt/history.log y term.log (si has usado apt), /var/log/aptitude (si has usado aptitude).

Si lo que quieres es ver exactamente lo que aparece en la consola tal y como lo vas viendo tu, debería de ser /var/log/apt/term.log

 

  No hay bar que por bien no venga....
Jue, 01/06/2017 - 14:24
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Ya me lo mirare, aunque sea por curiosidad.

 

  Ok, gracias.