Gnome no me funciona con aceleración gráfica.

6 envíos / 0 nuevos
Último envío
#1 Vie, 19/10/2018 - 04:38
setaseta
Imagen de setaseta
Desconectado/a
se unió: 20/12/17

Gnome no me funciona con aceleración gráfica.

Hola

Ya lo había probado en anteriores versiones, pero lo he vuelto a intentar y sigue sin funcionar.

La tarjeta gráfica que tengo:

VGA compatible controller: NVIDIA Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)

En principio Debian 9.x instala por defecto el controlador libre nouveau.

Pero resulta que no es demasiado estable con aplicaciones 3D, y lo normal es que se cuelgue.

En el escritorio Gnome con nouveau funciona un rato hasta que se cuelga.

Para probar Gnome sin aceleración gráfica obligo a no cargar nouveau con la orden:

echo -e "blacklist nouveau" > /etc/modprobe.d/fbdev-blacklist.conf

echo -e "options nouveau modeset=0" > /etc/modprobe.d/modesetting.conf

Reinicio el ordenador y Gnome funciona sin aceleración gráfica.

Ahora instalo los driver con aceleración gráfica.

apt-get install nvidia-detect

apt-get install linux-headers-$(uname -r) nvidia-legacy-304xx-driver

Reinicio el ordenador y ya no funciona Gnome.

Los demás escritorios, MATE, Xfe, Lxe, funciona perfectamente.

En KDE se puede cambiar la forma de renderizado para hacerlo por software. En Gnome no he podido deshabilitar la aceleración gráfica por hardware, por lo que no he podido hacerlo funcionar.

He probado:
gsettings set org.gnome.desktop.interface enable-animations false

Sigue sin funcionar.

¿Alguna idea? , No vale que cambie de tarjeta ;)

 

Saludos

Juan

 

 

Vie, 19/10/2018 - 10:34
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

creaste el archivo para que lo detecte la xorg?
 

# mkdir /etc/X11/xorg.conf.d
# echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "nvidia"\nEndSection' > /etc/X11/xorg.conf.d/20-nvidia.conf

te fijaste si estas entrando a la sesion con gnome Wayland y no con xorg?

probaste nvidia-graphics-drivers-legacy-304xx   de los repos stretch-backports?

saludos...

Lun, 22/10/2018 - 14:10
setaseta
Imagen de setaseta
Desconectado/a
se unió: 20/12/17

Hola

He creado el fichero la nvidia, pero sigue igual.

Vuelvo a decir que los demás entornos funcionan bien, a excepción de KDE que debo habilitar el renderizado por software.

No sabía nada de Wayland, pero mirando por hay lo he deshabilitado  en el Gdm3 por si las moscas, pero sigue sin funcionar.

Lo único que me has dicho y que no he hecho es lo de nvidia-graphics-drivers-legacy-304xx   de los repos stretch-backports. Pero creo que aquí tiro la toalla, hace mucho tiempo deje de utilizar Gnome3 y con los demás escritorios me van bien.

Gracias por la respuestas.

 

Como curiosidad te mando parte de messages donde aparece un error .

Oct 22 18:10:50 debian963 /usr/lib/gdm3/gdm-x-session[2894]: dbus-update-activation-environment: setting PWD=/home/seta
Oct 22 18:10:50 debian963 /usr/lib/gdm3/gdm-x-session[2894]: dbus-update-activation-environment: setting XDG_DATA_DIRS=/usr/share/gnome:/usr/share/gnome:/usr/share/gnome:/usr/share/gnome:/usr/share/gnome:/usr/local/share/:/usr/share/
Oct 22 18:10:51 debian963 org.a11y.atspi.Registry[2990]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Oct 22 18:10:51 debian963 gnome-keyring-ssh.desktop[3004]: SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
Oct 22 18:10:51 debian963 org.gnome.Shell.desktop[3011]: X Error of failed request:  BadMatch (invalid parameter attributes)
Oct 22 18:10:51 debian963 org.gnome.Shell.desktop[3011]:   Major opcode of failed request:  140 (RANDR)
Oct 22 18:10:51 debian963 org.gnome.Shell.desktop[3011]:   Minor opcode of failed request:  7 (RRSetScreenSize)
Oct 22 18:10:51 debian963 org.gnome.Shell.desktop[3011]:   Serial number of failed request:  207
Oct 22 18:10:51 debian963 org.gnome.Shell.desktop[3011]:   Current serial number in output stream:  208
Oct 22 18:10:51 debian963 gnome-session[2911]: gnome-session-binary[2911]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Oct 22 18:10:51 debian963 org.gnome.Shell.desktop[3014]: X Error of failed request:  BadMatch (invalid parameter attributes)
Oct 22 18:10:51 debian963 org.gnome.Shell.desktop[3014]:   Major opcode of failed request:  140 (RANDR)
Oct 22 18:10:51 debian963 org.gnome.Shell.desktop[3014]:   Minor opcode of failed request:  7 (RRSetScreenSize)
Oct 22 18:10:51 debian963 org.gnome.Shell.desktop[3014]:   Serial number of failed request:  207
Oct 22 18:10:51 debian963 org.gnome.Shell.desktop[3014]:   Current serial number in output stream:  208
Oct 22 18:10:51 debian963 gnome-session[2911]: gnome-session-binary[2911]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Oct 22 18:10:51 debian963 gnome-session[2911]: gnome-session-binary[2911]: WARNING: App 'org.gnome.Shell.desktop' respawning too quickly
Oct 22 18:10:51 debian963 gnome-session[2911]: Unable to init server: Could not connect: Connection refused
Oct 22 18:10:51 debian963 kernel: [  586.063872] gnome-session-f[3017]: segfault at 0 ip b71f192d sp bf9cb524 error 4 in libgtk-3.so.0.2200.11[b6f14000+803000]
Oct 22 18:10:51 debian963 tracker-store.desktop[3038]: (uint32 2,)
Oct 22 18:10:51 debian963 gnome-session-binary[2911]: Entering running state
Oct 22 18:10:52 debian963 clipit[3048]: Failed to load module "canberra-gtk-module"
Oct 22 18:10:52 debian963 clipit[3048]: /build/glib2.0-YYXhFA/glib2.0-2.50.3/./gobject/gsignal.c:2523: signal 'child-added' is invalid for instance '0x1d89118' of type 'GtkMenu'
Oct 22 18:10:52 debian963 gnome-settings-[3024]: g_task_return_error: assertion 'error != NULL' failed

 

 

Lun, 22/10/2018 - 14:27
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

podrías poner que te tira el comando journal
 

su
journalctl -b -p err

te fijaste de poner un kernel de backports junto con el driver de nvidia backports?

Lun, 29/10/2018 - 12:17
aldo
Imagen de aldo
Desconectado/a
se unió: 26/03/17

Usa el privativo de la pagina de nvidia. No pierdes nada. Intentalo.

Aqui : Controlador nvidia

Aqui viene el modelo de tu tarjeta grafica en la pestania: "Productos soportados" en GeForce Series 7.

Saludos (syb).

 

Lun, 29/10/2018 - 19:15
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Para mí que seguimos cayendo en el uso incorrecto de la información que se nos da. Si la salida de nvidia-detect ha dado el controlador que se instala en el primer post del hilo, el paquete correcto a instalar sería xserver-xorg-video-nvidia-legacy-304xx (éste metapaquete es suficiente y posiblemente arrastre menos dependencias que el otro, lo que evita conflictos entre librerías), no el que se ha instalado (y sería interesante conocer la salida en consola de ese proceso, no sea que no se compile correctamente por cualquier cosa). Después, comprobar tras un  reinicio que el  sistema usa el driver nvidia en lugar de nouveau con el comando lspci -k. Si sigue apareciendo nouveau, se mete en blacklist y el sistema usará automáticamente el de nvidia en el siguiente reinicio.

Una vez comprobado que todo  esto es correcto y se sigue con el mismo problema, se podría probar la solución de instalar kernel, headers, y driver desde repositorios de backports y realizar la comprobación anterior tras un reinicio del sistema (en ambos casos es lo mismo).

Tras esto, no estaría de más buscar algún bug de gnome o gdm que tuvieran que ver con nvidia y las versiones que se están utilizando.

Por último, y sólo en última instancia, recurrir a instalar los de la página oficial de nvidia, tendiendo en cuenta que hay que bajar la versión que corresponda al kernel que estamos usando y asegurarse de  tener instalado lo necesario para que se pueda compilar el módulo (en este caso, sería conveniente purgar antes lo que se haya instalado de nvidia, así como cualquier configuración que se haya hecho), teniendo además en cuenta que se debe repetir el proceso manualmente si hay una actualización del kernel.

  No hay bar que por bien no venga....