No puedo usar wifi

17 envíos / 0 nuevos
Último envío
#1 Mar, 31/10/2017 - 09:34
cali
Imagen de cali
Desconectado/a
se unió: 31/10/17

No puedo usar wifi

Hola soy nuevo en el grupo y en linux, instale debian 9 conectado a internet con cable pero no puedo hacer funcionar el wifi.

la red se ve pero no me llega nunca a conectar.

buscando por google probe varios procesos pero no funcionaron.

el iwconfig me muestra lo siguiente.

ens1      no wireless extensions.

wlx38a28cc44919  IEEE 802.11  ESSID:"s:audissio"  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:off
          
lo        no wireless extensions.

Saludos y muchas gracias.

 

 

Mar, 31/10/2017 - 10:40
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

Manda la salida de

lshw -short

 

lspci -k
#ipconfig -a

Especifica el entorno grafico que estas utilizando, gnome, cinnamon, plasma kde,....

 

 

 Saludos

 

Mar, 31/10/2017 - 11:18 (Responder a #2)
cali
Imagen de cali
Desconectado/a
se unió: 31/10/17

Gracias por tu respuesta

el entorno que uso es gnome

intente con lo que pusiste pero sigue sin funcionar.

Mar, 31/10/2017 - 11:57
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

cali si no nos das la información que se te requiere es casi imposible que se te pueda ayudar.

No sabemos si es una notebook o un pc, ni si es 64bits o 32bits, no sabemos la marca de la placa de wifi ni modelo. Tampoco sabemos si seguís teniendo acceso a internet bajo la conexión lan. etc, etc, etc.

primero que nada LEE https://exdebian.org/normas/normas-del-foro

Sobre lo que te esta pidiendo gacs es para que ejecutes dichos comandos, copies el contenido y lo pegues acá ya que de esa manera tendremos información de tu hardware.

El comando lshw creo que no viene preinstalado en debian asi que lo tendrías que instalar utilizando la terminal y con conexión a internet

su
apt install lshw

saludos...

 

Mar, 31/10/2017 - 14:12 (Responder a #4)
cali
Imagen de cali
Desconectado/a
se unió: 31/10/17

Nuevamente gracias por responder y disculpas por la falta de información

Tengo una notebook de 64 bits y la placa es una realtek

 

lshw -short

H/W path       Device           Class          Description
==========================================================
                                system         SMART R9-PE
/0                              bus            SMART R9-PE
/0/0                            memory         64KiB BIOS
/0/28                           memory         4GiB System Memory
/0/28/0                         memory         4GiB DIMM DDR3 1600 MHz (0,6 ns)
/0/28/1                         memory         DIMM [empty]
/0/36                           memory         224KiB L1 cache
/0/37                           memory         2MiB L2 cache
/0/38                           processor      Intel(R) Pentium(R) CPU  N3710  @
/0/100                          bridge         Atom/Celeron/Pentium Processor x5
/0/100/2                        display        Atom/Celeron/Pentium Processor x5
/0/100/13                       storage        Atom/Celeron/Pentium Processor x5
/0/100/14                       bus            Atom/Celeron/Pentium Processor x5
/0/100/14/0    usb1             bus            xHCI Host Controller
/0/100/14/0/4                   communication  802.11n WLAN Adapter
/0/100/14/1    usb2             bus            xHCI Host Controller
/0/100/1a                       generic        Atom/Celeron/Pentium Processor x5
/0/100/1b                       multimedia     Atom/Celeron/Pentium Processor x5
/0/100/1c                       bridge         Atom/Celeron/Pentium Processor x5
/0/100/1c.1                     bridge         Atom/Celeron/Pentium Processor x5
/0/100/1c.1/0  ens1             network        RTL8111/8168/8411 PCI Express Gig
/0/100/1f                       bridge         Atom/Celeron/Pentium Processor x5
/0/100/1f.3                     bus            Atom/Celeron/Pentium Processor x5
/0/1           scsi0            storage        
/0/1/0.0.0     /dev/sda         disk           500GB ST500LM030-2E717
/0/1/0.0.0/1                    volume         99MiB Windows FAT volume
/0/1/0.0.0/2   /dev/sda2        volume         15MiB reserved partition
/0/1/0.0.0/3   /dev/sda3        volume         269GiB Windows NTFS volume
/0/1/0.0.0/4   /dev/sda4        volume         899MiB Windows NTFS volume
/0/1/0.0.0/5   /dev/sda5        volume         191GiB EXT4 volume
/0/1/0.0.0/6   /dev/sda6        volume         4000MiB Linux swap volume
/0/2           scsi1            storage        
/0/2/0.0.0     /dev/cdrom       disk           DVDRAM GUD0N
/1                              power          Battery Name
/2                              power          Battery Name
/3                              power          Battery Name
/4                              power          Battery Name
/5             wlx38a28cc44919  network        Wireless interface

lspci
00:00.0 Host bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register (rev 35)
00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller (rev 35)
00:13.0 SATA controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SATA Controller (rev 35)
00:14.0 USB controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller (rev 35)
00:1a.0 Encryption controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine (rev 35)
00:1b.0 Audio device: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition Audio Controller (rev 35)
00:1c.0 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #1 (rev 35)
00:1c.1 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port #2 (rev 35)
00:1f.0 ISA bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU (rev 35)
00:1f.3 SMBus: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx SMBus Controller (rev 35)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)

nuevamente muchas gracias

 

Mar, 31/10/2017 - 14:35
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

Bien ,según el comando  'iwconfig' ahi tenes una interfaz de red wifi 

wlx38a28cc44919  IEEE 802.11  ESSID:"s:audissio"  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:off

o sea esta activa el sistema la reconoce, pero lo ha logrado asociarse ( conectarse) a la red ( access point ,router ,etc) entonces .

¿Como se llama tu red wifi ? ( el essid ) ejemplo : Mired.

¿Tiene algún tipo de cifrado para poder acceder a ella ? ( tenes que poner alguna contraseña? 

Son preguntas válidas para saber si has configurado correctametne los datos ,o en todo caso ,para hacer un intento en forma " manual" de que la wifi se conecte a tu red.

 

Mar, 31/10/2017 - 14:39
pvaldes
Imagen de pvaldes
Desconectado/a
colaborador
se unió: 07/04/16

Voy a decir una tontería porque no domino el tema ¿Tienes instalado el paquete firmware-realtek para las realtek RTL8111?

Si falta firmware al arrancar te lo dirá en dmesg.

Mar, 31/10/2017 - 15:19
cali
Imagen de cali
Desconectado/a
se unió: 31/10/17

Gracias por las respuestas

El nombre de la red essid y la contraseña estan bien configurados

y tengo instalado el firmware-realtek

Mar, 31/10/2017 - 16:20
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

a lo mejor estas teniendo el problema de que esta tomando el driver r8169 en lugar del driver r8168 

https://blog.desdelinux.net/solucionar-problemas-con-realtek-rtl8111-8168b-en-lmde/

https://bbs.archlinux.org/viewtopic.php?id=195251

Mar, 31/10/2017 - 17:11
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

Unos digas atrás me paso algo similar, por ahi vi algo que había una falla  en network-manager-gnome y solo hace el intento de conexión y se desconecta no seguí indagando ya que lo solucione configurando manual.  toma en cuenta si que estoy utilizando cinnamon y la distribución sid de debian.

Entiendo que instalaste la distribución estable? ya actualizaste?, tienes instalado firmware-linux-free?

Para poder conectar manual tendrías que responder las preguntas del sensei caliban, el nombre de la red?, si la conexión requiere de contraseña? que es preferible quitar la contraseña mientras no logres comprobar que te puedes conectar.

Por otra parte ya te aseguraste que si lleva contraseña la estas digitando correctamente, los dígitos que van en mayuzculas, los numero los 0 no confundirlos con la O...........

 

 Saludos

 

Mar, 31/10/2017 - 19:56
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

la wifi viene incluida en el equipo o es externa? en la la salida de lshw si aparece un dispositivo wifi, pero en la salida de lspci solo veo un ethernet, que es al realtek que os estáis refiriendo, no veo en ningún sitio que tenga una wifi realtek... ¿me equivoco?

A parte de eso, el nombre me parece algo extraño, si bién ha cambiado la forma de nombrar las interfaces, una wifi, a no ser que sea externa no debería tener un nombre tan largo... no se, no me cuadra algo de la salida de  los comandos...

podrías poner la salida del comando journalctl -b -p err y la del comando journalctl -b |grep -i firmware? Y ya de paso, marca y modelo de netbook?

Por otro lado, incluir un signo como ':' en el nombre de una red no es una buena idea, la verdad, Punto, barra baja, si se pueden incluir, no  estaría muy seguro de que los dos puntos sean muy recomendables.

  No hay bar que por bien no venga....
Mar, 31/10/2017 - 20:32
cali
Imagen de cali
Desconectado/a
se unió: 31/10/17

hola gracias pos la respuesta

la Red se llama audissio simplemente

la notebook es marca exo

root@debian:/home/usuariox# journalctl -b -p err
-- Logs begin at Tue 2017-10-31 19:31:35 -03, end at Tue 2017-10-31 20:29:00 -03. --
oct 31 19:31:36 debian systemd[1]: Attaching egress BPF program to cgroup /sys/fs/cgroup/unified/system.slice/systemd-udevd.service failed: Invalid ar
oct 31 19:31:39 debian kernel: bluetooth hci0: firmware: failed to load rtl_bt/rtl8723b_config.bin (-2)
oct 31 19:31:42 debian systemd[1]: Attaching egress BPF program to cgroup /sys/fs/cgroup/unified/system.slice/systemd-logind.service failed: Invalid a
oct 31 19:31:45 debian bluetoothd[553]: Sap driver initialization failed.
oct 31 19:31:45 debian bluetoothd[553]: sap-server: Operation not permitted (1)
oct 31 19:31:45 debian bluetoothd[553]: Failed to set mode: Blocked through rfkill (0x12)
oct 31 19:31:48 debian systemd[1]: Attaching egress BPF program to cgroup /sys/fs/cgroup/unified/system.slice/systemd-hostnamed.service failed: Invali
oct 31 19:32:05 debian systemd[1]: Attaching egress BPF program to cgroup /sys/fs/cgroup/unified/system.slice/systemd-localed.service failed: Invalid
oct 31 19:32:08 debian bluetoothd[553]: Failed to set mode: Blocked through rfkill (0x12)
oct 31 19:55:42 debian bluetoothd[553]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
oct 31 19:55:42 debian pulseaudio[1039]: [pulseaudio] backend-ofono.c: Failed to register as a handsfree audio agent with ofono: org.freedesktop.DBus.
oct 31 19:55:42 debian bluetoothd[553]: RFCOMM server failed for :1.72/Profile/HSPHSProfile/00001108-0000-1000-8000-00805f9b34fb: rfcomm_bind: Address
oct 31 19:55:46 debian systemd[1]: Attaching egress BPF program to cgroup /sys/fs/cgroup/unified/system.slice/systemd-hostnamed.service failed: Invali
oct 31 19:55:46 debian bluetoothd[553]: Failed to set mode: Blocked through rfkill (0x12)
oct 31 19:55:47 debian systemd[1]: Attaching egress BPF program to cgroup /sys/fs/cgroup/unified/system.slice/systemd-localed.service failed: Invalid
oct 31 20:02:54 debian systemd[1]: Attaching egress BPF program to cgroup /sys/fs/cgroup/unified/system.slice/systemd-hostnamed.service failed: Invali
lines 1-17/17 (END)

journalctl -b |grep -i firmware
oct 31 19:31:39 debian kernel: bluetooth hci0: firmware: failed to load rtl_bt/rtl8723b_config.bin (-2)
oct 31 19:31:39 debian kernel: bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
oct 31 19:31:39 debian kernel: bluetooth hci0: firmware: direct-loading firmware rtl_bt/rtl8723b_fw.bin
oct 31 19:31:39 debian kernel: usb 1-4: rtl8xxxu: Loading firmware rtlwifi/rtl8723bu_nic.bin
oct 31 19:31:39 debian kernel: usb 1-4: firmware: direct-loading firmware rtlwifi/rtl8723bu_nic.bin
oct 31 19:31:39 debian kernel: usb 1-4: Firmware revision 35.0 (signature 0x5301)
oct 31 19:31:47 debian NetworkManager[550]: <info>  [1509489107.1326] manager[0x5626c4208040]: monitoring kernel firmware directory '/lib/firmware'.
oct 31 19:31:48 debian kernel: r8169 0000:02:00.0: firmware: direct-loading firmware rtl_nic/rtl8168g-2.fw

 

Mié, 01/11/2017 - 13:32
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Bueno, pues quitando los errores que no tienen nada que ver, si veo que carga firmware de la wifi, pero tiene un problema con el bluetooth, que no halla el firmware. En los paquetes que hay en sid, no encuentro ese archivo, así que es posible que no haya controlador o tengas que buscar el archivo en otro sitio y meterlo en tu sistema. el comando/servicio rfkill está bloqueando el bluetooth por ese motivo. Es posible que esto interfiera con la wifi si es un modelo que incluye ambos en un solo dispositivo.

Al bluetooth, de momento, le falta un archivo, ya que si carga un firmware, pero no el otro, asi que imagino que tampoco te funciona... Necesitas descargar este archivo https://github.com/lwfinger/rtl8723au_bt/blob/master/Linux_BT_USB_2.11.20140423_8723BE/8723B/rtl8723b_config y luego copiarlo, como root y renombrándolo

sudo cp ARCHIVODESCARGADO /lib/firmware/rtl_bt/rtl8723b_config.bin

Una vez hecho esto, reinicia el sistema y ejecuta el comando rfkill list y nos pones la salida aqui. También otra vez la salida de journalctl -b -p err y journalctl -b | grep -i firmware

  No hay bar que por bien no venga....
Mié, 01/11/2017 - 15:54
cali
Imagen de cali
Desconectado/a
se unió: 31/10/17

Ok Gracias

rfkill list
0: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

journalctl -b -p err
-- Logs begin at Wed 2017-11-01 15:41:24 -03, end at Wed 2017-11-01 15:50:32 -03. --
nov 01 15:41:25 debian systemd[1]: Attaching egress BPF program to cgroup /sys/fs/cgroup/unified/system.slice/systemd-udevd.service failed: Invalid ar
nov 01 15:41:38 debian systemd[1]: Attaching egress BPF program to cgroup /sys/fs/cgroup/unified/system.slice/systemd-logind.service failed: Invalid a
nov 01 15:41:40 debian bluetoothd[524]: Sap driver initialization failed.
nov 01 15:41:40 debian bluetoothd[524]: sap-server: Operation not permitted (1)
nov 01 15:41:40 debian bluetoothd[524]: Failed to set mode: Blocked through rfkill (0x12)
nov 01 15:41:42 debian systemd[1]: Attaching egress BPF program to cgroup /sys/fs/cgroup/unified/system.slice/systemd-hostnamed.service failed: Invali
nov 01 15:42:03 debian systemd[1]: Attaching egress BPF program to cgroup /sys/fs/cgroup/unified/system.slice/systemd-localed.service failed: Invalid
nov 01 15:42:07 debian bluetoothd[524]: Failed to set mode: Blocked through rfkill (0x12)
nov 01 15:45:46 debian bluetoothd[524]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
nov 01 15:45:46 debian pulseaudio[1001]: [pulseaudio] backend-ofono.c: Failed to register as a handsfree audio agent with ofono: org.freedesktop.DBus.
nov 01 15:45:46 debian bluetoothd[524]: RFCOMM server failed for :1.72/Profile/HSPHSProfile/00001108-0000-1000-8000-00805f9b34fb: rfcomm_bind: Address
nov 01 15:45:51 debian systemd[1]: Attaching egress BPF program to cgroup /sys/fs/cgroup/unified/system.slice/systemd-hostnamed.service failed: Invali
nov 01 15:45:51 debian bluetoothd[524]: Failed to set mode: Blocked through rfkill (0x12)
nov 01 15:45:52 debian systemd[1]: Attaching egress BPF program to cgroup /sys/fs/cgroup/unified/system.slice/systemd-localed.service failed: Invalid
nov 01 15:46:03 debian kernel: [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=16418 end=16419) time 472 us, min 763

journalctl -b | grep -i firmware
nov 01 15:41:29 debian kernel: bluetooth hci0: firmware: direct-loading firmware rtl_bt/rtl8723b_config.bin
nov 01 15:41:29 debian kernel: bluetooth hci0: firmware: direct-loading firmware rtl_bt/rtl8723b_fw.bin
nov 01 15:41:29 debian kernel: usb 1-4: rtl8xxxu: Loading firmware rtlwifi/rtl8723bu_nic.bin
nov 01 15:41:30 debian kernel: usb 1-4: firmware: direct-loading firmware rtlwifi/rtl8723bu_nic.bin
nov 01 15:41:30 debian kernel: usb 1-4: Firmware revision 35.0 (signature 0x5301)
nov 01 15:41:41 debian NetworkManager[557]: <info>  [1509561701.2022] manager[0x564779886040]: monitoring kernel firmware directory '/lib/firmware'.
nov 01 15:41:43 debian kernel: r8169 0000:02:00.0: firmware: direct-loading firmware rtl_nic/rtl8168g-2.fw

 

 

Mié, 01/11/2017 - 21:57
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

bueno, aunque el bt sigue bloqueado, la wifi dice que no, y carga todos los firmwares correctamente, simple y llanamente, es que debería de funcionar, no veo nada raro, la verdad. Lo únioc que me resulta curioso, es que la wifi está conectada a un puerto usb (interior, pero puerto usb), es extraño xD

No veo razón alguna por la que no deba de funcionar, la verdad. Como no venga alguien con otra idea y te guie por donde mirar, para mí está todo correcto, debería funcionar si o si...

 

Edit....

Si la red se llama audissio, ¿porque más arriba aparece ESSID: "s:audissio"? Debería poner ESSID:"audissio"... eso no me cuadra en absoluto tampoco.

  No hay bar que por bien no venga....
Jue, 02/11/2017 - 00:49
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

prueba lo de este link, para que hay un cruse en el arranque de dos utileria para laptop

 

 Saludos

 

Jue, 02/11/2017 - 11:32
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

Yo deshabilitaría networkmanager o cualquier otro , e intentaría un acceso manual, primero con una red sin cifrado ,y si de este modo la wifi logra asociarse ( conectarse) con el ap/router ,  le agrego el cifrado y reitero el intento si también asi se accede ,ya tenes definido que el problema no es la interfaz wifi si no que algún accesorio de conexión  del sistema y la computadora .( o sea estrechar el margen de donde se produce el problema.)