Problema con la red y el sonido

7 envíos / 0 nuevos
Último envío
#1 Vie, 02/02/2018 - 00:20
Alejandro Castrillon
Imagen de Alejandro Castrillon
Desconectado/a
se unió: 01/02/18

Problema con la red y el sonido

Estado: 
[ACTIVO]

Hola a todos, Aclaro que soy muy novato en Linux (estoy estudiando), Mi problema es el siguiente 

RED: Hace poco instale la ultima versión Debian 9.3 y en los primeros pasos de proceso de instalación (Detección de Hardware de red) me sale un cuadro de dialogo algo largo pero lo principal que dice es: "Los Ficheros de firmware que faltan son: rt2870.bin" y ps yo omití ese paso y seguí con la instalación la cual termino bien pero ahora no tengo acceso a Internet y yo no tengo router cerca asi que me conecto por la Red inalámbrica por medio de un adaptador que compre y no encuentro como ni donde descargar este fichero faltante para poder conectarme a la red.

SONIDO: Acabo de notar que debían reconoce mi tarjeta de sonido pero el PC esta mudo y no encuentro la razón,  

de antemano muchas gracias por su ayuda.

Vie, 02/02/2018 - 07:32
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

sobre el tema de red tendrias que descargar https://packages.debian.org/stretch/firmware-misc-nonfree, para instalarlo

/home/tu_nombre_usuario/firmware-misc-nonfree_20161130-3_all.deb
su
dpkg -i firmware-misc-nonfree_20161130-3_all.deb

despues que recuperes el acceso a internet instala lshw y ejecuta

su
apt update && apt upgrade && apt install lshw
lshw -short 

PD: también tenes la opción de realizar la instalación de debian con imágenes del instalador de debian que traen firmware non free

http://cdimage.debian.org/cdimage/unofficial/non-free/images-including-firmware/current/amd64/iso-cd/

Esta imagen netinstall solo trae el sistema base y otras yerbas, pero para tener un escritorio gráfico (xfce4, mate, gnome, kde, etc) y algunas cosas más, hay que tener conexión a Internet y terminar la instalación desde Internet

saludos...

Vie, 02/02/2018 - 12:50
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

Como te han dicho te falta un firmware, concretamente ralink, que se encuentra en los repositorios 'non-free'

O agregas el repositorio non-free  a tu /etc/apt/sources.list ,  haces 

aptitude update
aptitude install firmware-misc-nonfree

(mientras puedas acceder de algún modo a internet claro.) De otro modo  como te han indicado te bajas el paquete 

(podes copiarlo desde otra pc a un medio atraíble,,como un pendrive) te lo llevas a tu computadora y seguís los pasos que te indicaron .

finalmente podes listar los dispositivos de red con 

ip link 
## y para activarla si hiciera falta 

ip link set wlan0 up  
## suponiendo que tu interfaz figure como wlan0 (o lo que sea )

 

Vie, 02/02/2018 - 21:55
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

Tengo un adactador usb que ni en la instalación ni ya en uso me lo reconoce por que necesita el firmware que los compañeros te menciona, lo que hago es conectarme por medio de un celular android, conecto el celular por cable usb al computador comparto el internet por medio de usb, listo las interfaces que tengo después de conectado el celular
 

ip addr show

......
enp0s29u1u4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
    link/ether 4e:2a:37:53:1d:94 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::bbab:a812:7440:7b01/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
.....

En mi caso la interfaces  es enp0s29u1u4, la agrego en el archivo de configuración /etc/network/interfaces para que escuche un servidor dhcp y queda así

#nano /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

auto enp0s29u1u2
iface enp0s29u1u2 inet dhcp

Guardo y  reinicio la red

# /etc/init.d/networking restart

si tienes que reiniciar asegurate que el celular tenga activado el compartir internet por medio de usb.

ya una ves que tenga conexión  instala el firmware que te recomienda comenta la interfaces que agregates en el archivo de configuracion /etc/network/interfaces

#nano /etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

#auto enp0s29u1u2
#iface enp0s29u1u2 inet dhcp

reinicia y prueba

 

 Saludos

 

Vie, 09/02/2018 - 04:00
Alejandro Castrillon
Imagen de Alejandro Castrillon
Desconectado/a
se unió: 01/02/18

Muchísimas, pero Muchísimas gracias, Me sirvió de mucho su ayuda.

Ahora me encuentro con que no conecta a la red inalámbrica, La señal va de un 45% hasta un 52% de intensidad según Debian, 

Pero me imagino que puede ser falta de alguna actualización o algo, asi que buscare la forma de encontrarle una solución, o pude ser por la distancia aunque no creo porque en la misma maquina tengo un HD con Win 10 y navega perfectamente, Aunque si el problema puede ser de una configuración del sistema, seria genial y agradecería mucho que me compartieran esa información.

Nuevamente muchas gracias por su ayuda en la solución de mi problema, aprendí mucho y despeje muchas dudas.

Vie, 09/02/2018 - 10:33
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

lo que podrías probar es utilizar Wicd en lugar de networkmanager. 

También se puede probar de instalar un kernel y un driver de backports que serian un poco más modernos.

Decis que con windows se conecta, y si luego de iniciar en windows, reinicias (no apagas) y elegís debian ¿al iniciar debian tenes wifi?

Dom, 04/03/2018 - 15:55
Percontator
Imagen de Percontator
Conectado
colaborador
se unió: 20/03/16

 Ahora me encuentro con que no conecta a la red inalámbrica, La señal va de un 45% hasta un 52% de intensidad según Debian, 

  No se si voy a meter la pata, pero yo creo que una cosa es que no reconozca o decodifique correctamente

 la señal que recibe, y otra es que la reconozca, la lea, pero que no le llegue el suficiente nivel para "leer todas

 la palabras del mensaje".

 Conceptualmente lo veo como esas conversaciones en la distancia en que oyes la voz de la otra persona, pero

 pierdes muchas palabras.

 

 ¿Realmente reconoce al emisor?. ¿Tiene los permisos de acceso al mismo?.

 Suponiendo los dos "si",  si  acercas el ordenador al router o emisor, ¿mejora la situación?.