Firefox deja a ALSA sin soporte

Firefox deja a ALSA sin soporte

Pues eso, todo parece indicar que Mozilla dejará de dar soporte para ALSA en favor de Pulseaudio a partir de la versión 52 de Firefox. Así que quien actualice a esa versión tendrá que instalar Pulseaudio o cambiar de navegador para poder tener sonido en la red. Recordemos que PulseAudio se instala de forma predeterminada en la mayoría de los entornos de escritorio de Debian y que ALSA está siendo dejada de lado por la mayoría de distros.

De momento en Debian Stretch (testing) todavía tenemos la versión firefox-esr (45.8.0esr-1) aunque ya asoma la Firefox 52 en Sid.

Según leo por ahí, existe la posibilidad de de compilar Firefox con la opción:

  --disable-pulseaudio --enable-alsa

Eso si, esta opción nos deja sin actualizaciones de Mozilla, por lo que habría de volver a compilar.

En resumen, que las cosas se complican para los usuarios fieles de Firefox y que quieran mantener ALSA (por los motivos que sea) como gestor de sonido en Linux. Así que ¿que os parece el rumbo que está tomando Mozilla?

Fuente:

http://www.omgubuntu.co.uk/2017/03/firefox-52-no-sound-pulseaudio-alsa-linux

https://support.mozilla.org/t5/Firefox/No-ALSA-support-after-upgrade-to-52/td-p/1372444

moonwatcher
Imagen de moonwatcher
Etiqueta: 
Categoría: 
Lun, 27/03/2017 - 23:57
Devoto
Imagen de Devoto
Conectado
colaborador
se unió: 17/04/16

¿Pero por qué me hacen eso?, yo sigo usando Alsa en vez de Pulse Audio porque no se lleva bien con mi portátil. Habrá que cambiarme a Pale Moon o Midori, no hay de otra, o bueno quien sabe si los chicos de Seamonkey vayan a hacer lo mismo.

 

Saludos y gracias por la información wink

devoto - El amor ocupa devoción.

Lun, 24/04/2017 - 15:58
juancuyo
Imagen de juancuyo
Desconectado/a
se unió: 04/05/16

Uso desde hace tiempo IceCat y Seamonky, sin extrañar para nada a firefox. Esperare a ver que hacen los desarrolladores de estas dos versiones.