Abiword ha quedado inutilizable tras actualización (el cursor parpadea y la interfaz se congela)

5 envíos / 0 nuevos
Último envío
#1 Dom, 09/07/2017 - 21:13
Devoto
Imagen de Devoto
Desconectado/a
colaborador
se unió: 17/04/16

Abiword ha quedado inutilizable tras actualización (el cursor parpadea y la interfaz se congela)

¡Hola!

Tengo un problema con Abiword 3.0.2-2 en mi ordenador con Debian Stretch con IceWM y en mi portátil con LXDE (ambos de 32 bits), ya que al tratar de abrir un documento o simplemente al iniciarlo no me deja hacer nada. Simplemente el cursor empieza a parpadear sin cesar y la interfaz se congela o bien me permite abrir una opción de los menús y después las demás opciones se ponen de color gris, y una vez así no me deja seleccionar nada. O bien, abre sin problemas un documento y entonces empieza a parpadear la zona del documento en gris. Lo cual luce de esta manera:

 

abiword-error

 

Al ejecutarlo desde una terminal esto es lo que obtengo:

 

(abiword:3884): Gtk-CRITICAL **: gtk_render_background: assertion 'GTK_IS_STYLE_CONTEXT (context)' failed
(abiword:3884): Gtk-CRITICAL **: gtk_render_frame: assertion 'GTK_IS_STYLE_CONTEXT (context)' failed

 

He buscado con el Pato y he encontrado un error similar en Launchpad, al parecer decían que con cambiar el tema y usar el que no te diera ese error era la solución, pero ya he probado y descargado varios temas y me sucede lo mismo.  También me ha llamado la atención el comentario de Henk Terhell que decía que el cambiar de tema no tenía ningún efecto en Abiword y esto sucedia tanto en Debian Stretch, como en Lubuntu 17.04 y Xubuntu 17.04. No sé si sea un error sin solucionar o simplemente una mala cofiguración...

Aunque ahora uso Lyx tengo muchos documentos en el formato nativo de Abiword y no hay manera de abrirlos ya que este no lo puedo utilizar correctamente.

 

¿Qué me recomiendan hacer?, gracias por su vaiioso tiempo y por leerme.

Mar, 11/07/2017 - 05:13
shicefgo
Imagen de shicefgo
Desconectado/a
se unió: 28/03/16

Hola.

LibreOffice 5 tiene una opción para abrir documentos Abiword (al menos en mi instalación aparece smiley).

Según dicen aquí, el formato abw es xml y puede estar comprimido con gzip, lo que estaría indicado por la extensión del nombre del archivo. (.abw sería xml puro -no haría falta descomprimirlo- y .zabw o .abw.gz serían documentos comprimidos con gzip).

Si LibreOffice es demasiado pesado para tu equipo y necesitas acceder sea como sea a algún documento abw, podrías copiarlo con otro nombre y descomprimirlo en su caso para cargarlo en el navegador web o en un editor de texto llano, como nano u otro parecido. Claro que el marcado xml hará parecer farragoso el documento, pero con algo de paciencia y atención podrás acceder a la información.

 

Mar, 11/07/2017 - 11:57
Devoto
Imagen de Devoto
Desconectado/a
colaborador
se unió: 17/04/16

¡Muchas gracias!

No sabía que se podían abrir en LibreOffice, lo he instalado en el portátil con LXDE y se ve muy mal su interfaz, es gris :S ... No creo que sea buena idea instalar LibreOffice en mi viejo ordenador, son muchas dependencias las que tiene y además no tengo espacio ya. Voy a pasar los documentos de Abiword a odt para evitar problemas como este en el futuro.

 

También les he hechado un vistazo con Ne, son demasiadas etiquetas, creo que me voy a lo fácil con Writer.  Aunque me pregunto si alguien ha encontrado una solución al error de Abiword, no es que Lyx o Writer no me sirvan pero llevo años usando Abiword en Puppy Linux y estoy muy acostumbrado a su facilidad de uso. Cuando estudiaba era lo que usaba para hacer mis trabajos, y así hasta ahora. Han pasado muchos años D:

 

Gracias por tu ayuda wink

 

 

devoto - El amor ocupa devoción.

Mar, 11/07/2017 - 15:05
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

ya probaste purgar y instalar de nuevo?. En sid no esta dando esa falla y es la misma version, bueno lo utilice con  cinnamon y no daba falla, si no quiere borrar prueba primero borrar la capeta abiword de /home/tu-usuario/.config/ y lo inicias desde terminal.

Cada ves que cambio de versión de debían procuro borrar las carpetas .config , .local y .share asi no me evito herencias no soportadas en nuevas versiones.

   

 Saludos

 

Mar, 11/07/2017 - 17:59
Devoto
Imagen de Devoto
Desconectado/a
colaborador
se unió: 17/04/16

Hola @gacs, sí, ya he purgado e instalado de nuevo Abiword y me sigue dando el mismo error. También borre las carpetas que mencionas y sigue igual. Pensaba que era por no tener un escritorio completo instalado, pero en mi portátil con LXDE ocurre lo mismo.

 

¡Gracias por responder!

devoto - El amor ocupa devoción.