El sistema me quedó inservible [100% SOLUCIONADO]

31 envíos / 0 nuevos
Último envío
#1 Sáb, 22/10/2016 - 07:44
rayo
Imagen de rayo
Desconectado/a
colaborador
se unió: 21/02/16

El sistema me quedó inservible [100% SOLUCIONADO]

Hola.

Uso GNU/Linux Debian Stretch. Hasta hoy todo funcionaba perfecto, pero hace unas horas hubo una actualización (el servidor que uso es el austriaco) y entre los paquetes había una actualización del kernel. Al finalizar la actualización y hacerle un reboot se quedó el sistema inservible, no me deja acceder ni siquiera al arranque de emergencia para intentar una recuperación. Se pone en marcha Grub y luego la pantalla se queda en negro con una raya parpadeando en la parte superior izquierda, no se puede escribir, ni acceder a las ttys ni nada.

En el mismo ordenador tengo instalado Debian Estable, la que estoy usando en este momento, con los programas mínimos para poder acceder a los datos en caso de que el sistema operativo habitual que uso (Stretch) tenga algún problema, es por eso que puedo usar Internet y escribir este mensaje.

Me temo que no hay nada que hacer para recuperar mi Stretch sin tener que hacer una reinstalación completa. ¿Se podría solucionar este problema de alguna otra forma?

Podría acceder a los ficheros de Stretch desde la versión estable que estoy usando, pero no sé que podría hacer para dejarlo como estaba antes de que se actualizara el kernel.

Saludos.

Sáb, 22/10/2016 - 08:19
moonwatcher
Imagen de moonwatcher
Desconectado/a
moderador
se unió: 21/01/16

¿cuando sale el grub no puedes entrar con el kernel mas antiguo?

We were but stones. Your light made us stars

https://linuxveredas.blogspot.com.es/

Sáb, 22/10/2016 - 08:39 (Responder a #2)
rayo
Imagen de rayo
Desconectado/a
colaborador
se unió: 21/02/16

Hola.

No, no puedo. Recuerdo que hace un tiempo atrás, cuando había una actualización a una versión más nueva del kernel, en el menú del Grub se podía elegir el arranque con el viejo o el nuevo kernel, y si funcionaba bien la nueva versión luego podías desinstalar la vieja, pero ahora parece que ya no existe esa funcionalidad, que va todo automático, que cuando se actualiza el kernel se borra en antiguo.

No se trata de una actualización a una versión más nueva, sino que se instaló misma versión 4,7 con la que estaba funcionando antes, pero supongo que con algunas modificaciones hechas por los desarrolladores de Debian.

Se queda intentando cargar de forma infinita, no hace por arrancar ni nada.

Gracias.

Sáb, 22/10/2016 - 13:18
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Supongo que grub que administra los sistemas es el de debian de reserva,,el que te funciona.Se me ocurre que para usar un kernel viejo  configures una entrada en 40_custom,  estipulando el kernel viejo ,  debian guarda en /boot,   un vmlinuz.old  y un  initrd.img.old   si  en dicha entrada  apuntas a ellos,  te cargara debian con eel anterior .

Para guía aca o  este 

Recorda que luego de hacer una nueva entrada  tenes que actualizar grub,

Para modificaciones en el sistema operativo defectuoso desde otro tendras que hacer un chroot.

Investiga tambien el caso de  ( si fuera la causa ) modeset=0   , depende claro de que interfaz gráfica tengas .

Edito: Si fueras por este camino te pongo un ejemplo de una entrada personalizada para grub 

### buscara en la particion de /boot especificada por su UUID, initrd.img.old , y vmlinuz.old ####
###  cambiando " ro quiet  "  por " ro single "  carga en modo recuperacion ( recovery mode)




menuentry "El nombre que gustes" {
insmod part_msdos
insmod ext2
search --set=root --fs-uuid 4427f33b-226a-4449-b88e-71106c7f14e9 ←←( aca el UUID de la particion)
search --no-floppy --fs-uuid --set=root 4427f33b-226a-4449-b88e-71106c7f14e9
linux /vmlinuz.old root=UUID=4427f33b-226a-4449-b88e-71106c7f14e9  ro quiet
initrd /initrd.img.old
}

 

Sáb, 22/10/2016 - 14:03
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

mas que un problema del kernel eso parece un tema de controlador de video. si estas usando nvidia podrías eliminar o renombrar /etc/X11/xorg.conf  o /etc/X11/xorg.conf.d/20-nvidia.conf desde el debian estable.
 

En caso que no puedas acceder via grub a los viejos kernels,  desde el debian estable podes entrar el debian testing via chroot y actualizar, etc, o sino desde el cd de instalación de debian podes también entrar via chroot

 

---Agrego----

si estas usando Gnome3 también podría ser un bug de gdm3 en ese caso via chroot podrías instalar lightdm configurándolo como predeterminado en el momento de la instalación

---------

Sáb, 22/10/2016 - 15:22 (Responder a #5)
rayo
Imagen de rayo
Desconectado/a
colaborador
se unió: 21/02/16

Hola,

Quote:
debian guarda en /boot, un vmlinuz.old y un initrd.img.old

En /boot no encontré ningún fichero con el nombre .old

Estuve probando con el nomodeset y no funciona.

Tanto en el arranque normal como en el modo recovery no funciona.

Hace un rato descargué la guía que me indicas para estudiarla más a fondo durante los próximos diás. Como hace tanto tiempo que el sistema operativo no tenía ningún fallo ya casi no me acuerdo de muchas cosas relacionadas con la configuración.

 

#########

Este es el primer fallo grave que me ocurre en GNU/Linux. Hace como unos 12 años que estoy usando Debian y nunca había tenido un problema como este usando Testing. La versión estable funciona como una roca, cero fallos en todo el tiempo.

 

No recuerdo los paquetes que se actualizaron y como siempre hago un aptitude clean para aprovechar espacio se borraron, pero eran pocos, solamente algunas librerías, se actualizó el Smplayer, y unos paquetes que hacían referencia al kernel, un update de la misma versión del kernel 4,7, supongo que algunos ligeros cambios hechos por los desarrolladores de Debian. En los paquetes me parece que no había nada relacionado con la gráfica, ninguna actualización de los drivers.

 

También estuve consultando en el foro de Debian en inglés, pero me temo que mi inglés no es muy bueno y no pude expresarme muy bien:

 

http://forums.debian.net/viewtopic.php?f=10&t=130252

 

El PC que tengo es ya muy viejo así que puede ser que se le haya atragantado alguna línea de código que contienen las actualizaciones.

 

Intentaré reinstalar de nuevo, pero solamente tengo una copia vieja de Debian Squeeze, el PC no acepta arrancar desde un pendrive (PC viejo), y no tengo una grabadora CD. Sería cosa de instalar Squeeze mínimo, sin las X, luego ir actualizando hasta Stretch y luego instalar los programas, pero dentro de unos días porque ahora necesito el PC para hacer algunos trabajos de ofimática (me sirve Jessie)

 

Yo creo que no voy a ser capaz de resucitar la Stretch, pues se quedo totalmente muerta.

 

Saludos.

 

 

Sáb, 22/10/2016 - 15:30
moonwatcher
Imagen de moonwatcher
Desconectado/a
moderador
se unió: 21/01/16

Oye ¿porque no pruebas a hacer un chroot antes desde tu debian estable?

Una vez dentro puedes intentar actualizar. muchas veces en testing sobre todo lo que aptitude se lleva, aptitude devuelve wink

En ete articulo hay informacion de como se entra  a otro sistema mediante chroot:

http://exdebian.org/articulos/instalar-debian-gnulinux-desde-un-sistema-gnulinux

We were but stones. Your light made us stars

https://linuxveredas.blogspot.com.es/

Sáb, 22/10/2016 - 15:31
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Perdon ,fue un error mio por ciertas configuraciones que yo utilice ,  busca en  / 

ls /
0755  cdrom  home            lib         mnt   root  srv  usr      vmlinuz.old
bin   dev    initrd.img      lost+found  opt   run   sys  var
boot  etc    initrd.img.old  media       proc  sbin  tmp  vmlinuz

Pero da igual ,tambien podes indicar una imagen que tengas guardada 

...................................
linux /boot/vmlinuz-4.5.0-1-686-pae root=UUID=495ab113-7639-471a-b989-88cbad95528d ro quiet
initrd /boot/initrd.img-4.5.0-1-686-pae
}

El punto es indicar donde grub debe ir a buscar y que tiene que cargar , 

Sáb, 22/10/2016 - 15:37 (Responder a #8)
rayo
Imagen de rayo
Desconectado/a
colaborador
se unió: 21/02/16

Quote:
mas que un problema del kernel eso parece un tema de controlador de video

 

Hola,

Esta es la gráfica que tiene el PC:

 

[code]

$ lspci -knn | grep -iA2 '\''[030[02]\]'
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV280 [Radeon 9200 SE] [1002:5964] (rev 01)
        Subsystem: Tul Corporation / PowerColor CN-AG92E [148c:2073]
        Kernel driver in use: radeon

 

[/code]

 

Estuve haciendo unas pruebas con un fichero xorg.conf, creo recordar que le puse el driver genérino vesa, pero no funciona.

 

Quote:
En caso que no puedas acceder via grub a los viejos kernels,  desde el debian estable podes entrar el debian testing via chroot y actualizar

Sí, hace un rato desinstalé y volví a instalar el kernel, pero sigue igual. Dentro de unos días voy a hacerle un aptitude update y upgrade a ver si es cosa de algún bug y se soluciona.

 

Saludos y muchas gracias.

Sáb, 22/10/2016 - 15:42
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Hace poco instale  jessie en un pc viejo ,vieeeeeeeeeeeeeejo,en el cual tenia un  sid,  en la ultima actualizacion murio y no he podido aun resucitarlo ,asi que creo que algo hay en las actulizaciones en viejos dispositivos.

Por cierto tampoco acepta bootear desde un pendrivey no tengo grabadora  asi que tire de un viejo cd netinst,,,wheezy, 

NO intentes saltar de una version muy vieja directamente ,instala lo minimo ,actualiza ,luego pasas a la siguiente rama y volves hacerlo .

La opcion que te ha comentado moonwatcher, es muy viable y podras instalar direrectamente desde tu actual debian en funcionamiento .

Y por último, paciencia, no des por muerto algo que quiza puedas recuperar y rescatar lo que ahi tenes ( al menos si tenes   tu /home separado podras usarlo en la nueva instalación .)

Dom, 23/10/2016 - 03:48
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

De todas formas, aun sin poder iniciar sesión, al tener el otro sistema para hacerlo, puedes luego acceder a la partición del sistema que no te inicia y mirar los logs del sistema. El asunto de la gráfica es algo extraño ya que dices que ni siquiera puedes entrar al modo recovery (este modo no usa ningún entorno gráfico, así que es dificil que sea culpa del driver de vídeo si al principio si se ve tanto el grub como cuando inicia. Los archivos que te interesarían serían /var/log/syslog, /var/log/kern.log, y /var/log/aptitude o dpkg para saber que es lo que se ha actualizado y ver si ocurrió un error durante la compilación de algún modulo (los drivers gráficos, virtualbox, y otros más se "autocompilan" si está instalado el correspondiente archivo dkms).

  No hay bar que por bien no venga....
Dom, 23/10/2016 - 12:44 (Responder a #11)
rayo
Imagen de rayo
Desconectado/a
colaborador
se unió: 21/02/16

Hola, Pango.

Estuve consultando esos registros, pero no los entiendo mucho. No sé si cuando pone "err 0" es que está indicando algún error.

 

Esto es lo que está escrito en esos ficheros. Cuando hice la actualización, como venía una actualización del kernel, hice un reboot al finalizar la actualización.

 

/var/log/aptitude

 

Esta fue exactamente la actualización que mató a la Stretch. Casi seguro, por no decir seguro, que el problema surgió al instalar alguno de los siguientes paquetes. Recuerdo que eran 25 paquetes los que se actualizaron.

 

Aptitude 0.8.3: log report
Sat, Oct 22 2016 11:04:24 +0100

  IMPORTANT: this log only lists intended actions; actions which fail
  due to dpkg problems may not be completed.

Will install 25 packages, and remove 0 packages.
1096 kB of disk space will be used
========================================
[UPGRADE] ethtool:i386 1:4.6-1 -> 1:4.8-1
[UPGRADE] evince:i386 3.22.0-1 -> 3.22.1-2
[UPGRADE] evince-common:i386 3.22.0-1 -> 3.22.1-2
[UPGRADE] grub-common:i386 2.02~beta2-36 -> 2.02~beta3-1
[UPGRADE] grub-pc:i386 2.02~beta2-36 -> 2.02~beta3-1
[UPGRADE] grub-pc-bin:i386 2.02~beta2-36 -> 2.02~beta3-1
[UPGRADE] grub2-common:i386 2.02~beta2-36 -> 2.02~beta3-1
[UPGRADE] libarchive13:i386 3.2.1-4 -> 3.2.1-5
[UPGRADE] libboost-date-time1.61.0:i386 1.61.0+dfsg-2.1+b1 -> 1.61.0+dfsg-3
[UPGRADE] libboost-filesystem1.61.0:i386 1.61.0+dfsg-2.1+b1 -> 1.61.0+dfsg-3
[UPGRADE] libboost-iostreams1.61.0:i386 1.61.0+dfsg-2.1+b1 -> 1.61.0+dfsg-3
[UPGRADE] libboost-system1.61.0:i386 1.61.0+dfsg-2.1+b1 -> 1.61.0+dfsg-3
[UPGRADE] libevdocument3-4:i386 3.22.0-1 -> 3.22.1-2
[UPGRADE] libevview3-3:i386 3.22.0-1 -> 3.22.1-2
[UPGRADE] libnautilus-extension1a:i386 3.22.0-1 -> 3.22.1-2
[UPGRADE] libqt5clucene5:i386 5.6.1-2 -> 5.6.1-3
[UPGRADE] libqt5designer5:i386 5.6.1-2 -> 5.6.1-3
[UPGRADE] libqt5help5:i386 5.6.1-2 -> 5.6.1-3
[UPGRADE] linux-compiler-gcc-5-x86:i386 4.7.6-1 -> 4.7.8-1
[UPGRADE] linux-headers-4.7.0-1-686-pae:i386 4.7.6-1 -> 4.7.8-1
[UPGRADE] linux-headers-4.7.0-1-common:i386 4.7.6-1 -> 4.7.8-1
[UPGRADE] linux-image-4.7.0-1-686-pae:i386 4.7.6-1 -> 4.7.8-1
[UPGRADE] linux-kbuild-4.7:i386 4.7.6-1 -> 4.7.8-1
[UPGRADE] smplayer:i386 16.4.0~ds0-1 -> 16.9.0~ds0-1
[UPGRADE] smplayer-l10n:i386 16.4.0~ds0-1 -> 16.9.0~ds0-1
========================================

Log complete.

========================================

 

 

/var/log/kern.log

 

Esto es lo que pone después de la fecha en que se instaló la actualización, es lo último que pone antes de quedarse la Stretch rota;

 

 

Oct 22 11:07:23 debian kernel: [  485.222890] device-mapper: uevent: version 1.0.3
Oct 22 11:07:23 debian kernel: [  485.223141] device-mapper: ioctl: 4.34.0-ioctl (2015-10-28) initialised: dm-devel@redhat.com
Oct 22 11:07:41 debian kernel: [  503.949268] xfs: Unknown symbol posix_acl_update_mode (err 0)
Oct 22 11:07:41 debian kernel: [  503.995402] jfs: Unknown symbol posix_acl_update_mode (err 0)
Oct 22 11:07:41 debian kernel: [  504.078743] ntfs: driver 2.1.32 [Flags: R/O MODULE].
Oct 22 11:07:41 debian kernel: [  504.191350] QNX4 filesystem 0.2.3 registered.
Oct 22 11:07:42 debian kernel: [  504.312073] raid6: mmxx1    gen()  1238 MB/s
Oct 22 11:07:42 debian kernel: [  504.380034] raid6: mmxx2    gen()  2157 MB/s
Oct 22 11:07:42 debian kernel: [  504.448017] raid6: sse1x1   gen()  1175 MB/s
Oct 22 11:07:42 debian kernel: [  504.516013] raid6: sse1x2   gen()  1958 MB/s
Oct 22 11:07:42 debian kernel: [  504.584116] raid6: int32x1  gen()   553 MB/s
Oct 22 11:07:42 debian kernel: [  504.652010] raid6: int32x1  xor()   342 MB/s
Oct 22 11:07:42 debian kernel: [  504.720070] raid6: int32x2  gen()   726 MB/s
Oct 22 11:07:42 debian kernel: [  504.788028] raid6: int32x2  xor()   476 MB/s
Oct 22 11:07:42 debian kernel: [  504.856090] raid6: int32x4  gen()   576 MB/s
Oct 22 11:07:42 debian kernel: [  504.924064] raid6: int32x4  xor()   393 MB/s
Oct 22 11:07:42 debian kernel: [  504.992126] raid6: int32x8  gen()   524 MB/s
Oct 22 11:07:42 debian kernel: [  505.060031] raid6: int32x8  xor()   337 MB/s
Oct 22 11:07:42 debian kernel: [  505.060034] raid6: using algorithm mmxx2 gen() 2157 MB/s
Oct 22 11:07:42 debian kernel: [  505.060038] raid6: using intx1 recovery algorithm
Oct 22 11:07:42 debian kernel: [  505.073829] xor: measuring software checksum speed
Oct 22 11:07:42 debian kernel: [  505.112013]    pIII_sse  :  1657.000 MB/sec
Oct 22 11:07:42 debian kernel: [  505.152010]    prefetch64-sse:  1677.000 MB/sec
Oct 22 11:07:42 debian kernel: [  505.152015] xor: using function: prefetch64-sse (1677.000 MB/sec)
Oct 22 11:07:42 debian kernel: [  505.230151] btrfs: Unknown symbol posix_acl_update_mode (err 0)
Oct 22 11:07:42 debian kernel: [  505.250095] fuse init (API version 7.25)
Oct 22 11:08:28 debian kernel: [  550.850471] xfs: Unknown symbol posix_acl_update_mode (err 0)
Oct 22 11:08:28 debian kernel: [  550.876407] jfs: Unknown symbol posix_acl_update_mode (err 0)
Oct 22 11:08:28 debian kernel: [  551.008608] btrfs: Unknown symbol posix_acl_update_mode (err 0)
 

 

El fichero var/log/syslog es muy extenso e incluso hay versiones comprimidas en gz. Estuve leyéndolo, pero no sé encontrar los errores.

 

 

El paquete dkms no está instalado ni en Stretch ni en Jessie.

Haciendo chroot a Stretch:

/# dpkg -l | grep dkms

(no da ninguna salida, no está instalado)

--------------

Gracias por toda la información. Con esto por lo menos tengo alguna pista para intentar resolver el problema.

Saludos.

Dom, 23/10/2016 - 12:51 (Responder a #12)
rayo
Imagen de rayo
Desconectado/a
colaborador
se unió: 21/02/16

si estas usando Gnome3 también podría ser un bug de gdm3

 

Hola, rockyiii,

Se me olvidó decír que el escritorio que estoy usando en Stretch es el LXDE.

Dom, 23/10/2016 - 20:22
rayo
Imagen de rayo
Desconectado/a
colaborador
se unió: 21/02/16

¡Ya logré hacer funcionar de nuevo la Stretch! Ahora mismo estoy usando la Stretch para escribir este comentario.

Como sospechaba, el problema es cosa del kernel

Durante unas de las muchas pruebas que hice, se me ocurrió meterle a la Stretch los paquetes del kernel que tiene la Jessie y de momento está funcionando muy bien. Ahora en el Grub de la Stretch puedo elegir arrancar con kernel 4,7 (que no funciona) o el kernel 3,16 (que funciona bien)

La Jessie solamente tiene instalados estos paquetes que hacen referencia al kernel linux:

linux-image-3.16.0-4-686-pae
linux-image-686-pae

La Stretch tiene estos cuatro paquetes:

linux-headers-4.7.0-1-686-pae
linux-headers-4.7.0-1-common
linux-image-4.7.0-1-686-pae
linux-kbuild-4.7

Después de saber los paquetes que estaban en juego en Stretch leyendo el registro en /var/log/aptitude, tal y como me enseñó Pango, viendo los paquetes que tenía la Jessie, descargué los dos paquetes de la Jessie y se los metí a la Stretch usando dpkg... y resucitó Stretch.

Muchísimas gracias a todos. Sin vuestra ayuda no habría podido hacer que la Stretch esté funcionando de nuevo. Tengo la Stretch bastante retocada y me va un poco más rápido que la Jessie en mi viejo PC, así que la dejo con el kernel 3,16 hasta ver si con el tiempo funciona también con la versión 4,7

No entiendo mucho de estas cosas, imagino que al meterle el kernel 3,16 no habré abierto un agujero en la seguridad del sistema.

Saludos y gracias.

Dom, 23/10/2016 - 23:06
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

bueno, un agujero de seguridad no, pero siempre estarás más expuesto al ser un kernel más viejo (aunque debian cuida mucho la seguridad en sus versiones estables).

Ahora que ya tienes stretch en funcionamiento, realiza un aptitude update && aptitude safe-upgrade a ver si se te actualiza algo y, después, mira los paquetes que se actualizaron cuando apareció el problema y vuelve a instalarlos con el comando aptitude reinstall PAQUETES. Viendo que se te actualizó tanto el kernel como el grub, no estaría de más que comprobaras cosas como el controlador gráfico, no sea que necesite una actualización que no se produjo al mismo tiempo que el kernel (tratandose de drivers gráficos, puedes comprobar que está instalado su correspondiente paquete dkms y hacerle un aptitude reinstall a ese paquete también) y cuando acabe todo, ejecutar sudo update-grub para asegurarte de que su actualización ha sido correcta.

  No hay bar que por bien no venga....
Lun, 24/10/2016 - 19:24 (Responder a #15)
rayo
Imagen de rayo
Desconectado/a
colaborador
se unió: 21/02/16

Hola, Panko.

Sí, eso de reinstalar los paquetes ya lo había hecho antes de ponerle el kernel 3.16

De momento no he visto nada raro en la gráfica.

Estuve probando con el kernel 4.7 para ordenadores viejos, el que no está señalado como "pae" en el repositorio. Mi viejo PC no lleva tanta memoria así no me hace falta el "pae", pero tampoco funciona. Tanto el kernel 4.7 pae como el de PC viejos siempre rompe el arranque.

Estuve haciendo muchas pruebas, pero de momento solamente funciona con el kernel 3.16-pae (si hay un kernel 3.16 para ordenadores viejos no lo he probado porque funciona bien con el pae)

Hoy hubo un nuevo update, pero no hubo suerte:

Se actualizarán los siguientes paquetes:
binutils geoip-database gvfs gvfs-common gvfs-daemons gvfs-libs libc-bin libc-l10n libc6
libdatetime-timezone-perl libelf1 libgeoip1 libhyphen0 libtag1v5 libtag1v5-vanilla libwps-0.4-4
linux-image-686-pae locales lsb-base lsb-release multiarch-support ntpdate tzdata

--------------------------
Stretch está funcionando muy bien, sólo que con el kernel que no corresponde a su repositorio.

Gracias por los comentarios y saludos.

Lun, 24/10/2016 - 20:21
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Eso suena a soporte descontinuado o algo por el estilo. Conforme el kernel y los controladores van avanzando, se suele ir quitando dispositivos soportados de los mismos (como se hace con los controladores de nvidia, por ejemplo) y metiendolos en otros paquetes o, simplemente, no haciendo ya controladores compatibles con kernels nuevos. Si tu equipo ya tiene un tiempo, es más que probable que cuánto más moderna sea una distribución, algún que otro componente deje de estar soportado en su paquetería.

  No hay bar que por bien no venga....
Lun, 24/10/2016 - 23:05
enrique
Imagen de enrique
Desconectado/a
se unió: 19/02/16

Ahora espero te quede claro la conveniencia de hacer respaldos de la instalación, sugiero emplear Clonezilla livecd/usb o lnstalar "partclone" en ambas distros.
Respecto al uso de Clonezilla es muy simple aunque algo complejo de exlicar en u foro, pero en la red vas a encontrar cientos de tutos.
Para el uso de partclone, la partición a respaldar debe estar desmontada
Supongamos que
sda1 -----> stretch
sda2 -----> jessie
/medla/datos/respaldos ----> ruta de la carpeta para almacenar los respados
image_sda1.stret.gz ----> archivo imagen a crear

Aclarado lo anterior, estando en jessie y con stretch desmontada ejecuta el sigioemte Script como root

#!/bin/sh
e2fsck -p /dev/sda1
partclone.ext4 -c -s /dev/sda1 | gzip -c > /medla/datos/respaldos/image_sda1.stret.gz

 
Con lo anterior ya tienes una imagen respaldo y para restaurarla ejecuta este otro script siempre teniendo desmontada la partición a restaurar

#!/bin/sh
zcat /medla/datos/respaldos/image_sda1.stret.gz | partclone.ext4 -r -o /dev/sda1

Eso serṕa todo, solo indico que al ser procesospor lotes, estos reslados son muy rápidos. menos de 10 minutos para crear o para resturar una imagen de respsldo

Mar, 25/10/2016 - 13:23
rayo
Imagen de rayo
Desconectado/a
colaborador
se unió: 21/02/16

Quote:
Si tu equipo ya tiene un tiempo

Creía que se podía ver la configuración de mi equipo, que había un apartado para añadir una descripción del equipo. Debe ser de cuando estaba en el foro de EsDebian o en otro foro.

Mi equipo está ya un poco obsoleto, tendrá unos 12 años o más, pero para el uso que le doy todavía me sirve.

AMD Athlon XP, 1500 MHz
Radeon 9200 SE (Editado: Hasta hace poco estaba usando una TNT2)
QDI KuDoz 7E/333X (6 PCI, 1 AGP, 3 DIMM, Audio)
Un disco duro de 80 GB y otro de 160 GB
526 MB RAM
Lector DVD y disquetera
Sistema operativo - Debian GNU/Linux
Entorno escritorio - LXDE

Quote:
Ahora espero te quede claro la conveniencia de hacer respaldos de la instalación

Nunca me he interesado por hacer un respaldo del sistema operativo, solo he hecho copias de seguridad para los datos y para la configuración del usuario en el /home.

Con Debian estoy muy contento porque desde que tengo el PC he estado usando Debian y nunca había tenido ningún problema serio en Testing. Esto de la Stretch no importa porque siempre pude seguir usando el PC mediante la partición de emergencia con la Jessie

La versión estable de Debian es siempre una roca. La perfección de la perfección.

La versión testing de Debian yo la veo como una versión más estable que algunas distribuciones "estables" de otras marcas. Toda la vida he usado testing para hacer trabajos con el PC.

Saludos.

Mar, 25/10/2016 - 14:21
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Si, se puede ver, es una oración condicional, no es una pregunta (no veo que estén puestas las características en el post inicial, pero se deduce a lo largo del hilo).

  No hay bar que por bien no venga....
Sáb, 29/10/2016 - 09:32
rayo
Imagen de rayo
Desconectado/a
colaborador
se unió: 21/02/16

Hace un rato instalé, solamente a modo de prueba, el kernel 4.8 que encontré en el paquete de la versión experimental, y funciona perfecto, el PC arranca sin ningún problema, así que imagino que se podría descartar que el problema sea cosa de los drivers de la tarjeta gráfica o que el nuevo kernel deja de tener soporte para mi viejo PC.

$ uname -r
4.8.0-rc8-686-pae

Este es el paquete que instalé solamente a modo de prueba:

https://packages.debian.org/experimental/kernel/linux-image-4.8.0-rc8-686-pae