El sistema me quedó inservible [100% SOLUCIONADO]

31 envíos / 0 nuevos
Último envío
Dom, 30/10/2016 - 17:18
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Puede ser que un driver no funcione en una versión del kernel, puede ser que el kernel 4.8 introduzca un driver nuevo, puede ser que al instalar dicho kernel el driver haya compilado correctamente, pueden ser muchas cosas, incluso un bug del kernel respecto a tu hardware, quien sabe. Muchas veces se saca un firmware de un paquete porque ya no es necesario, y siempre puede pasar que tu hardware si lo necesite y no tengas el controlador actualizado, quien sabe. Cuando pasan esas cosas, siempre puedes tirar de reportbug-ng o de la misma página de Debian Bug Tracking System para buscar si hay algo que te afecte.

  No hay bar que por bien no venga....
Dom, 11/12/2016 - 14:28
rayo
Imagen de rayo
Desconectado/a
colaborador
se unió: 21/02/16

El paquete 4.8.0-rc8-686-pae que instalé a modo de prueba con dpkg tomándolo prestado de la versión experimental funcionó bien, pero cuando Strech se actualizó a esa versión tampoco se ponía en marcha. Con la versión experimental arrancaba, pero cuando tomó ese paquete desde el repositorio oficial Stretch no se ponía en marcha, así que seguí usando la versión 3.16. Más tarde pasó a la versión 4.8.0-1-686-pae, pero tampoco funcionaba.

Pensaba que esas versiones nuevas ya no funcionarían en mi viejo PC, así que me quedé usando la versión 3.16.

Hoy probé a ver si arrancaba con la versión 4.8.0-1 que tiene por defecto Stretch y funciona perfecto. Seguramente se reparó en alguna actualización de algún paquete, pero como son tantos no tengo idea cual fue el paquete que arregló el problema.

$ uname -r
4.8.0-1-686-pae

100% Solucionado el problema. Ahora todo está nuevamente funcionando bien.

Feliz Navidad.

Lun, 19/12/2016 - 20:24
monzterous
Imagen de monzterous
Desconectado/a
se unió: 19/12/16

A mi me paso lo mismo con esa versión de Kernel, hice algunas cosas que veo también intentaste y no daba, tuve que regresar al 3.16. Pero efectivamente en cuanto salio nueva versión de Kernel funciono, ya no me preocupe por ver que paquete/driver/script o lo que sea ocasionaba el fallo

Mar, 20/12/2016 - 13:05 (Responder a #24)
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

rayo wrote:
.......................................................................................................

Pensaba que esas versiones nuevas ya no funcionarían en mi viejo PC, así que me quedé usando la versión 3.16. ...................

Si ejecutas  

aptitude search linux-image 

Vas a ver que entre los distintos kernels disponible tendras 

p   linux-image-4.8.0-1-rt-686-pae-unsigned  - Linux 4.8 for modern PCs, PREEMPT_RT              
p   linux-image-4.8.0-2-686                  - Linux 4.8 for older PCs (signed)                  
i A linux-image-4.8.0-2-686-pae              - Linux 4.8 for modern PCs (signed)                 
p   linux-image-4.8.0-2-686-pae-unsigned     - Linux 4.8 for modern PCs                          
p   linux-image-4.8.0-2-686-unsigned         - Linux 4.8 for older PCs                           
p   linux-image-4.8.0-2-rt-686-p

Por ejemplo ,tal que existen versiones tanto para modernas como para antiguas pc de nuevas versiones de kernel 

Tengo funcionando un debian sid en un viejo pentium III 450 Mhz; 190 Mb  RAM , con el ultimo kernel  disponible.

Jue, 22/12/2016 - 17:19
rayo
Imagen de rayo
Desconectado/a
colaborador
se unió: 21/02/16

Dijo Caliban:

Quote:

Por ejemplo ,tal que existen versiones tanto para modernas como para antiguas pc de nuevas versiones de kernel

Sí, también estuve probando en su día las versiones para máquinas antiguas y tampoco funcionaba. No funcionaba nada del kernel 4.8 que estuviese disponible en el repositorio oficial testing.

Lo que me pareció muy raro es que si le instalaba el que estaba en el repositorio de la experimental se ponía en marcha, pero si intentaba usar el que estaba en la versión testing no había forma de hacerlo funcionar, siendo ambos la misma versión del paquete. Cuando el paquete del kernel de la experimiental pasó a la versión testing, se quedó inservible.

Hace poco se volvió a actualizar el kernel. Ahora mismo estoy usando la versión 4.8.0-2-686-pae

$ uname -r
4.8.0-2-686-pae

Una cosa que me gustó ver en esta última actualización fue que ahora, cuando pasó a la versión 4.8.0-2, no borró de forma automática el kernel anterior, sino que lo dejó instalado dejándolo marcado como obsoleto. Así, si falla un kernel nuevo, queda en la máquina el kernel anterior y se puede arrancar desde éste si el nuevo da problemas. Como la versión 4.8.0-2 me funciona perfectamente, luego borré la versión anterior de forma manual. Recuerdo que así funcionaba el tema hace un tiempo atrás, que al instalar una versión nueva quedaba presenta la antigua, pero luego, no recuerdo la fecha, empezaron a borrarse de forma automática los kernel obsoletos de forma automática. No sé si será cosa de alguna configuración que hice o si fue una idea de Debian para que la gente que no conoce mucho el tema no se le queden acumulados los kernel obsoletos ocupando espacio en disco e inflando el menú de Grub.

Jue, 22/12/2016 - 19:08
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

 18. No edites el tema una vez resuelto ya tiene dias que se dio como solucionado recuerde que si hacemos uno seguiran los demas, ya andan dos hilos activos  que se dieron como solucionados.

 

saludos

 

 Saludos

 

Vie, 23/12/2016 - 08:50
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

En Sid mismo no se desinstala ningún kernel viejo, aún cuando se marcan como obsoletos en el repositorio. Yo siempre mantengo uno anterior instalado por si las moscas, piensa que muchas veces, lo que se hace es actualizar el mismo kernel que estás usando en lugar de instalar la versión nueva. En el caso de Stable, esto apenas tiene importancia, ya que no vas a cambiar de kernel a no ser que sea absolutamente necesario porque se haya descubierto algún fallo grave de seguridad, por ejemplo. El kernel tienes que desinstalarlo tu. Como he dicho, no se desinstalan y puedes fácilmente, estando en testing o sid, con 4 ó 5 instalados como mínimo.

Respecto a lo que dices de que funciona/no funciona, ya te dije que pueden ser muchas cosas. Que un kernel en experimental te funciona y luego al pasar a sid o testing no lo haga, puede pasar perfectamente, piensa que no sólo es el kernel lo que se actualiza y, como te dije, el asunto de controladores gráficos es más delicado de lo que parece. En Debian Sid he estado una buena temporada sin poder instalar el privativo de nvidia que hay en repositorios por incompatibilidad con la versión de Xorg, por ejemplo, así como han habido épocas también que no podía instalarlo porque la versión disponible daba error al compilar los módulos con ciertas versiones del kernel. Por este mismo caso, al instalar un kernel que no corresponde a tu sistema, hay que comprobar/instalar una versión de controladores acordes al mismo.

  No hay bar que por bien no venga....
Vie, 23/12/2016 - 08:55
rayo
Imagen de rayo
Desconectado/a
colaborador
se unió: 21/02/16

Quote:
18. No edites el tema una vez resuelto ya tiene dias que se dio como solucionado recuerde que si hacemos uno seguiran los demas, ya andan dos hilos activos que se dieron como solucionados.

Ah, vale. Edité el tema porque primero estaba parcialmente solucionado, pero luego se solucionó totalmente a raíz de una actualización del software. Había marcado la cabecera de este tema como [Solucionado]. Luego, cuando se solucionó totalmente el problema, añadí la etiquieta [100% Solucionado], pero me olvidé quitar la anterior, así que la cabecera quedó así:

[SOLUCIONADO] [100% SOLUCIONADO]

Lo que hice fue quitar la etiqueta [SOLUCIONADO] y dejar solamente la que dice [100% SOLUCIONADO], pero no sabía que al editar nuevamente la cabecera el tema se quedaba señalado como activo, como tema sin resolver.

Gracias y disculpen las posibles molestias que haya causado. Mi intención era mejorar el aspecto visual de la cabecera.

Vie, 23/12/2016 - 09:05
rayo
Imagen de rayo
Desconectado/a
colaborador
se unió: 21/02/16

Quote:
En Sid mismo no se desinstala ningún kernel viejo

Pues no sé lo que pasó. Cuando tuve el problema con el kernel de Stretch fue porque al instalarse la nueva versión se desinstaló de forma automática la antigua. Luego no funcionó la versión nueva, pero como ya no tenía la antigua se quedó el sistema inservible.

Eso de la desinstalación automática del kernel me di cuenta unos meses atrás. Ahora, aparte de que se solucionó el problema, al instalarse la nueva versión se queda la vieja instalada.

No sé si fue que yo hice alguna configuración o instalé algún paquete que hace que las versiones viejas se desinstalen solas, o si es que Debian añadió esa funcionalidad y luego la quitó para que no le pase a nadie lo que me pasó a mí, o sea, que no funciona el kernel nuevo y desapareció el antiguo.

Si fue cosa que hice yo mismo en la configuración, como al aparecer el problema estuve retocando muchas cosas, quitando cosas, añadiendo otras, pues no sé lo que pasó realmente.

Editado. No sé, pero yo creo que si hubiese sido algún problema con la gráfica el sistema hubiese funcionado, pero sin entorno X, o sea, que hubiese podido usarlo desde una tty, pero lo que pasó es que al intentar cargarse el kernel se quedaba parpadeando de forma infinita. A mí me han pasado problemas con la gráfica, pero el kernel se pone en marcha independientemente de los drivers de la tarjeta, o al menos eso creo.

Editado. Volviendo a lo del kernel, yo creo que los de Debian hicieron algún cambio para que el kernel antiguo se desistalase de forma automática, pero luego lo quitaron para evitar problemas como el que me pasó a mí, pero esto es hablar por hablar porque no tengo pistas ni nada acerca de lo que pasó.

El caso fue así, apareció una versión nueva del kernel, una vez que hice el update con aptitude reinicié el PC para usar el nuevo kernel, pero el nuevo dejó de funcionar y el antigua había desaparecido de forma misteriosa, sin yo quitarlo de forma manual. Como solamente tenía el kernel que no arrancaba se quedó el sistema totalmente inservible.

Tengo una aplicación que borra cosa, BleachBit, pero no la usé para nada durante la actualización y además no tengo ningún script ni aplicación configurada para borrar cosas de forma automática al iniciar el sistema, o al menos eso creo yo.

El caso es que antes desistalaba el kernel obsoleto y ahora no lo hace.

Saludos.

Vie, 23/12/2016 - 12:07
caliban
Imagen de caliban
Conectado
moderador
se unió: 14/01/16

Podes comprobar el listado  de kernels instalados 

# dpkg -l | grep linux-image

Pero ademas  si   vas a  el directorio raiz y haces un listado 

cd /
ls
0755  cdrom  home            lib         mnt   root  srv  usr      vmlinuz.old
bin   dev    initrd.img      lost+found  opt   run   sys  var
boot  etc    initrd.img.old  media       proc  sbin  tmp  vmlinuz

Fijate  vmlinuz  y  vmlinuz.old , o sea se conserva un nucleo antiguo por si las moscas .

Yo tambien conservo siempre al menos el kernel anterior, y  en las instalaciones con varios sistemas personalizo grub de tal modo que tenga disponible  el ultimo instalado  y  el  old  ( ademas de ese modo si actualizo los otros sistemas el grub que los administra siempre tendra disponible el ultimo kernel instalado y el anterior , pero esto es otro cuento.