No me pides la autorizacion del root ?

12 envíos / 0 nuevos
Último envío
#1 Dom, 30/09/2018 - 15:20
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

No me pides la autorizacion del root ?

 Yo sigo probando con los discos e instalaciones. Ayer estuve a vueltas con la instalación del 9.5
 en uno de los que daban problemas con el escritorio del 9.1.
 Después de dos intentos, que acabaron en desastre, a la tercera parece que he logrado que se instale.
 ..Al menos aparentemente, ya que las palabras acentuadas y los caracteres no americanos los pinta como quiere,
 a la americana.  También veo algún aviso, al arrancar, nada grave, y cuando le doy a shutdown, empieza a
 recogerlo todo, pero cuando ya ha salido del entorno gráfico y debería terminar el cierre, se me despide
 con un kernel panic !.  (En fin, que le haremos, de momento botonazo y listos).

 Pero lo que me trae aquí es otro error.
 Durante el primer arranque, una de las cosas que haces es pasearte un poco por el escritorio, a ver si está
 todo donde debe.
 Cuatro configuraciones del entorno para estar más a gusto, y siguiente parada, el synaptic. Que aún queda
 mucho por instalar.

 Pero ... Le doy al menú, espero,  le vuelvo a dar,  espero. Hasta 4 veces repetí la orden.  Y nada.
 Oyes el click click del disco acusando la orden, pero allí no pasa nada. (Vaya, a ver si tendré que empezar
 por hacerle un dpkg al synaptic).

 Sigo paseando, y me doy cuenta de que la fecha está mal. Pues nada, a corregirlo.  Y cuando le doy a "establecer
 el tiempo" me suelta que no tengo permiso para esto.   Y sale,  sin más!.
 Vamos a ver!. Normalmente, ¿no te pide la autorización de root para aceptar o no la puesta en hora?.
 Y ahora que lo pienso, el acceso a synaptic también empieza con una ventanita que te pide las credenciales de
 administrador.   ¿Será eso lo que ocurre?, porque algún otro programa probado se ha abierto sin dificultad.

 He mirado en la cónsola de texto (tty lo que sea), y logueado como user me permite usar el su normalmente.
 Otra cosa ya es el sudo, que me dice que no soy "sudoer".  Pero no es la primera vez, ni la 2ª, ni la 3ª
 que un debian me dice esto, y a pesar de todo en los otros me salía la ventanita de autorización sin problema.
 La cosa debe ir por otro lado.

 Así pues, suponiendo que el problema en el escritorio sea eso, que no se dispara la ventana emergente
 para pedir la autorización,  ¿que programa/aplicación es el que se encarga de eso?.
 ¿Donde puedo mirar para ver donde empieza el fallo?.
 ( ¿Se da realmente la orden de pedir el pass?,   si se pide, ¿en que punto falla?,   si cree que no corresponde
 desplegar la ventana, ¿porque se me niega?.  Etc ).

 

Dom, 30/09/2018 - 17:59
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Gran planteamiento de problema y consulta, si señor... vamos mejorando xD

¿gnome, plasma, budgie, enlightement, xfce, lxde, lxqt, openbox, i3, icewm..? ¿has intentado configurar sudoers? ¿has lanzando synaptic desde consola? ¿has comprobado que tienes gksu instalado? ¿has configurado el idioma? ¿hay alguna constancia de los errores que comentas al inicio y del kernel panic del  final?

¿sigo? Tanto tiempo por estos lares...

  No hay bar que por bien no venga....
Lun, 01/10/2018 - 13:00
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Primero que nada, este post no cumple con las normas del foro, no tiene un titulo descriptivo, si bien hay una larga descripción de acciones realizadas no queda claro cual es el problema y tampoco se brinda información técnica o enlaces a donde se busco información, etc.

.....

 Pero ... Le doy al menú, espero,  le vuelvo a dar,  espero. Hasta 4 veces repetí la orden.  Y nada.
 Oyes el click click del disco acusando la orden, pero allí no pasa nada. (Vaya, a ver si tendré que empezar
 por hacerle un dpkg al synaptic)
....

Si el problema es con synaptic que no inicia desde un enlace simbólico o que poniendo la contraseña no inicia, puede ser por muchas cuestiones, podrías poner el resultado de un journalctl -b -p err y que te pone en una terminal cuando tiras de synaptic-pkexec o como su synaptic.

....

 Vamos a ver!. Normalmente, ¿no te pide la autorización de root para aceptar o no la puesta en hora?.
 Y ahora que lo pienso, el acceso a synaptic también empieza con una ventanita que te pide las credenciales de
 administrador.   ¿Será eso lo que ocurre?, porque algún otro programa probado se ha abierto sin dificultad.

....

En debian utilizan pkexec polkit https://www.freedesktop.org/software/polkit/docs/0.105/pkexec.1.html y para tirar de synaptic es synaptic-pkexec (seguramente tiene una configuración especial) y no pkexec synaptic

*Si usas gnome, y tenes un theme, fijate si sacando el theme el enlace synaptic funciona

 

saludos...

Mar, 02/10/2018 - 13:49
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Ups!, es verdad. Se me olvidó decir que el escritorio es mate, cierto.

 Pero lo que me va a ir muy bien es la lista de cosas a comprobar, que ante este problema, para mi desconcertante,

 no sabía ni por donde empezar, ya que el sistema en si arranca y parece correcto, es solo este  "pequeño detalle"

 de no poder autorizar las operaciones.

 

 Así por de pronto pues, incluirme en los sudoers, pedir journalctl -b -p err,  y luego probar con synaptic-pkexec, o

 pkexec synaptic  o como le guste más llamarlo.

 (¿Así que la famosa ventanita de autorización de root viene de pkexec.?)

 (Y ya que comento, ni sabía que synaptic se pudiese poner en marcha fuera del escritorio. Lo que se aprende! ).

 

 El idioma está en español, (otra cosa son los acentos, que no van),   Lo del gksu, pues no se, la verdad.

 En cuanto a los errores durante el arranque y el kernel panic al apagar, supongo que estarán por algún log,

 si es necesario lo copio y me lo traigo.

 

 No hurgué mucho por la instalación, porque después de 10 horas y media o algo más, era ya de noche,

 a la mañana siguiente tenía que venir para acá, y hasta este finde no podré volver a verlo.

 

 A ver si para entonces, o lo he corregido o tengo más datos que aportar, que en la apertura del post ni los tenía

 ni sabía como hacer para tenerlos.

 

 Gracias,  y disculpas.

 

Mar, 09/10/2018 - 14:52
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 Por algún lado hay que empezar. Lo haré por el synaptic, que es por lo que escribí.

 Ya decía yo. Aunque me ponga como root, si ordeno "synaptic" desde la consola, -la auténtica-, me dice:
 "Unable to init server: No se pudo conectar: Conexión rehusada.

 synaptic (839): Gtk WARNING **: Cannot open display".

 Paso al emulador de consola, (escritorio) y repito.  Como usuario simplemente me dice que no encontró la orden.
 Me hago root, con su, ordeno y el synaptic aparece sin ningún problema, tan majo como siempre.

 Luego se confirma mi sospecha, el synaptic está bien, sera un problema de permisos de root.

 Siguiente parada, entrar en la lista de sudoers.
 Una vez hecho le doy a la entrada del menú del escritorio, (ya lo dije el otro día, pero es mate),
 sigue sin aparecer. Desde la consola del escritorio, sigue sin reconocer la orden como usuario simple.
 Pero si le doy "sudo synaptic" entonces, después de identificarme si se abre.

 Vamos a ver pues que pasa con psexec.
 

percontator@Silver-Tosh:~$ synaptic-pkexec
==== AUTHENTICATING FOR com.ubuntu.pkexec.synaptic ===
Authentication is required to run the Synaptic Package Manager
Authenticating as: root
Password:
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
==== AUTHENTICATION FAILED ===
Error executing command as another user: Not authorized

This incident has been reported.

 Al menos se ha interesado en pedirme las credenciales antes de ingresar al synaptic

 percontator@Silver-Tosh:~$ sudo synaptic-pkexec
 Y se abre.    (?)

 

percontator@Silver-Tosh:~$ sudo journalctl -b -p err
[sudo] password for percontator:
-- Logs begin at Thu 2018-10-04 22:07:15 CEST, end at Fri 2018-10-05 00:53:17 CEST. --
oct 04 22:07:20 Silver-Tosh kernel: ipw2100 0000:02:0a.0: firmware: failed to load ipw2100-1.3.fw (-2)
oct 04 22:07:20 Silver-Tosh kernel: ipw2100: eth%d: ipw2100_get_firmware failed: -2
oct 04 22:07:20 Silver-Tosh kernel: ipw2100: eth%d: Failed to power on the adapter.
oct 04 22:07:20 Silver-Tosh kernel: ipw2100: eth%d: Failed to start the firmware.
oct 04 22:07:23 Silver-Tosh systemd-backlight[248]: Failed to get backlight or LED device 'backlight:acpi_video0': No such device
oct 04 22:07:23 Silver-Tosh systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0.
oct 04 22:07:34 Silver-Tosh avahi-daemon[390]: chroot.c: open() failed: No such file or directory
oct 04 22:34:39 Silver-Tosh pulseaudio[1002]: [pulseaudio] pid.c: Daemon already running.
oct 04 23:20:17 Silver-Tosh kernel: i2c i2c-1: sendbytes: error -110
oct 04 23:26:35 Silver-Tosh sudo[1333]:     percontator : user NOT in sudoers ; TTY=tty2 ; PWD=/home/percontator ; USER=root ; COMMAND=/usr/sbin/visud

 Esto es un poco contradictorio, se supone que me he hecho sudoer, pero no me identifica bien.  [??]
 Ah, espera.

 


-- Logs begin at Fri 2018-10-05 01:19:59 CEST, end at Fri 2018-10-05 01:31:13 CEST. --
oct 05 01:20:05 Silver-Tosh kernel: ipw2100 0000:02:0a.0: firmware: failed to load ipw2100-1.3.fw (-2)
oct 05 01:20:05 Silver-Tosh kernel: ipw2100: eth%d: ipw2100_get_firmware failed: -2
oct 05 01:20:05 Silver-Tosh kernel: ipw2100: eth%d: Failed to power on the adapter.
oct 05 01:20:05 Silver-Tosh kernel: ipw2100: eth%d: Failed to start the firmware.
oct 05 01:20:09 Silver-Tosh systemd-backlight[247]: Failed to get backlight or LED device 'backlight:acpi_video0': No such device
oct 05 01:20:09 Silver-Tosh systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0.
oct 05 01:20:18 Silver-Tosh avahi-daemon[387]: chroot.c: open() failed: No such file or directory
oct 05 01:20:57 Silver-Tosh kernel: i2c i2c-1: sendbytes: error -110
oct 05 01:20:58 Silver-Tosh kernel: i2c i2c-1: sendbytes: error -110
oct 05 01:25:57 Silver-Tosh pulseaudio[747]: [pulseaudio] pid.c: Daemon already running.
oct 05 01:25:57 Silver-Tosh pulseaudio[749]: [pulseaudio] pid.c: Daemon already running.
~

 Je je. Nada como un buen reinicio para que todos se actualicen y se enteren bien.  :)

 Aun así sigo sin ver nada relacionado con el tema que nos ocupa.
 Se queja del ipw2100, que lo tengo pero no me corre prisa instalárselo.
 De que no puede controlar como debe el backlight. (Cierto, pero por ahora con el control de energía
 ya lo tengo en un punto cómodo).
 Del pulse audio, que ya veré luego si suena o hay que arreglarlo.
 Y de algo del i2c.  (no se que quiere decir, pero ¿influye para algo en los permisos de root?).

 Y hablando de permisos, al intentar cambiar la fecha/hora no me deja. La explicación que me da:

 Not autorized for action
 org.mate.settingsdaemon.datetimemechanism.settime

 

 Vamos a ver lo del gksu.

 Ah, pues parece que ahí si hay algo. Libgksu2-0 si está instalado, pero gksu no.
 Punto para Panko.       Instalando.       Hecho.

 Pero cuando le doy a la entrada de synaptic del menú, sigue sin suceder nada.
 ¿Hay algún registro o alguna orden que permita ver la cadena de llamadas que efectúa el menú?,
 a ver si veo donde se corta la secuencia. ...Porque tiene que ser algo así.

 Mirando cosas he podido ver la orden de lanzamiento que da el menú.

 nombre         Gestor de paquetes Synaptic
 descripción    Gestor de paquetes
 orden          synaptic-pkexec
 comentario     Instalar, desinstalar y actualizar los paquetes de software
 tipo           archivo de configuración del escritorio (application/x-desktop)
 tamaño         9,0 kB (9017 bytes)

 Vamos a probar.

 En ventana user:


 percontator@Silver-Tosh:~$ synaptic-pkexec
==== AUTHENTICATING FOR com.ubuntu.pkexec.synaptic ===
Authentication is required to run the Synaptic Package Manager
Authenticating as: root
Password:
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
==== AUTHENTICATION FAILED ===
Error executing command as another user: Not authorized

This incident has been reported.

 

 Basicamente, lo mismo de antes de entrar en la lista sudo. Parece que pasa de sudo de identificaciones, etc.
 ¿Y porque carajo me sigue desautorizando?. Si ya estoy como sudoer, pero aquí no me deja ni con el
 pasword sudo ni con el del root.
 Y eso en la ventana de consola, porque fuera ni se molesta en abrir la ventanilla de autentificacion.

 ¿Alguien me echa una mano?.

 

 ¿Queda algo?.  Ah, si. Lo de los errores al encender y el panic al apagar.

 Lo del arranque, como ya dije, no creo que tenga mayor importancia. Básicamente, las lineas relativas a la
 falta de firmware para el ipw2100, y las advertencias de que no puede tomar el control de la iluminación
 del backlight.

 

 Buscando por los logs de /var/log he encontrado estas lineas, aunque no veo nada importante para el tema
 que nos ocupa ahora.

 En messages:


Oct  5 01:53:06 Silver-Tosh org.a11y.atspi.Registry[538]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Oct  5 01:54:07 Silver-Tosh org.a11y.atspi.Registry[608]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Oct  5 01:54:29 Silver-Tosh notification-ar[734]: Negative content width -2 (allocation 1, extents 1x2) while allocating gadget (node box, owner GtkBox)
Oct  5 01:55:27 Silver-Tosh clock-applet[733]: GtkDialog mapped without a transient parent. This is discouraged.
Oct  5 01:55:32 Silver-Tosh clock-applet[733]: GtkDialog mapped without a transient parent. This is discouraged.
Oct  5 01:55:46 Silver-Tosh clock-applet[733]: GtkDialog mapped without a transient parent. This is discouraged.
Oct  5 02:19:26 Silver-Tosh kernel: [ 1687.014272] nouveau 0000:01:00.0: DRM: Calling LVDS script 6:
Oct  5 02:19:26 Silver-Tosh kernel: [ 1687.014279] nouveau 0000:01:00.0: DRM: 0xB9C3: Parsing digital output script table
Oct  5 02:20:01 Silver-Tosh kernel: [ 1722.583057] nouveau 0000:01:00.0: DRM: Calling LVDS script 2:
Oct  5 02:20:01 Silver-Tosh kernel: [ 1722.583067] nouveau 0000:01:00.0: DRM: 0xBAC4: Parsing digital output script table
Oct  5 02:20:01 Silver-Tosh kernel: [ 1722.714109] nouveau 0000:01:00.0: DRM: Calling LVDS script 5:
Oct  5 02:20:01 Silver-Tosh kernel: [ 1722.714115] nouveau 0000:01:00.0: DRM: 0xB9AC: Parsing digital output script table
Oct  5 02:27:54 Silver-Tosh gvfsd[633]: dbus_mount_reply: Error from org.gtk.vfs.Mountable.mount(): Falló al obtener la lista de compartición del servidor: Conexión rehusada
Oct  5 02:27:54 Silver-Tosh gvfsd-network[1050]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: La ubicación especificada no está montada
Oct  5 02:27:54 Silver-Tosh gvfsd[633]: dbus_mount_reply: Error from org.gtk.vfs.Mountable.mount(): Falló al obtener la lista de compartición del servidor: Conexión rehusada
Oct  5 02:27:54 Silver-Tosh gvfsd-network[1045]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: La ubicación especificada no está montada

 

En syslog:

Oct  5 01:20:36 Silver-Tosh NetworkManager[401]: <info>  [1538695236.8219] manager: startup complete
Oct  5 01:20:57 Silver-Tosh kernel: [   66.376030] i2c i2c-1: sendbytes: error -110
Oct  5 01:20:58 Silver-Tosh kernel: [   68.140032] i2c i2c-1: sendbytes: error -110
Oct  5 01:21:12 Silver-Tosh kernel: [   81.400352] nouveau 0000:01:00.0: DRM: Calling LVDS script 6:
Oct  5 01:21:12 Silver-Tosh kernel: [   81.400364] nouveau 0000:01:00.0: DRM: 0xB9C3: Parsing digital output script table
Oct  5 01:21:12 Silver-Tosh kernel: [   81.920771] nouveau 0000:01:00.0: DRM: Calling LVDS script 2:
Oct  5 01:21:12 Silver-Tosh kernel: [   81.920782] nouveau 0000:01:00.0: DRM: 0xBAC4: Parsing digital output script table
Oct  5 01:21:12 Silver-Tosh kernel: [   82.051848] nouveau 0000:01:00.0: DRM: Calling LVDS script 5:
Oct  5 01:21:12 Silver-Tosh kernel: [   82.051857] nouveau 0000:01:00.0: DRM: 0xB9AC: Parsing digital output script table

....   .....

Oct  5 02:27:51 Silver-Tosh systemd[1]: Started Hostname Service.
Oct  5 02:27:54 Silver-Tosh gvfsd[633]: mkdir failed on directory /var/cache/samba: Permiso denegado
Oct  5 02:27:54 Silver-Tosh gvfsd[633]: mkdir failed on directory /var/cache/samba: Permiso denegado

Oct  5 02:27:54 Silver-Tosh gvfsd[633]: mkdir failed on directory /var/cache/samba: Permiso denegado
Oct  5 02:27:54 Silver-Tosh gvfsd[633]: mkdir failed on directory /var/cache/samba: Permiso denegado
Oct  5 02:27:54 Silver-Tosh gvfsd[633]: mkdir failed on directory /var/cache/samba: Permiso denegado
Oct  5 02:27:54 Silver-Tosh gvfsd[633]: mkdir failed on directory /var/cache/samba: Permiso denegado
Oct  5 02:27:54 Silver-Tosh gvfsd[633]: dbus_mount_reply: Error from org.gtk.vfs.Mountable.mount(): Falló al obtener la lista de compartición del servidor: Conexión rehusada
Oct  5 02:27:54 Silver-Tosh gvfsd-network[1050]: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: La ubicación especificada no está montada

....   ....
 
Oct  5 01:25:32 Silver-Tosh systemd[564]: Started D-Bus User Message Bus.
Oct  5 01:25:40 Silver-Tosh dbus-daemon[581]: Activating via systemd: service name='org.a11y.Bus' unit='at-spi-dbus-bus.service'
Oct  5 01:25:40 Silver-Tosh systemd[564]: Starting Accessibility services bus...
Oct  5 01:25:40 Silver-Tosh dbus-daemon[581]: Successfully activated service 'org.a11y.Bus'
Oct  5 01:25:40 Silver-Tosh systemd[564]: Started Accessibility services bus.
Oct  5 01:25:40 Silver-Tosh at-spi-bus-launcher[604]: Activating service name='org.a11y.atspi.Registry'
Oct  5 01:25:40 Silver-Tosh dbus-daemon[581]: Activating service name='ca.desrt.dconf'
Oct  5 01:25:40 Silver-Tosh at-spi-bus-launcher[604]: Successfully activated service 'org.a11y.atspi.Registry'
Oct  5 01:25:40 Silver-Tosh org.a11y.atspi.Registry[609]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Oct  5 01:25:40 Silver-Tosh dbus-daemon[581]: Successfully activated service 'ca.desrt.dconf'
Oct  5 01:25:42 Silver-Tosh x-session-manager[573]: WARNING: Unable to find provider '' of required component 'dock'
Oct  5 01:25:44 Silver-Tosh dbus-daemon[581]: Activating via systemd: service name='org.gtk.vfs.Daemon' unit='gvfs-daemon.service'
Oct  5 01:25:44 Silver-Tosh systemd[564]: Starting Virtual filesystem service...
Oct  5 01:25:44 Silver-Tosh dbus-daemon[581]: Successfully activated service 'org.gtk.vfs.Daemon'

 

 Lo demás, no se si habrá algo que se me haya escapado, pero al menos no veo ni warnings, ni 'error',
 ni lineas de asteriscos ni nada. No parece tener mayores problemas.

 Del fallo al apagar, no he conseguido encontrar nada del texto que sale en pantalla. pero aunque el
 principio del reporte se sale por arriba antes de que hayas podido leer nada, las últimas líneas hablan de:


 Kernel offset: 0x11000000 from 0xc1000000 (relocation range: 0xc0000000-0xf7ffdfff)
---[end Kernel panic - not syncing: Atemptted to kill init! exit code=0x00000009

 Por suerte veo que por la red hay gente con el mismo problema. Con un poco de suerte, en cuanto llegue
 el momento espero poder encontrar la causa.
 (Si no ya me tendréis por aquí dando la lata otra vez).   Pero de momento, una cosa a la vez, y a ver
 que aprendo de cada una.

 

Mar, 09/10/2018 - 18:07
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

sobre el tema de synaptic, el error

polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie

googleando aparece en infinidad de temas. fijate si polkit se esta ejecutado

su
systemctl status polkit.service

creo haber leído algo de gnome, asi que fijate si tenes el paquete policykit-1-gnome

PolicyKit es una aplicación de herramientas de desarrollo para el control de todo el sistema de privilegios en sistemas operativos del tipo UNIX. Proporciona la capacidad de que procesos no privilegiado puedan comunicarse con procesos privilegiados. En contraste con los sistemas como sudo, no concede permisos de root a todo un proceso, sino que permite un mayor nivel de control centralizado del sistema. Es producido por el proyecto freedesktop.org.

https://es.wikipedia.org/wiki/PolicyKit

a lo mejor por ese lado viene los tiros

saludos...

Jue, 11/10/2018 - 06:21
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Así pues el sospechoso principal es policyKit.

 Me llevo unos cuantos enlaces de google sobre el tema, y a ver si este 'finde' puedo hacerle de inquisidor.

 A ver si saco algo.

 

 Gracias

 

Sáb, 13/10/2018 - 14:56
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

consulta, ¿probaste de ejecutar synaptic solo con la theme default? si usas gnome sin ningún theme de shell todo default? ¿te fijaste si estas iniciando sesión en xorg y no en wayland? te comento esto porque recietemente tuve un problema similar con synaptic y era que gnome entraba en wayland y se ve que algo pasaba con los themes, puse todo default y entre en xorg y 0 problemas

 

saludos...

 

Mié, 17/10/2018 - 15:15
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

Ya está!, je je je, Ya lo tengo. cool
Pero cuando os diga lo que era, os vais a reir.
Aunque más importante son las cosas nuevas que he visto, y probado. smiley.   Lo primero probar lo sugerido/solicitado.
 

systemctl status polkit.service
 
* polkit.service - Authorization Manager
   Loaded: loaded (/lib/systemd/system/polkit.service; static; vendor preset: enabled)
   Active: active (running) since Wed 2018-10-10 22:16:43 CEST; 26min ago
     Docs: man:polkit(8)
 Main PID: 411 (polkitd)
    Tasks: 3 (limit: 4915)
   CGroup: /system.slice/polkit.service
           `-411 /usr/lib/policykit-1/polkitd --no-debug

oct 10 22:16:41 Silver-Tosh systemd[1]: Starting Authorization Manager...
oct 10 22:16:43 Silver-Tosh polkitd[411]: started daemon version 0.105 using authority implementation `local' version `0.10
oct 10 22:16:43 Silver-Tosh systemd[1]: Started Authorization Manager.
~

Aparentemente funciona, y está acivado.

Entonces lo siguiente es ver que me explica la web sobre el policy kit y sus componentes.

En  https://www.linuxquestions.org/questions/linux-desktop-74/authentication-agent-not-loading-running-4175593542/
leo: 

In the initial post I should have noted:

$ ps aux | grep polkit
polkitd 2988 0.0 0.3 379032 13724 ? Ssl nov15 0:00 /usr/lib/polkit-1/polkitd --no-debug

In other words, the polkit daemon is running, but not the authentication agent. The same command in my Manjaro systems shows both polkitd and lxpolkit running.

Creo que es lo mismo que me da a mi.  Si es mi caso, que el servicio, o demonio, esté en marcha pero el agente

de autentificación no, o que no lo pueda acceder, encajaría con mis datos del principio.
Vamos a tomar este supuesto.

 Lastima que la explicación no es exactamente para debian/ubuntu, por lo que no todo ha de encajar igual.
 Además de usar otro escritorio y otros programas y aplicaciones que no conozco.

______________________________________________________

El siguiente, más cercano, habla de que lo he compilado de esta manera, y con estas opciones, etc...
Aún así da algunos path que es bueno comparar y ver si están ahí.

_______________________________________________________

Siguiente:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=841878

Es curioso que ya en octubre de 2016, siendo stretch aún 'unstable', tuvo un bug en
policykit-1-gnome 0.105-4 , que se extendió a varias versiones.
¿Una regresión tal vez?.
 

I can confirm that:

A) Executing
'/usr/lib/x86_64-linux-gnu/polkit-gnome-authentication-agent-1' on the
command line enabled the expected dialog for launching Synaptic from XFCE;

B) The issue has been resolved with policykit-1-gnome 0.105-5.

Thank you.

On Oct 27, 2016 2:00 AM, "Simon McVittie" <smcv@debian.org> wrote:

> Control: reassign 842184 policykit-1-gnome 0.105-4
> Control: severity 842184 serious
>
> On Thu, 27 Oct 2016 at 07:27:05 +0000, Grand T wrote:
> > The error is in  policykit-1-gnome 0.105-4
> >
> >  /etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop refer to
> >
> > Exec=/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
> >
> > but it don't exist so it is not started !
> >
> > The exec is now at/usr/lib/x86_64-linux-gnu/polkit-gnome-authentication-
> agent-1
> >
> > I modified
> >
> > /etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop to set up
> > Exec=/usr/lib/x86_64-linux-gnu/polkit-gnome-authentication-agent-1
>
> Good catch! It looks as though this was caused by modernizing the
> packaging of policykit-1-gnome from debhelper 8 to 10, which changed its
> ${libexecdir}, without also updating
> debian/polkit-gnome-authentication-agent-1.desktop to use the new
> value of ${libexecdir}.
>
> So this is not actually a policykit-1 bug, but rather policykit-1-gnome,
> which is a separate source package. Contrary to its name, pk-1-gnome
> is not actually used in "full" GNOME any more (because GNOME Shell has
> its own built-in polkit agent), but it does get used in XFCE, Unity and
> GNOME Flashback.

Finalmente entiendo que fue un problema de paths debido a los cambios que se estaban haciendo.
Pero las búsquedas realizadas me han permitido encontrar la llamada al agente de autentificación.
Teniendo en cuenta que es difícil establecer la comparación, pues estoy en un archivo 2 años posterior,
con un i386-32 y escritorio mate, no gnome. (Veo que mate tiene su propio polkit, no el de gnome)
Pero un reporte interesante.
__________________________

Yo tengo:

 /usr/lib/i386-linux-gnu/polkit-mate/polkit-mate-authentication-agent-1    (biblioteca compartida (application/x-sharedlib))  46'4 KB

 /usr/lib/i386-linux-gnu/polkit-1/extensions/libnullbackend.so      (biblioteca compartida (application/x-sharedlib))

 /usr/lib/policykit-1/polkitd        (biblioteca compartida (application/x-sharedlib))

 /usr/lib/policykit-1/polkit-agent-helper-1      " "              " "

 /etc/xdg/autostart/polkit-mate-authentication-agent-1.desktop
 archivo de configuración del escritorio (application/x-desktop)     Agente de autenticación de PolicyKit para escritorio MATE

 orden:   /usr/lib/i386-linux-gnu/polkit-mate/polkit-mate-authentication-agent-1

 

Probando:

percontator@Silver-Tosh:~$  /usr/lib/i386-linux-gnu/polkit-mate/polkit-mate-authentication-agent-1

** (polkit-mate-authentication-agent-1:2723): WARNING **: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
Cannot register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
percontator@Silver-Tosh:~$

Aunque me es desconcertante que si ordeno
Exec=/usr/lib/i386-linux-gnu/polkit-mate/polkit-mate-authentication-agent-1
tal como sale en el reporte, y como lo hace el archivo de configuración, no sale nada, simplemente
me devuelve el prompt y espera la siguiente orden. Y no veo aparecer nada, ni avisos ni ventanas ni nada.
¿surprise?

 

___________________________________________________________________________________

En  https://forums.linuxmint.com/viewtopic.php?t=250998

ps axu | grep -v grep | grep policykit

This should display 2 lines. The poliykit daemon, run by user root. The policity authentication agent, run under your account.

Code: Select all

~$ ps axu | grep -v grep | grep policykit
root    1052  0.0  0.2 283748  8944 ?        Ssl  09:11   0:00 /usr/lib/policykit-1/polkitd --no-debug
karl    2197  0.0  0.8 487520 31552 ?        Sl   09:12   0:00 /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1

__________________________________________________________________________________

 

( Aquí viene "la madre del cordero" )

percontator@Silver-tosh:~$ ps axu | grep -v grep | grep policykit
root       657  0.0  0.6  36328  6848 ?        Ssl  17:55   0:00 /usr/lib/policykit-1/polkitd --no-debug

Hummm, sospechoso, solo el root, no estoy en la lista de usuarios admitidos. frown
Eeps!. Hagámoslo bien, por si las diferencias.
 

percontator@Silver-tosh:~$ ps axu | grep -v grep | grep polkit
root       657  0.0  0.6  36328  6848 ?        Ssl  17:55   0:00 /usr/lib/policykit-1/polkitd --no-debug

Igual.

En este mismo post insisten en que es importante, paralelamente, comprobar que servicios se inician con la sesion.  En el escritorio de debian lo tenemos fácil.

 ¡La madre que lo...!!!
Corrigiendo.

--- Otra sesión ----

percontator@Silver-tosh:~$ ps axu | grep -v grep | grep polkit
root       657  0.0  0.6  36328  6852 ?        Ssl  17:55   0:00 /usr/lib/policykit-1/polkitd --no-debug
percontator   2787  0.0  0.9  32852 10236 ?        Sl   19:26   0:00 /usr/lib/i386-linux-gnu/polkit-mate/polkit-mate-authentication-agent-1

Ahora si!. Esto ya está mucho mejor.  :)   Y además ya me han concedido la famosa ventanita de login.

 

¿Sabéis que es lo que se dejó el muy ...?
En las "aplicaciones al inicio", lo dejó todo correctamente puesto, - menos el policy kit, que lo dejó desmarcado.
A saber que aire le dio, o si estaría tomando durante la instalación, pero algo que hasta ahora
siempre lo había puesto bien, en esta ocasión lo dejó sin activar.
 Y el mareo que te da buscar la causa si no lo esperas o no sospechas. angry

Pero al menos, como decía he visitado otros sitios y visto otras cosas que si no, no te decides nunca
a meterte con ellas.
Y como decía el escritor, "bien está lo que bien acaba"

Y "colorin colorado".  :).

Muchas gracias a todos los que me han ayudado y orientado. Sin ellos no hubiera sabido por donde empezar.
 

Próxima parada, a ver que pasa con el core del final.

Vie, 19/10/2018 - 08:31
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Una última pregunta antes de cerrar el tema,  por curiosidad.

 

 En la situación que se daba, - con el servicio del polkit desactivado para el user al inicio de sesión,

 si hubiese querido activarlo manualmente, una vez abierta y usada la sesión, ¿que orden habría que dar?,

¿tal vez un sysctl  start polkit, o restart polkit.  O es otra cosa distinta ?.

 

 

 Se me ha ocurrido ahora, (y perdón por la pregunta). No lo he probado nunca, pero imagino que estas ordenes sysctl

 son propias del root  y no las puede ordenar el usuario, excepto con sudo.    ¿O si que puede?.

 

 

Vie, 19/10/2018 - 12:29
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

pueden usarlas tanto root, como el usuario. Todo depende de que vayas a hacer con ellas. Piensa que hay demonios que se inician con el sistema, pero hay otros que se inician con la sesión del usuario.

La orden systemctl comando tiene que ser utilizada como root, pero tienes el parámetro de usuario: systemctl --user comando con la que gestionas los servicios del usuario.

Uno de ellos, por poner un ejemplo, es pulseaudio. Pulseaudio no inicia con el sistema, si no que lo hace al iniciar sesión el usuario. En este caso, tendrías que usar systemctl --user reload-or-restart pulseaudio.service para reiniciarlo, por ejemplo.

Puedes saber que servicios inicia el user con el comando systemctl --user list-units. Esto te permite, además, crearte tus propios servicios de usuario, siendo estos gestionados por tí mismo sin necesidad de ser root.

  No hay bar que por bien no venga....
Dom, 21/10/2018 - 14:10
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Buena explicación, gracias.