Partición con Windows.

7 envíos / 0 nuevos
Último envío
#1 Lun, 09/10/2017 - 01:13
viclog_
Imagen de viclog_
Desconectado/a
se unió: 09/10/17

Partición con Windows.

Buenas noches, acabo de instalar mi Debian 9, lo que realice fue lo siguiente:

En mi disco duro de 1TB instale primero Windows 10, y debido al interés en Debian cree una partición para tener un dual boot con ambos sistemas, durante la instalación establecí que GRUB se instalará en el único disco, sin embargo al iniciar solamente me da la opción de iniciar con Debian, revise las particiones y la de windows aún esta ahí, es decir, no fue formateada, ahora... Necesito ayudar sobre como meter esa partición en GRUB y poder iniciar ambos sistema a disposición.

 

Muchas gracias por la ayuda.

Lun, 09/10/2017 - 10:02
rockyiii
Imagen de rockyiii
Conectado
administrator
se unió: 11/01/16

Antes de realizar un post hay que tomarse el trabajo de leer las normas del foro, en especial el punto 4 ¿me pregunto si "partición con windows" será un titulo descriptivo de tu problema? ¿y si una persona que tenga el mismo problema que el tuyo al leer "partición de windows" pueda deducir que se trata de un problema en el que grub no detecta a sistema operativo windows ?

fijate si tenes instalado os-prober https://packages.debian.org/stretch/os-prober

su
apt update
apt install os-prober
update-grub2

https://wiki.debian.org/Grub

Jue, 12/10/2017 - 13:24
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 Hola.

 Aparte de si falta o no algún paquete en tu instalación, o de si os-prober esta instalado y trabajando como debe, ten en cuenta

 que dada la gran dispersión de versiones del windows y la cantidad de ordenadores y dispositivos en los que lo han metido,

 grub no está garantizado a reconocer e instalar una entrada de grub a medida para cada caso y configuración con windows.

 (a mi por ejemplo, no me coje una pequeña partición ms-dos que tengo en un portátil).

 

 En tal caso, y si crees que todo está correcto y bien instalado se sugiere insertar a mano los parámetros para esa entrada, y luego

 llamar a update-grub.

 

  En mi caso particular:  https://exdebian.org/comment/2858#comment-2858

 Otros casos, (para windows ) :

 https://eldebiandepepe.wordpress.com/2012/01/30/como-agregar-un-s-o-en-el-grub-a-mano-en-debian/

 https://www.google.es/search?dcr=0&q=debian+grub+no+encuentra+windows+10&oq=debian+grub+no+encuentra+windows+10&gs_l=psy-ab.3...24623.26636.0.27636.7.7.0.0.0.0.109.604.5j2.7.0....0...1.1.64.psy-ab..0.2.196...0i13k1.0.eNztSN3_jXc

 

 (Te aviso, eso si, que si la formula dada en una página te da algún error del grub, confrontes la sintaxis y la secuencia de las lineas

 con las de otras páginas, ya que te digo por experiencia que a mi me marearon un poco con los corchetes, los parentesis, el chainloader

  las ordenes sobrentendidas y por tanto omitidas y la madre que los parió).

 ( Pero al fin lo acabas sacando. )

 

 

 

Vie, 20/10/2017 - 11:22
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

la pregunta aqui es... ¿cómo está particionado tu disco? Tiene toda la pinta de que con la instalación de debian, te has cargado el arranque uefi de windows metiendo ahi el grub... con lo que tu windows no tiene arranque, asi que grub no es capaz de encontrarlo.

Tanta información nos desborda...

  No hay bar que por bien no venga....
Dom, 22/10/2017 - 13:48
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Ah!, Como decía que el windows aún esta ahí yo asumí que si podía arrancarse, aunque no desde el grub.

Lun, 23/10/2017 - 11:43 (Responder a #5)
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Si, pero nos sigue faltando información, ni sabemos como está particionado el disco, si windows formateó en modo GPT e instaló la correspondiente partición para los arranques de UEFI (que es la que presumo, y digo presumo porque no tenemos información, como ya había dicho, te has cargado con la instalación de grub. Para los sistemas "modernos", hay varios tutoriales por ahí y, además, necesitarías grub-uefi y no grub, si mal no recuerdo.

  No hay bar que por bien no venga....
Mar, 24/10/2017 - 14:47
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Panko: " además, necesitarías grub-uefi y no grub, si mal no recuerdo."

Bueno, yo aún estoy con "los de toda la vida", pero cierto, es verdad, ese paquete lo he visto por ahi, supongo que

si usas arranque uefi ese debe ser el correcto.   (Al hablar de grub lo digo en generico, pero buen apunte).