Problemas con udev al actualizar de Wheezy a Jessie

2 envíos / 0 nuevos
Último envío
#1 Dom, 08/10/2017 - 17:22
eltitu
Imagen de eltitu
Desconectado/a
se unió: 08/10/17

Problemas con udev al actualizar de Wheezy a Jessie

Buenas.

He actualizado un sistema de Wheezy a Jessie (i386, sin entorno gráfico). En principio, todo ha ido bien excepto que no me deja actualizar el paquete udev. Con apt-get upgrade me dice:

Since release 198, udev requires support for the following features in
the running kernel:

- inotify(2)            (CONFIG_INOTIFY_USER)
- signalfd(2)           (CONFIG_SIGNALFD)
- accept4(2)
- open_by_handle_at(2)  (CONFIG_FHANDLE)
- timerfd_create(2)     (CONFIG_TIMERFD)
- epoll_create(2)       (CONFIG_EPOLL)
Since release 176, udev requires support for the following features in
the running kernel:

- devtmpfs         (CONFIG_DEVTMPFS)

Please upgrade your kernel before or while upgrading udev.

AT YOUR OWN RISK, you can force the installation of this version of udev
WHICH DOES NOT WORK WITH YOUR RUNNING KERNEL AND WILL BREAK YOUR SYSTEM
AT THE NEXT REBOOT by creating the /etc/udev/kernel-upgrade file.
There is always a safer way to upgrade, do not try this unless you
understand what you are doing!

dpkg: error al procesar el archivo /var/cache/apt/archives/udev_215-17+deb8u7_i386.deb (--unpack):
 el subproceso script pre-installation nuevo devolvió el código de salida de error 1
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Se encontraron errores al procesar:
 /var/cache/apt/archives/udev_215-17+deb8u7_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

 

Dado que el kernel que tengo instalado es el "oficial" de Debian, doy por hecho que está compilado con las opciones que necesita udev. He probado apt-get clean && dpkg --configure -a && apt-get -f install, pero sigo con el mismo error.

No me atrevo a desinstalar udev porque me da miedo no poder volverlo a instalar y, por ahora, el sistema funciona bien. ¿Cómo puedo solucionar esto? ¿A alguien le ha pasado?

 

Gracias por adelantado y un saludo a todos

Dom, 08/10/2017 - 19:42
Berbellon
Imagen de Berbellon
Desconectado/a
colaborador
se unió: 04/05/16

Saludos, haz leído las notas de lanzamiento de Jessie, https://www.debian.org/releases/jessie/i386/release-notes/ch-upgrading.en.html#newkernel

4.6. Upgrading your kernel and related packages
4.6.1. Installing a kernel metapackage

Realiza lo indicado, reinicia con el nuevo kernel y no deberías tener más problemas con "udev". Aunque puedo estar equivocado, puesto que hace años que no toco un sistema Debian y derivados.