Se cuelga el cursor del ratón inalámbrico en Debian 10 Buster cada cierto tiempo

3 envíos / 0 nuevos
Último envío
#1 Dom, 03/11/2019 - 15:02
viriato
Imagen de viriato
Desconectado/a
se unió: 29/08/17

Se cuelga el cursor del ratón inalámbrico en Debian 10 Buster cada cierto tiempo

Estado: 
[SOLUCIONADO]

Hasta ahora no me había pasado, pero el día de hoy, se ha congelado el ratón inalámbrico marca logitech 2 veces. He probado con otro teclado  inalámbrico que tiene touchpad en lugar de ratón y el problema es el mismo. No es que no reciba señal sino que el el cursor del ratón se queda congelado, a veces, puede seguir un video en Youtube reproduciéndose pero el cursor no se mueve y tienes que apagar y reiniciar el equipo para que el ratón pueda funcionar correctamente. ¿Alguno de ustedes ha tenido este problema?

 

Los componentes de mi equipo son los siguientes: 

 

  1. Placa base: ASUS ROG Strix X570-F Gaming - Placa Base de Gaming ATX AMD X570 con PCIe 4.0, iluminación Aura Sync, LAN 2,5 Gbps e Intel Gigabit, Dos M.2 con disip
  2. Tarjeta gráfica: ASUS ROG-STRIX-RX580-T8G-GAMING Radeon RX 580 8GB GDDR5 - Tarjeta gráfica (AMD, Radeon RX 580, 7680 x 4320 Pixeles, 1411 MHz, 1431 MHz, 8 GB)
  3. Microprocesador: AMD Ryzen 7 2700 - Procesador con disipador de calor Wraith Spire LED (20 MB, 8 núcleos, velocidad de 4.10 GhZ, 65 W)
  4. Fuente de alimentación: Corsair RM750 - Fuente de Alimentación (ATX Totalmente Modular, 80 Plus Gold, 750 W) color negro (CP-9020195-EU)
  5. Disco duro sólido interno SSD: Crucial P1 CT500P1SSD8 - Disco Duro sólido Interno SSD de 500 GB (3D NAND, NVMe, PCIe, M.2)
  6. Memoria RAM Corsair Vengeance RGB - Kit de memoria Entusiasta de 16 GB (2 x 8 GB, DDR4, 3200 MHz, C16 XMP 2.0) negro
  7. Instalé solamente  Debian 10 Buster en el disco duro y estoy contento con el rendimiento hasta ahora
Jue, 07/11/2019 - 14:07
viriato
Imagen de viriato
Desconectado/a
se unió: 29/08/17

He probado varias soluciones que he visto por ahí, no soy el único que tiene ese problema.

 

No sé si debe a que había algún problema en la superficie en la que muevo el ratón, humedad, polvo, lo que fuere o lo resolví gracias a estos links, que pongo aquí por si le sirve de ayuda a otros.

 

Lo primero que hice fue cambiar los parametros de configuración del ratón en Debian 10 Buster, fui al botón "Menú" de la barra de escritorio, y en buscar, escribí "Ratón y panel táctil" y modifiqué una serie de parametros, para que fuese más rápido.

 

También seguí estas instrucciones que son para touchpad:

 

https://slimbook.es/tutoriales/linux/65-solucion-problema-touchpad-en-linux

A todo aquel que haya "trasteado" con los drivers para solucionar el problema se recomienda hacer una nueva instalación limpia. También recomendamos sólo hacer esto si no nos funciona bien el touchpad, ya que en algunas versiones de Ubuntu no es necesario.

Bien, si eres de los que le funciona mal, funciona lento o responde con lentitud el touchpad, empieza abriendo un terminal o consola.

1- Deberemos editar un archivo del grub para añadir esta linea: i8042.nomux=1. Para ello escribimos el siguiente comando:

sudo -H gedit /etc/default/grub
2- Entonces veremos que se nos abre un archivo de texto, pues lo que haremos es buscar la linea: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash".


3- Un a vez localizada, añadir a continuación de "quiet splash" esta linea: i8042.nomux=1

Opcional: Podrias probar a definir también algunos de los siguientes parametros:

psmouse.resolution=1200

psmouse.resetafter=1

psmouse.rate=50

psmouse.smartscroll=1

mousedev.xres=1900

mousedev.yres=800

(Estos parametros se pueden poner individualmente o todos juntos entre las comillas de la linea mencionada antes)

Guardamos el documento y lo cerramos.

4- Seguidamente actualizaremos el grub, ejecutando el siguiente comando.

sudo update-grub

 

De momento, llevo varios días sin que el ratón se cuelgue.

Jue, 20/05/2021 - 16:47
siguiendoideas
Imagen de siguiendoideas
Desconectado/a
se unió: 18/05/21

Bueno, mi comentario no ayudara pero en mi caso termine instalando de nuevo, estaba un poco atrasado y decidi instalar una nueva version de debian

De un momento a otro pasaba justo esoq ue comentas, al principio crei que se habia trabado el sistema pero no porque los videos se seguian reproduciendo

1) Crei que era el cpu que se calentaba porque tenia un par de años que no limpiaba de polvo y si, el cooler estaba super lleno de polvo, no le pasaba nada de aire

2) Crei que era el disco duro que ya de porsi era descartado y pense que se bloqueaba por algun sector dañado (ya me habia pasado algo asi antes). Pues tampoco era eso

3) Por si las moscas cambie de HD e instale una nueva version de debian y pues se soluciono el problema

Lo curioso es que si cambiaba de puertos usb si funcionaban, tambien noté que si suspendia al regresar ya no funcionaban, pero lo mas curioso es que solo se bloqueaban si estaban en los perifericos USB destinados al mouse/teclado, si los colocaba en perifericos USB que no fueran los normalmente destinados a estos dos dispositivos no habia problemas, no aporta nada a tu solucion que parece que es la definitiva, pero comparto estas curiosidades xD