Videos en Debian Stretch + Gnome,fallas aleatorias durante la reproducción

36 envíos / 0 nuevos
Último envío
#1 Lun, 15/01/2018 - 18:18
Jaime
Imagen de Jaime
Desconectado/a
se unió: 15/01/18

Videos en Debian Stretch + Gnome,fallas aleatorias durante la reproducción

Estado: 
[SOLUCIONADO]

Hola amigos, soy nuevo en Linux, me decidí de una vez a botar Windows.

En las ultimas dos semanas he tenido unos loops que duran aproximadamente 3 segundos cuando veo videos en YouTube luego sigue la reproducción normal, aparecen como cada 6 u 8 minutos ¿a alguien le ha sucedido? Uso escritorio Gnome 3.

Edito: Me pasa en navegador Firefox, Pale Moon y Epiphany, son los tres que he probado. No tenía instalado VLC, acabo de reproducir dos videos y me van bien hasta el momento. Adjunté la información del hardware.

Saludos y gracias.

Lun, 15/01/2018 - 19:16
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

¿con que navegador web te pasa eso? ¿con vlc te pasa?

las características del hardware de tu pc serian de mucha ayuda, seria muy bueno que edites tu post y en la parte de "Poner información del hardware aquí" pongas el contenido de lshw -short te aclaro que lshw no viene en debian asi que primero lo tenes que instalar.
 

saludos...

Lun, 15/01/2018 - 21:26 (Responder a #2)
Jaime
Imagen de Jaime
Desconectado/a
se unió: 15/01/18

Ahí edité la información, amigo.

Saludos.

Mar, 16/01/2018 - 01:07
PabliNet
Imagen de PabliNet
Desconectado/a
se unió: 28/10/16

Corregime si está bien lo que entiendo: tu tarjeta gráfica no es Intel.

Mar, 16/01/2018 - 06:35 (Responder a #4)
Jaime
Imagen de Jaime
Desconectado/a
se unió: 15/01/18

PabliNet wrote:

Corregime si está bien lo que entiendo: tu tarjeta gráfica no es Intel.

Tiene la integrada que es intel, y la dedicada que es una nvidia 740m

Mar, 16/01/2018 - 10:08
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Seguramente no tenes instalados los controladores privativos de la tarjeta nvidia y por eso la reproducción de vídeo se ve muy pobre ya que debe estar echando mano del controlador libre para nvidia llamado nouveau que en algunos casos no funciona bien con las gráficas más nuevas

Voy a tratar de armarte una mini guia para que instales los drivers nvidia y puedas alternar entre la gráfica intel y la nvidia

Primero que nada tenes que instalar los repositorios main contrib non-free en tu sources.list

su
nano /etc/apt/sources.list
  • Para guarda los cambios en nano CTRL + o
  • Para salir de nano CTRL + x

https://exdebian.org/wiki/introducci%C3%B3n-los-repositorios-de-debian

https://manpages.debian.org/jessie/apt/sources.list.5.es.html

un ejemplo de como seria

deb http://deb.debian.org/debian stretch main contrib non-free
deb-src http://deb.debian.org/debian stretch main contrib non-free

deb http://deb.debian.org/debian stretch-updates main contrib non-free
deb-src http://deb.debian.org/debian stretch-updates main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free

 

Ya con los repositorios no libres cargados, lo que sigue es instalar el paquete nvidia-detect para detectar cual es el controlador adecuado para tu gráfica.

su
apt update
apt install nvidia-detect
nvidia-detect

En tu caso, seguramente te va a sugerir a nvidia-driver como driver para tu gráfica.

su
apt install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') nvidia-driver nvidia-settings

En una instalación normal solo faltaría agregar en Xorg.conf el driver de nvidia,

su
mkdir /etc/X11/xorg.conf.d
echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "nvidia"\nEndSection' > /etc/X11/xorg.conf.d/20-nvidia.conf

Pero como tu portátil tiene la posibilidad de alternar entre la gráfica intel y la nvidia, puede que lo mejor es que instales bumblebee, de esta forma por defecto el portátil usaría la gráfica intel y para situaciones determinadas la nvidia, aumentando el rendimiento de la bateríay  blablablabla...

En algunos tutoriales hablan de la posibilidad de alternar entre estas gráficas con la tecnologia Nvidia Prime (sin usar bumblebee), que se podría ejecutar desde nvidia settings https://www.muylinux.com/2014/08/27/nvidia-prime-ubuntu/

Para instalar bumblebee

su
apt install bumblebee-nvidia primus

Luego hay que agregar el usuario al grupo bumblebee

su
adduser nombre_de_tu_usuario bumblebee

para ejecutar una aplicación con la gráfica nvidia

optirun firefox

saludos...

Mar, 16/01/2018 - 11:51 (Responder a #6)
Jaime
Imagen de Jaime
Desconectado/a
se unió: 15/01/18

rockyiii wrote:

Seguramente no tenes instalados los controladores privativos de la tarjeta nvidia y por eso la reproducción de vídeo se ve muy pobre ya que debe estar echando mano del controlador libre para nvidia llamado nouveau que en algunos casos no funciona bien con las gráficas más nuevas

Voy a tratar de armarte una mini guia para que instales los drivers nvidia y puedas alternar entre la gráfica intel y la nvidia

Primero que nada tenes que instalar los repositorios main contrib non-free en tu sources.list

su
nano /etc/apt/sources.list
  • Para guarda los cambios en nano CTRL + o
  • Para salir de nano CTRL + x

https://exdebian.org/wiki/introducci%C3%B3n-los-repositorios-de-debian

https://manpages.debian.org/jessie/apt/sources.list.5.es.html

un ejemplo de como seria

deb http://deb.debian.org/debian stretch main contrib non-free
deb-src http://deb.debian.org/debian stretch main contrib non-free

deb http://deb.debian.org/debian stretch-updates main contrib non-free
deb-src http://deb.debian.org/debian stretch-updates main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free

 

Ya con los repositorios no libres cargados, lo que sigue es instalar el paquete nvidia-detect para detectar cual es el controlador adecuado para tu gráfica.

su
apt update
apt install nvidia-detect
nvidia-detect

En tu caso, seguramente te va a sugerir a nvidia-driver como driver para tu gráfica.

su
apt install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') nvidia-driver nvidia-settings

En una instalación normal solo faltaría agregar en Xorg.conf el driver de nvidia,

su
mkdir /etc/X11/xorg.conf.d
echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "nvidia"\nEndSection' > /etc/X11/xorg.conf.d/20-nvidia.conf

Pero como tu portátil tiene la posibilidad de alternar entre la gráfica intel y la nvidia, puede que lo mejor es que instales bumblebee, de esta forma por defecto el portátil usaría la gráfica intel y para situaciones determinadas la nvidia, aumentando el rendimiento de la bateríay  blablablabla...

En algunos tutoriales hablan de la posibilidad de alternar entre estas gráficas con la tecnologia Nvidia Prime (sin usar bumblebee), que se podría ejecutar desde nvidia settings https://www.muylinux.com/2014/08/27/nvidia-prime-ubuntu/

Para instalar bumblebee

su
apt install bumblebee-nvidia primus

Luego hay que agregar el usuario al grupo bumblebee

su
adduser nombre_de_tu_usuario bumblebee

para ejecutar una aplicación con la gráfica nvidia

optirun firefox

saludos...

 

Muchas gracias por la ayuda.

Instalé nvidia-detect, pero después cuando ejecuto el comando nvidia-detect me dice: No NVIDIA GPU detected.

 

 

Mar, 16/01/2018 - 12:45
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

pero en la información de hardware te marca que tenes una  GeForce GT 740M podrías fijarte de reiniciar y volver a probar o sino en la configuración de la bios de esa notebook si esta deshabilitada la gforce o si hay alguna tecla especial para activarla.

Realmente me parece extraño que lshw la detecte y nvidia-detect no.

La otra que se me ocurre, aunque no tiene nada que ver con esto, es que necesites hacer un update upgrade y por eso no te este andando bien nvidia-detect, de ser asi proba con:

su
apt update && apt upgrade && apt full-upgrade && apt clean

saludos...

Mar, 16/01/2018 - 15:17 (Responder a #8)
Jaime
Imagen de Jaime
Desconectado/a
se unió: 15/01/18

rockyiii wrote:

pero en la información de hardware te marca que tenes una  GeForce GT 740M podrías fijarte de reiniciar y volver a probar o sino en la configuración de la bios de esa notebook si esta deshabilitada la gforce o si hay alguna tecla especial para activarla.

Realmente me parece extraño que lshw la detecte y nvidia-detect no.

La otra que se me ocurre, aunque no tiene nada que ver con esto, es que necesites hacer un update upgrade y por eso no te este andando bien nvidia-detect, de ser asi proba con:

su
apt update && apt upgrade && apt full-upgrade && apt clean

saludos...

Sigue sin funcionar.

He ejecutado lspci y dentro de todo lo que sale, me muestra lo siguiente:

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)

y más abajo, esto:

01:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1)

¿habrá alguna diferencia que detecte la GPU como controlador 3D y no como controlador VGA?

 

P.D: En la Bios no sale por ninguna parte la configuración de dispositivos gráficos. Buscando por ahí y por allá instalé nvidia-driver, pero al reiniciar me tiró error antes de la pantalla de inicio de sesión, así que tuve que reinstalar Debian, ya es como la quinta vez que lo instalo probando cosas.

 

Saludos.

Mar, 16/01/2018 - 17:12
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

En windows tenias solo la intel como gráfica o también tenias la nvidia.???

Lo unico que se me ocurre es que sigas el procedimiento solo hasta la parte de instalar nvidia-driver nvidia-settings y no pongas esta parte:

su
mkdir /etc/X11/xorg.conf.d
echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "nvidia"\nEndSection' > /etc/X11/xorg.conf.d/20-nvidia.conf

si te tira errores copia y pegalos, no reinstales debian

ejecuta journal para ver que errores tira

su
journalctl -b -p err

 

Mar, 16/01/2018 - 17:37 (Responder a #10)
Jaime
Imagen de Jaime
Desconectado/a
se unió: 15/01/18

rockyiii wrote:

En windows tenias solo la intel como gráfica o también tenias la nvidia.???

Lo unico que se me ocurre es que sigas el procedimiento solo hasta la parte de instalar nvidia-driver nvidia-settings y no pongas esta parte:

su
mkdir /etc/X11/xorg.conf.d
echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "nvidia"\nEndSection' > /etc/X11/xorg.conf.d/20-nvidia.conf

si te tira errores copia y pegalos, no reinstales debian

ejecuta journal para ver que errores tira

su
journalctl -b -p err

 

Cuando instalé nvidia-driver me tiro una pantalla que decía: El módulo nouveau cargado en el núcleo genera conflicto. El módulo libre nouveau del núcleo está cargado y genera conflictos con el módulo no libre nvidia del núcleo. La manera más sencilla de solucionarlo es reiniciar la máquina una vez la instalación haya concluido.

Eso me salió hoy también cuando instalé ese driver, y cuando reinicié me tiro el error en la pantalla de inicio de sesión y no pude entrar al equipo y por lo tanto reinstalé Debian.

Te detallo los errores que tira journal:

 

-- Logs begin at Tue 2018-01-16 15:52:58 -03, end at Tue 2018-01-16 17:25:08 -03
ene 16 15:52:58 debian-nb kernel: ACPI Error: No handler for Region [EC__] (ffff
ene 16 15:52:58 debian-nb kernel: ACPI Error: Region EmbeddedControl (ID=3) has
ene 16 15:52:58 debian-nb kernel: ACPI Error: Method parse/execution failed [\_S
ene 16 15:52:58 debian-nb kernel: ACPI Error: [DSSP] Namespace lookup failure, A
ene 16 15:52:58 debian-nb kernel: ACPI Error: Method parse/execution failed [\_S
ene 16 15:52:58 debian-nb kernel: ACPI Error: [DSSP] Namespace lookup failure, A
ene 16 15:52:58 debian-nb kernel: ACPI Error: Method parse/execution failed [\_S
ene 16 15:53:03 debian-nb kernel: bluetooth hci0: firmware: failed to load rtl_b
ene 16 15:53:03 debian-nb kernel: Bluetooth: hci0: Failed to load rtl_bt/rtl8723
ene 16 15:53:04 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 085014 fffff
ene 16 15:53:04 debian-nb kernel: nouveau 0000:01:00.0: priv: GPC0: 4188ac 00000
ene 16 15:53:04 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 10ecc0 fffff
ene 16 15:53:04 debian-nb kernel: rtl8723ae 0000:05:00.0: firmware: failed to lo
ene 16 15:53:04 debian-nb kernel: nouveau 0000:01:00.0: DRM: Pointer to TMDS tab
ene 16 15:53:04 debian-nb kernel: nouveau 0000:01:00.0: DRM: Pointer to flat pan
ene 16 15:53:04 debian-nb kernel: ACPI Error: [\_SB_.PCI0.GFX0.DD02._BCL] Namesp
ene 16 15:53:04 debian-nb kernel: ACPI Error: Method parse/execution failed [\_S
ene 16 15:53:09 debian-nb avahi-daemon[521]: chroot.c: open() failed: No such fi
ene 16 15:53:26 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 085014 fffff
ene 16 15:53:26 debian-nb kernel: nouveau 0000:01:00.0: priv: GPC0: 4188ac 00000
ene 16 15:53:26 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 10ecc0 fffff
ene 16 15:53:37 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 085014 fffff
lines 1-23...skipping...
-- Logs begin at Tue 2018-01-16 15:52:58 -03, end at Tue 2018-01-16 17:25:08 -03. --
ene 16 15:52:58 debian-nb kernel: ACPI Error: No handler for Region [EC__] (ffff8f1bef1b9cf0) [EmbeddedControl] (20160831/evregion-166)
ene 16 15:52:58 debian-nb kernel: ACPI Error: Region EmbeddedControl (ID=3) has no handler (20160831/exfldio-299)
ene 16 15:52:58 debian-nb kernel: ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC._REG] (Node ffff8f1bef1bac30), AE_NOT_EXIST (20160831/p
ene 16 15:52:58 debian-nb kernel: ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
ene 16 15:52:58 debian-nb kernel: ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT4._GTF] (Node ffff8f1bef1ed960), AE_NOT_FOUND (20160831
ene 16 15:52:58 debian-nb kernel: ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
ene 16 15:52:58 debian-nb kernel: ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT4._GTF] (Node ffff8f1bef1ed960), AE_NOT_FOUND (20160831
ene 16 15:53:03 debian-nb kernel: bluetooth hci0: firmware: failed to load rtl_bt/rtl8723a_fw.bin (-2)
ene 16 15:53:03 debian-nb kernel: Bluetooth: hci0: Failed to load rtl_bt/rtl8723a_fw.bin
ene 16 15:53:04 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 085014 ffffffff (1d70820b)
ene 16 15:53:04 debian-nb kernel: nouveau 0000:01:00.0: priv: GPC0: 4188ac 00000001 (1870822e)
ene 16 15:53:04 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 10ecc0 ffffffff (1e70822c)
ene 16 15:53:04 debian-nb kernel: rtl8723ae 0000:05:00.0: firmware: failed to load rtlwifi/rtl8723fw_B.bin (-2)
ene 16 15:53:04 debian-nb kernel: nouveau 0000:01:00.0: DRM: Pointer to TMDS table invalid
ene 16 15:53:04 debian-nb kernel: nouveau 0000:01:00.0: DRM: Pointer to flat panel table invalid
ene 16 15:53:04 debian-nb kernel: ACPI Error: [\_SB_.PCI0.GFX0.DD02._BCL] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
ene 16 15:53:04 debian-nb kernel: ACPI Error: Method parse/execution failed [\_SB.PCI0.PEG0.PEGP.DD02._BCL] (Node ffff8f1bef1fc668), AE_NOT_FOUND (201
ene 16 15:53:09 debian-nb avahi-daemon[521]: chroot.c: open() failed: No such file or directory
ene 16 15:53:26 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 085014 ffffffff (1c70820b)
ene 16 15:53:26 debian-nb kernel: nouveau 0000:01:00.0: priv: GPC0: 4188ac 00000001 (1f70822e)
ene 16 15:53:26 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 10ecc0 ffffffff (1b70822c)
ene 16 15:53:37 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 085014 ffffffff (1c70820b)
ene 16 15:53:37 debian-nb kernel: nouveau 0000:01:00.0: priv: GPC0: 4188ac 00000001 (1f70822e)
ene 16 15:53:37 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 10ecc0 ffffffff (1b70822c)
ene 16 15:53:44 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 085014 ffffffff (1c70820b)
ene 16 15:53:44 debian-nb kernel: nouveau 0000:01:00.0: priv: GPC0: 4188ac 00000001 (1f70822e)
ene 16 15:53:44 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 10ecc0 ffffffff (1b70822c)
ene 16 16:04:35 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 085014 ffffffff (1c70820b)
ene 16 16:04:35 debian-nb kernel: nouveau 0000:01:00.0: priv: GPC0: 4188ac 00000001 (1f70822e)
ene 16 16:04:35 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 10ecc0 ffffffff (1b70822c)
ene 16 16:04:49 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 085014 ffffffff (1c70820b)
ene 16 16:04:49 debian-nb kernel: nouveau 0000:01:00.0: priv: GPC0: 4188ac 00000001 (1f70822e)
ene 16 16:04:49 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 10ecc0 ffffffff (1b70822c)
ene 16 16:05:31 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 085014 ffffffff (1c70820b)
ene 16 16:05:31 debian-nb kernel: nouveau 0000:01:00.0: priv: GPC0: 4188ac 00000001 (1f70822e)
ene 16 16:05:31 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 10ecc0 ffffffff (1b70822c)
ene 16 17:20:52 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 085014 ffffffff (1c70820b)
ene 16 17:20:52 debian-nb kernel: nouveau 0000:01:00.0: priv: GPC0: 4188ac 00000001 (1f70822e)
ene 16 17:20:52 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 10ecc0 ffffffff (1b70822c)
ene 16 17:23:54 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 085014 ffffffff (1c70820b)
ene 16 17:23:54 debian-nb kernel: nouveau 0000:01:00.0: priv: GPC0: 4188ac 00000001 (1f70822e)
ene 16 17:23:54 debian-nb kernel: nouveau 0000:01:00.0: priv: HUB0: 10ecc0 ffffffff (1b70822c)

 

Saludos.

Mar, 16/01/2018 - 18:10
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

ese mensaje esta bien, el driver privativo de nvidia lo que hace es ocupar el lugar del libre nouveau,  fijate que la mayoria de los errores que te pones journal se relacionan con nouveau.

En teoría, ahora tendría que arrancar con el driver de intel, asi que no deberías tener problemas si reinicias.

si no tenes problemas busca el icono nividia setting y fijate si te aparece

o sino instalar bumblebee-nvidia primus como te puse en la guia

PD: no cites todo porque se hace muy largo el post

Mar, 16/01/2018 - 18:23 (Responder a #12)
Jaime
Imagen de Jaime
Desconectado/a
se unió: 15/01/18

Reinicié y en la pantalla de inicio de sesión me tira pantallas gris con el mensaje: Algo salió mal. Ocurrió un problema y el sistema no se puede recuperar. Cierre la sesión e inténtelo de nuevo.

Presiono enter para cerrar la sesión pero me sigue saliendo la misma pantalla.

Agrego: En Win10 si usaba la tarjeta.

Mar, 16/01/2018 - 19:00
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Quita todo lo que hayas instalado de nvidia (nvidia-driver no es necesario instalarlo la mayoría de las veces), reiniciar el sistema, y ahora tal y como está, instala y ejecuta nvidia-detect (comprueba que tu user está en el grupo video, por si acaso).

~$ nvidia-detect
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119M [GeForce 610M] [10de:1058] (rev ff)

Checking card:  NVIDIA Corporation GF119M [GeForce 610M] (rev ff)
Your card is supported by all driver versions.
It is recommended to install the
    nvidia-driver
package.

nvidia-detect nunca devuelve una salida nula, o te dice que no hay (con lo que me suena a que no tienes acceso al hardware (grupo vídeo), o te dice que no sabe que distro usas y no puede decirte que controlador instalar.

Basándome en tus especificaciones, tu hardware está soportado por el controlador actual, así que, para mi entender, el proceso que debes seguir es bien sencillo.

1.- Viendo la gráfica integrada que tienes, desinstala el paquete xserver-xorg-video-intel, el controlador del kernel es mas nuevo y el que viene en repositorios apenas está mantenido.

2.- Compbrueba como te han dicho que no tienes ningún /etc/X11/xonrg.conf ni ningún archivo en /etc/X11/xorg.conf.d/ que haga referencia a intel, nouevau, o nvidia

3.- instala el controlador que te haya dicho nvidia-detect (como he dicho, tu hardware debería estar soportado por el último, con lo que imagino que te dirá nvidia-driver, pero no es nvidia-driver lo que tienes que instalar, si no  su correspondiente paquete xserver-xorg-video-nvidia)

su
apt install xserver-xorg-video-nvidia bumblebee-nvidia linux-headers-`uname -r` build-essential bbswitch-dkms

deja que acabe el proceso. Si hubiera algún error durante la instalación de xserver-xorg-video-nvidia, reinicia, el sistema arrancará como siempre usando la intel (si, siempre usa la intel, aunque quieras la nvidia), y reinstala las partes correspondientes

su
apt install reinstall ~invidia ~idkms

una vez hecho esto, si no te ha dado ningún error, al reiniciar, el módulo nouveau estará blacklisteado y el sistema no cargará ni nouveau ni nividia, de todo eso se encargará la configuración de bumblebee, la cual puedes comprobar en el archivo /etc/bumblebee/bumblebee.conf para ver si usará el módulo nouveau o nvidia. Usualmente, viene configurado en auto, tu puedes poner el que desees que se utilice.

Con todo esto hecho correctamente, como te han dicho, para ejecutar algo usando la nvidia,  usas el comando optirun programa o primusrun programa.

 

Por otro lado, veo varios errores de acpi, demasiados de los que debería haber, igual necesitas  una configuración extra... ¿que modelo de ordenador es? con esa información igual te podemos pasar un parámetro de arranque que solucione  la mitad de tus problemas.

  No hay bar que por bien no venga....
Mar, 16/01/2018 - 20:43
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Aparentemente hay casos que nvidia-detect: arroja un No NVIDIA GPU detected. 

Es como que para la aceleración 3d usa la nvidia pero para el resto la intel. por algún motivo esta tomando mal el driver 375 entonces pierde aceleración 3d y como gnome necesita aceleración 3d no puede entrar al escritorio y le pone Algo salió mal. Ocurrió un problema y el sistema no se puede recuperar. Cierre la sesión e inténtelo de nuevo.

a lo mejor se podría probar de utilizar el driver 340 que seria nvidia-legacy-340xx-driver

su
apt install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') nvidia-legacy-340xx-driver nvidia-settings-legacy-340xx

Si no puedes entrar al escritorio, puedes entrar a una tty con la combinación de teclas CTL + Alt + F1 podes poner tu nombre de usuario y pass o sino directamente te logueas como root con las pass de root

 

Mar, 16/01/2018 - 20:45 (Responder a #15)
Jaime
Imagen de Jaime
Desconectado/a
se unió: 15/01/18

Realicé los pasos que me dijiste e instalé: xserver-xorg-video-nvidia...etc. No me salió ningún error durante la instalación, reinicié por si acaso y arrancó bien y entré con mi usuario.

Mi notebook:

MSI CX61 intel core i5-4200M
GPU Nvidia GeForce GT 740M 2GB DDR3
8GB RAM DDRIII

Nvidia-detect me sigue sin reconocer mi tarjeta y mi usuario está en el grupo video:

jaime@debian-nb:~$ nvidia-detect
No NVIDIA GPU detected.
jaime@debian-nb:~$ su
Contraseña: 
root@debian-nb:/home/jaime# nvidia-detect
No NVIDIA GPU detected.

 

Revisé el bumblebee.conf y está en automático:

# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=

Dejaré el detalle del archivo completo pos si acaso:

# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=
# Directory with a dummy config file to pass as a -configdir to secondary X
XorgConfDir=/etc/bumblebee/xorg.conf.d
# Xorg binary to run
XorgBinary=/usr/lib/xorg/Xorg

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=auto
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
#       switcheroo - vga_switcheroo method, use at your own risk
#             none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia/nvidia,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

 

Mié, 17/01/2018 - 04:09
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Bueno, pues ha habido suerte, almenos ya vuelves a tener el sistema en funcionamiento.

Respecto al principal problema, ¿sigue ocurriéndote lo mismo o no? el primer caso no debería ser problema alguno del hardware, ya que tu equipo es bastante capaz para reproducir casi cualquier tipo de vídeo (y mas sabiendo que vlc lo hace perfectamente), más bien parece un problema puntual con alguna configuración.

Respecto al driver a utilizar para la gráfica dedicada, puedes modificar ese parámetro en el archivo de configuración poniendo nouveau o nvidia (también te recomiendo poner el parámetro TurnCardOffAtExit en true para asi apagar la gráfica dedicada y ahorrar energía), reiniciar el servicio de bumblebee y ver cual te da mejor resultado y quedarte con él. Viendo tu equipo, que es posterior al mio (yo tengo un i7 de 3ª generación conuna intel hd4000 y una nvidia 610m) y tu un i5 de 4ª, que si bien no llega al i7 de 3ª, no anda muy lejos. La Intel es superior a la mía, por eso te recomendé desinstalar el driver de intel para usar el del kernel, y la nvidia es modernilla, digamos, por eso recomendé dicho paquete, que equivaldría al resultado de nvidia-detect (nvidia-driver).

Desconocía ese "bug"  de nvidia-detect, lo que si me ha ocurrido a veces, durante el lanzamiento de las releases, que no ha acabado de cambiar la nomemclatura de Sid/Unstable, es no saber que version del sistema estoy usando (sid pasa a llamarse sid/siguiente-release pasado un tiempo, y nvidia-detect no sabe que recomendar). Y, si no hay opción en la bios de escojer tarjeta gráfica a utilizar, sin duda se trata de la infame tecnología Optimus, intel siempre en uso, y la nvidia para los casos que quieras que haga el trabajo duro y le pase los resultados a la intel).

  No hay bar que por bien no venga....
Mié, 17/01/2018 - 07:44 (Responder a #17)
Jaime
Imagen de Jaime
Desconectado/a
se unió: 15/01/18

Muchas gracias a ambos, de verdad se pasaron, gracias además por la paciencia, sobre todo a rocky jajaja.

Pero el problema principal sigue pasando, quizás sea algo con flash o con gnome en particular. Creo haber instalado flash en su momento cuando comencé con este problema, ahora no lo tengo instalado, lo haré y les comentaré qué tal va.

Mié, 17/01/2018 - 09:38
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

Youtube no usa más flash hace tiempo, y prácticamente se podría decir que flash ha desaparecido de la web.
Si instalaste Bumblebee ejecuta
 

optirun firefox
o
optirun chromium

y fijate si sigue dando problemas al ver los vídeos en youtube.

hiciste lo que te decía panko de desinstalar el paquete xserver-xorg-video-intel quiero decir los vídeos de youtube con la gráfica intel los tenes que ver muy bien

Mié, 17/01/2018 - 10:28 (Responder a #19)
Jaime
Imagen de Jaime
Desconectado/a
se unió: 15/01/18

Agregué mi usuario al grupo bumblebee pero aun así no me deja ejecutar la accion: optirun firefox, me dice esto:

jaime@debian-nb:~$ optirun firefox
[10382.090037] [ERROR]You've no permission to communicate with the Bumblebee daemon. Try adding yourself to the 'bumblebee' group
[10382.090055] [ERROR]Could not connect to bumblebee daemon - is it running?

Lo ejecuté con sudo y se abrió firefox, pero el problema del video persiste, ¿puede ser un problema del entorno de escritorio?

Mié, 17/01/2018 - 11:02
rockyiii
Imagen de rockyiii
Desconectado/a
administrator
se unió: 11/01/16

si te fijas en la mini guia y en la url de wiki de debian que te pase tenes que agregar tu usuario al grupo bumblebee

para quitar xserver-xorg-video-intel

su
apt remove xserver-xorg-video-intel

AGREGO: -----------

Como creo que estas usando gnome te puede ser de ayuda la extensión Bumblebee Indicator (hay 2 iguales tendrías que fijarte cual de las dos te gusta mas)

AGREGO2:------------

que te pone si ejecutas

systemctl status bumblebeed.service