Kernel 5.6 me produces flashes en la pantalla

7 envíos / 0 nuevos
Último envío
#1 Mié, 13/05/2020 - 07:45
Vctrsnts
Imagen de Vctrsnts
Desconectado/a
se unió: 15/03/16

Kernel 5.6 me produces flashes en la pantalla

Buenas.

Tengo Debian SID con la versió 5.4 del kernel ( anteriormente tenia la versión 5.3 pero tuve que reinstalar ) pero veo que no estan disponibles los headers del kernel para virtualbox.

Entonces, he probado la versión 5.6 de "linux-image" y cada cierto tiempo la pantalla del portatil me hace unos flashes que asusta, con la versión 5.3 y ahora con la versión 5.4 no me pasa ( y eso que el portatil se pasa horas encendido ) pero en cambio haciendo el mismo uso pero con la versión 5.6 la pantalla parece las luces de una discoteca.

Alguien tiene este problema? He buscado por inet, pero no encuentro nada y tambien estoy buscando los headers del kernel 5.4 pero no estan en el respositorio de SID, solo estan los del 5.6...

Gracias si podeis echarme un cable porque no se por donde tirar...

Mié, 13/05/2020 - 22:20
gacs
Imagen de gacs
Desconectado/a
colaborador
se unió: 21/04/16

Debes proporcionar información del equipo, además información del sistema si te presenta algún mensaje de error;

sudo lspci -k
sudo journalctl -b -p err

 Saludos

 

Jue, 14/05/2020 - 07:44
Vctrsnts
Imagen de Vctrsnts
Desconectado/a
se unió: 15/03/16

Gracias,

Con respecto a los mensajes de error, no puedo poner porque no aparece nada y eso que estoy revisando los siguientes ficheros :

  • /var/log/kern.log
  • /var/log/message
  • /var/log/syslog

Con respecto al equipo es el siguiente lo pongo aqui porque sino seria un poco largo.

Rectifico lo que he puesto antes.

Ahora me acaba de pasar y he visto el siguiente error que anteriormente no estaba

May 14 16:37:56  kernel: [ 1821.849043] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun

De nuevo, gracias por todo

Jue, 14/05/2020 - 14:15
Vctrsnts
Imagen de Vctrsnts
Desconectado/a
se unió: 15/03/16

Buenas,

Añado más información que he encontrado y una posible solución que no entiendo bien como aplicar.

En este mismo foro ( este mensaje ) hay una persona que dice que tiene el mismo mensaje de error que yo tengo ( o parecido ) y entonces el usuario @panko le dice que lo correcto es desinstalar el driver xserver-xorg-video-intel para asi que se use el del propio kernel.

Yo lo he probado, pero cuando intento quitar dicho paquete / driver mi dice que me instalara el paquete / driver xserver-xorg-vide-ivtv y estoy viendo que esto es una una capturadora.

Entonces cual se tiene que instalar?? Gracias si podeis echarme un cable...

Mar, 19/05/2020 - 07:38 (Responder a #4)
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Es posible, suponiendo que aplicar la solución de otro hilo te funcione, que tengas instalado el metapaquete xserver-xorg-video-all, lo que provocaría que eliminar algun otro paquete de xserver-xorg-video quiera instalar otro para mantener sus dependencias. Si sabes que paquetes necesita tu sistema, puedes desinstalar dicho xserver-xorg-video-all y mantener instalados los tuyos. En mi caso, con un equipo con intel+nvidia, tengo

~$ aptitude search ~ixserver-xorg-video
i xserver-xorg-video-fbdev - X.Org X server -- fbdev display driver
i xserver-xorg-video-nouveau - X.Org X server -- Nouveau display driver
i xserver-xorg-video-vesa - X.Org X server -- VESA display driver

fbdev y vesa que serían los "genéricos" y nouveau para la nvidia.
Por otro lado, para el error que muestras, es posible que te sirva crear el archivo /etc/modprobe.d/i915.conf con el contenido siguiente

options i915 modeset=1 semaphores=1 enable_rc6=7 enable_dc=2 enable_fbc=1 lvds_downclock=1

  No hay bar que por bien no venga....
Vie, 22/05/2020 - 18:34 (Responder a #5)
Vctrsnts
Imagen de Vctrsnts
Desconectado/a
se unió: 15/03/16

Muchas gracias,

Lo probare, porque yo tambien tengo un equipo con intel + nvidia.

Gracias de nuevo...

Vie, 29/05/2020 - 10:23
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

Vaya!, este es todo un clásico. El viejo pipe error del i915.
Yo tengo un portátil P4, que hace algunos años atrás ya me lo daba.
Estuve mirando muchas páginas y sitios que hablaban sobre ello. Pero al final no llegué
a ninguna solución práctica y clara. Parecia como que aún no habian encontrado como eliminarlo.
Y como que realmente, una vez dentro del escritorio, se veia y funcionaba bien,
terminé por dejarlo estar a pesar del aviso en cada arranque.

Es bueno saber que alguien encontró una posible solución.
Ese post me lo voy a guardar, -gracias-, y cuando esté con el portátil ese, a ver
si me inspiro y me pongo a comprobarlo.

Y ahora que lo nombrais, ... humm... Tiene instalados a jessie y creo que incluso a buster,
pero no recuerdo haber mirado a ver si aparecía ese error.
En cuanto pueda volver a acceder a el lo comprobaré, y caso de que no apareciese en alguno
de los dos lo comentaré aquí, para que consten algunos datos más sobre el fifo error ese.