no puedo actualizar postgresql en mi elementaryOS 5.1 (basado en ubuntu 18)

2 envíos / 0 nuevos
Último envío
#1 Mié, 24/08/2022 - 22:44
dapt
Imagen de dapt
Desconectado/a
se unió: 03/02/17

no puedo actualizar postgresql en mi elementaryOS 5.1 (basado en ubuntu 18)

Estado: 
[ABANDONADO]

saludos chicos  tengo un problema, tengo una laptop con elementaryOS 5.1 (basado en ubuntu 18) y no puedo actualizar postgresql de 10 la version 14

necesito hacer el upgrade por tema de estudios

 agregué via ppa el postgresql-14 con estos comandos:

sudo apt install curl ca-certificates gnupg
curl https://www.postgresql.org/media/keys/ACCC4CF8.asc | gpg --dearmor | sudo tee /etc/apt/trusted.gpg.d/apt.postgresql.org.gpg >/dev/null
sudo sh -c 'echo "deb http://apt.postgresql.org/pub/repos/apt/ jammy-pgdg main" >> /etc/apt/sources.list.d/postgresql.list'

y luego usé:

sudo apt install postgresql-14

y la terminal me devolvió: 

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 postgresql-14 : Depende: postgresql-client-14 pero no va a instalarse
                 Depende: libc6 (>= 2.34) pero 2.27-3ubuntu1.6 va a ser instalado
                 Depende: libgcc-s1 (>= 3.3.1) pero no es instalable
                 Depende: libicu70 (>= 70.1-1~) pero no es instalable
                 Depende: libldap-2.5-0 (>= 2.5.4) pero no es instalable
                 Depende: libpq5 (>= 14~~) pero 10.22-0ubuntu0.18.04.1 va a ser instalado
                 Depende: libselinux1 (>= 3.1~) pero 2.7-2build2 va a ser instalado
                 Depende: libssl3 (>= 3.0.0~~alpha1) pero no es instalable
                 Depende: libstdc++6 (>= 11) pero 8.4.0-1ubuntu1~18.04 va a ser instalado
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

ayudenme por favor cool

Vie, 26/08/2022 - 06:09
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Supongo que eso mejor en algun foro de Elementary... pero ya que estamos:

fijate bien en lo que estás haciendo.... Tienes Elementary 5.1, basado en Ubuntu 18 (Bionic), y estás metiendo un repo de Ubuntu 22 (jammy). Son cuatro versiones del sistema operativo de diferencia. Cambia jammy por bionic en el repositorios que has añadido, ejecuta apt update y luego instala lo que necesites y pista.

  No hay bar que por bien no venga....