No se reproduce CD-R de audio

6 envíos / 0 nuevos
Último envío
#1 Lun, 11/04/2016 - 16:34
cnicolas
Imagen de cnicolas
Desconectado/a
colaborador
se unió: 21/02/16

No se reproduce CD-R de audio

Estado: 
[ACTIVO]

Buenas a todos.

Me esta ocurriendo algo raro, tengo un CD-R que en un equipo de musica se lee perfectamente y se reproduce  con buena calidad de audio.

Sin embargo en debian estable  no logro reproducirlo, al automontarse tanto en Xfce como Kde lo interpreta como un CD en blanco y es incapaz de reproducirlo

 

Lun, 11/04/2016 - 18:16
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

pues con esa información pueden ser mil cosas, la verdad... Desde que tu lector empiece a fallar, hasta que no soporte ese tipo de cd... Por otro lado, un cd con archivos mp3 no es un cd de audio, es un cd de datos. Y, del mismo modo, un CD de audio no necesita ser montado para que el sistema no pueda reproducirlo (de hecho, la mayoría de software lo reproduce sin montarlo, ya que la estructura es muy diferente a la un cd de datos). Si te fijas, al introducir un cd de audio en cualquier sistema Windows y acceder al mismo desde el navegador, no verás los archivos con las "canciones" verás "Track01" que no es más que un acceso directo a los datos en realidad, es solo una forma de mostrarlo.

 

Para empezar, podría ayudar la salida de dmesg o journalctl del momento en que introduzcas el cd en tu equipo a ver que "hace" el sistema.

 

Como no hay que montar el cd para poder escucharlo, comprueba que tu reproductor apunta al dispositivo y no al punto de montaje (bastante software trabaja directamente con /dev/sr0 en lugar de /media/cdrom0, ya que éste último es el punto de montaje y se usa para los soportes de datos y no de audio).

 

Edit....

 

Releyendo veo "al automontarse..." y me da que por ahi va tu problema... como ya he dicho, un cd de audio no se monta para poder reproducirlo, se usa otro sistema de lectura. Prueba a desmontar desde consola tu mismo el cd en cuestión y a reproducirlo entonces con vlc o kscd mismo a ver que pasa.

  No hay bar que por bien no venga....
Mar, 12/04/2016 - 20:35
elpatosilva
Imagen de elpatosilva
Desconectado/a
moderador
se unió: 22/01/16

Pues no se si Panko no lo dijo ya (Soy una persona sumamente ocupada y no tengo tiempo de leer todo cheeky) pero un cd de audio (cdda) no se lee como un sistema de archivos que se monta, sino que se accede directamente al dispositivo. Si lo montas por lo general lo vas a ver como si hubiera enlaces dentro, pero que no apuntan a ningun lado.

La mayoria de los reproductores de audio lo soportan, en una opción aparte, algo como "Abrir CD de audio" o similar

 La democracia es el proceso que garantiza que no seamos gobernados mejor de lo que nos merecemos.

Mié, 13/04/2016 - 14:35 (Responder a #3)
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Confirmo. Si alguna vez has intentado montar un cd "puro" o comercial de música verás que te da error, no

acepta montarlo como un sistema de archivos.

El hecho de que te lo monte como sistema de archivos indica que no es totalmente cd-audio, sin prejuicio de

que pueda reconocer los archivos tu equipo de música.

 

 En lo demás suscribo lo dicho por Panko, desmóntalo y luego prueba con un soft reproductor de audio.

Y una pregunta, ¿cuando lo monta, bajo que sistema lo hace?. ( ISO 9660 para un cdrom)

Bueno, dos, ¿te lo hace con cualquier cd o solo con este?, (cd-audio se entiende)

 

 

Jue, 14/04/2016 - 02:51
cnicolas
Imagen de cnicolas
Desconectado/a
colaborador
se unió: 21/02/16

Si, teneis razón , no me explique bien del todo.

Es un cd de musica (en un Cd-R) que en un reproductor de musica se escucha sin problemas pero por alguna extraña razon el equipo reconoce solo como CD vacio sin ningun dato dentro. El Lector esta bien, al menos reproduce CD originales sin problema alguno.

He probado a desmontarlo e intentar reproducirlo desde vlc con abrir Cd de audio .

¿podria ser que el CD-R no estuviese finalizado?

 

Debian y GNU/Linux en el core informatico.

Jue, 14/04/2016 - 20:59
Panko
Imagen de Panko
Desconectado/a
moderador
se unió: 18/02/16

Comprueba que vlc apunta directamente a la unidad y no a otro dispositivo. Prueba primero con /dev/sr0 (o el que veas que es el tuyo) antes que con /dev/dvd o /dev/cdrom

~$ ls /dev |grep sr0
lrwxrwxrwx   1 root root             3 abr 14 22:42 cdrom -> sr0
lrwxrwxrwx   1 root root             3 abr 14 22:42 cdrw -> sr0
lrwxrwxrwx   1 root root             3 abr 14 22:42 dvd -> sr0
lrwxrwxrwx   1 root root             3 abr 14 22:42 dvdrw -> sr0
brw-rw----+  1 root cdrom      11,   0 abr 14 22:42 sr0

 

  No hay bar que por bien no venga....