Verion de openssl build en nginx

6 envíos / 0 nuevos
Último envío
#1 Vie, 05/04/2019 - 11:50
marce_lo283
Imagen de marce_lo283
Desconectado/a
se unió: 05/04/19

Verion de openssl build en nginx

Estado: 
[ACTIVO]

Hola como estan? Estoy necesitando ayuda con un tema que tengo en ngnix. Como mi debian 8 tenia una version de openssl antigua y no soportaba alpn sobre http2, realice la actualizacion a debian 9. Actualmente tengo la version nueva de openssl y ngnix, pero el server web sigue sin soportar alpn. Cuando en la info de ngnix, me muestra que esta con el build de openssl viejo. como hago para que la instalacion de ngnix desde debian se reconfigure con la version nueva de openssl?

De la version 8 a la nueva de debian pase con el apt-get dist-upgrade. Salio todo ok excepto esto.

Con sudo apt-get ya lo desinstale y lo instale y sigue con el build de openssl viejo.

Alguna sugerencia?.

GRacias.

Vie, 05/04/2019 - 13:17
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

intenta  desinstalar/purgar   nginx   y  reinstalarlo  ( hace una copia de los archivos de configuración para tener todo a mano )

Vie, 05/04/2019 - 15:12 (Responder a #2)
marce_lo283
Imagen de marce_lo283
Desconectado/a
se unió: 05/04/19

Con que comandos me recomiendas? pq ya lo he desinstalado e instalado nuevamente.

Vie, 05/04/2019 - 16:26
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16
apt-get purge nginx

Edito:No estoy diciendo que con purgar e instalar  funcione .es una opcion ,supuestamente en debian 9  deberia funcionar por defecto todo eso.

Vie, 05/04/2019 - 16:33 (Responder a #4)
marce_lo283
Imagen de marce_lo283
Desconectado/a
se unió: 05/04/19

ok, lo probe y se volvio a instalar con la version de openssl vieja. igualmente gracias. Ya busque bastante en internet y no encuentro como forzarlo a que se instale con la verion nueva que tengo de openssl y que se instalo por defecto con el debian 9.

Vie, 05/04/2019 - 16:38
caliban
Imagen de caliban
Desconectado/a
moderador
se unió: 14/01/16

Bien ,mas temprano estuve buscando info  en internet y encontre unas cuantas guías de como hacerlo funcionar en debian 9, en unos casos  instalando desde los repositorios de debian , en otros desde repositorios propios,,y finalmente compilando .

Si buscas vas a encontrar unas cuantas guías , lamentablemente ( y como siempre) en puto ingles , Es lo que hay