Tarda en apagar

6 envíos / 0 nuevos
Último envío
#1 Mié, 07/11/2018 - 15:05
aldo
Imagen de aldo
Desconectado/a
se unió: 26/03/17

Tarda en apagar

Estado: 
[SOLUCIONADO]

Buenos dias a todos, un saludo. Acontinuacion describo el detalle que me sucede con Debian 9.5 con escritorio xfce, en laptop Lenovo B570 con procesador Intel al igual que el chipset.

Todo trabaja muy bien, el detalle es que al apagar el equipo, tarda muchisimo. La primera vez que lo hizo, pense que no se habia terminado de apagar por algun detalle, solo presentaba pantalla negra. La apague desde el boton de encendido. Despues me percate que si estaba en proceso de apagado, por el recovery journal que aparece al iniciar nuevamente el debian cuando se apaga incorrectamente.

Asi que espere un buen tiempo y ya se apago. Tarda cerca de 40 seg a 50 aprox. Alguna Idea?

Saludos.

 

Mié, 07/11/2018 - 15:30
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Podría ser que estuviese esperando después de ir enviando la señal kill a todos los procesos.

 O también podría ser un problema de comunicación con alguna de la particiones. Ya sabes, si ha de verificarla y

 escribir en su log antes de desmontarla

¿Aparece alguna cosa rara en los registros de /var/log?.  En el arranque, al montar las particiones, alguna de que

te diga que no puede accederla fácilmente, o que al cerrar te diga que le ha vencido el tiempo de respuesta, o cosas así.

Mira también al cerrar, si puedes ver las marcas de tiempo en algún log, si hay algún paso que requiera más tiempo de lo normal.

Y como que está con la pantalla oscura, y no en modo texto puedes examinar también el log del servidor x,  a ver si es ahí.

 

 Aunque claro, el tiempo de cierre dependerá también de la cpu que tengas, si es actual o no.

 Yo con los mios, 40 seg. sería  lento, pero no alarmante.  - Aunque he de decir que cierran rápido.-

 

 

Jue, 08/11/2018 - 21:24
Panko
Imagen de Panko
Conectado
moderador
se unió: 18/02/16

Usualmente es culpa de algún proceso que tarda en acabar o no se cierra correctamente. Systemd otorga un "tiempo de gracia" a los procesos para que finalicen acabando estos al finalizar ese tiempo. También hay algunos que no pueden acabar, y si están usando el disco, debian no consigue acabar el proceso de apagado hasta que éstos acaban, te aseguro que puede tardar mucho más que lo que te tarda a tí.

Como te han dicho, habría que mirar el log durante el apagado,  pero si tienes instalado y usas plymouth, no lo ves mientras se realiza el proceso. Para ver el proceso de encendido o apagado, tienes que pulsar la tecla ESCape en el momento que aparece la pantalla de progreso del arranque o del apagado, lo que quieras ver.

Otra opción para poder ver el log, es usar el comando

journalctl -b -1 --no-pager

que te mostrará el log del aranque anterior, desde el incio hasta el apagado o reinicio. Desde ahí, buscas hacia arriba hasta que veas algo en color rojo, que te indicará que ha habido un fallo, o un salto de tiempo en las marcas del log. Algunos servicios, como unattended-upgrades, puede provocar ese comportamiento, pero hay otros que son exclusivos del usuario y no del sistema que también pueden provocar esos retrasos.

 

P.D.: Por  la cantidad de mensajes que tienes publicados, ya deberías haber echado un vistazo a las normas... y sin embargo veo que información del sistema das la justa...  como siempre, a adivinar toca.

  No hay bar que por bien no venga....
Lun, 12/11/2018 - 12:26
aldo
Imagen de aldo
Desconectado/a
se unió: 26/03/17

Ya quedo solucionado. En una actualizacion del debian 9.5, ya tambien tardaba en iniciar, cosa que no hacia.

Por ahi envie un tema sobre eso y se solucionaba instalando el haveged. Por la tardanza en iniciar lo instale y para sorpresa, tambien se soluciono lo del apagado del equipo.

Solo para completar la info del sistema que tengo y que no puse al inicio del post: Debian 9.5 + compiz + xfce (trabajando al 100%), chipset intel y procesador inte i3 (laptop Marca Lenovo). Lo comento porque podria pensarse que el compiz podria ocacionar esa situacion del apagado tardio.

Gracias por su ayuda. Saludos.

syb.

 

Mar, 13/11/2018 - 15:40
Percontator
Imagen de Percontator
Desconectado/a
colaborador
se unió: 20/03/16

 

 Haveged: "Demonio para una fuente de entropía en el espacio de usuario, que no depende de los mecanismos estándar para

 cosechar, (obtener), la aleatoriedad del pool de entropía del sistema".

 ¿Os habeis enterado de algo?.  laugh  En packages.debian.org  creen que si.

 Menos mal que la cabecera de  https://wiki.archlinux.org/index.php/Haveged   Es más explícita y clara, que si no...

 

 Ahora quedaría preguntar si es tan necesario reforzar la generación de números aleatorios como para incluirlo en una instalación estandar.

 ¿O tal vez te vino más tarde, al instalar una aplicación en concreto?

 

 Así entiendo que debía ser este paquete el que retardaba el apagado del sistema, y que al actualizar has obtenido una nueva versión

 que corrige el problema.

 Gracias por comentarlo.

 

Mié, 14/11/2018 - 09:08
Panko
Imagen de Panko
Conectado
moderador
se unió: 18/02/16

Yo instalé haveged cuando sddm empezó a  tardar mucho en  iniciar debido al cambio en la forma  en que el kernel toma esa entropía del hardware. Nunca me ha provocado un arranque más lento.

Posiblemente una actualización o algo haya solucionado el problema que tenía, ya que no  sabemos en realidad cual és.

De todas formas, si no  se quiere instalar haveged para solucionar el problema de inicio de sddm (aunque no es su caso), basta con teclear aleatoriamente cuando vaya a iniciar sddm y éste iniciará normalmente sin retrasos.

  No hay bar que por bien no venga....